Question about 1988 Mazda MX-6

2 Answers

My indicators and hazard lights aren't working. I have tried everything and its not a fuse problem.i have tried fixing things towards the battery and i have checked all engine fuses but it just wont work? also my alarm at the same time has gone haywire. i press the button and it beeps but the doors don't unlock.

Posted by on

  • mfbb Jul 08, 2010

    thanks dartman340. i just rewired a piss-poor effort that the alarm installers did.. and now its fixed.. just one issue left.. do you know how i would find out about my indicators?

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

HAZARD LIGHTS NOT WORKING
looking a possible solution to getting my hazard lights to work. I checked the fuse in the drivers panel and it is good. Everything else works i.e. turn siganls, lights, fog but not my hazards. Whats the problem?

Posted on Jun 18, 2011

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 977 Answers

The problem could be the blinker unit has failed,you will find it somewhere under the dash,it may be a square box or a round cylinder with a clear plastic body it will have a connector plug that plugs into it ....hope this helps....cheers

Posted on Jul 07, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The indicator lights are all stuck on. AU Ford station wagon. Removed relay, and all fuses, but still on. Disconnected battery and they turned off. Reconnected battery and they all came back on with no...


The AU ford has two indicator relays , turning lights and hazard lights ,both use the indicator lights ,the hazards flash both front and rear lights , the turning indicator flashes one front and one rear light. I think the fault may be in the hazard circuit.

Feb 25, 2015 | Ford Cars & Trucks

1 Answer

Hi wonderd if any one can help. i have a ford focus 2002 tddi estate the hazards arnt working but the indicaters are. i've changed the hazard switch for a new one and checked all the fuses in the


Look on the back of the fuse board ,for this you have to drop the fuse board as their are two fuses at the back and i know one is for the central locking ,the other ? Now when the hazard switch is disconnected the indicators shouldnt work but the only thing i can think of is the indicator unit is faulty ,do the hazards light the indicator lights up and they dont flash or is nothing happening?

Jan 24, 2013 | Ford Cars & Trucks

1 Answer

I have an 02 kia sportage. my signal lights come on but dont blink outside. no lights for the signal lights come on on the dash at all. also, no hazard lights.


If the 15A HAZARD fuse in the passenger compartment fuse box is OK, power is getting to the hazard function of the flasher unit. Pressing the hzard switch should cause the hazard lights to flash. HOWEVER, there is an electronic time and warning indication system module connected to to the hazard switch lead and that may be affecting things. If the 10A TURN fuse is OK, power is applied to the turn switch (with the engine in START or RUN) and you state you can select a right or left turn. HOWEVER, the RED/WHT and RED/BLU outputs from the flasher unit connect directly to the front and rear turn lamps and the instrument cluster turn indicators so you are not getting any flasher output. Again, that electronic time & warning indication system module could be affecting things

Oct 26, 2012 | Cars & Trucks

1 Answer

Indicators not working


TRY REPLACING THE FLASHER IT IS A ROUND SILVER TUBE LOOKING THING ON FUSE PANEL

Oct 08, 2012 | Cars & Trucks

1 Answer

My brake lights, turn signals and hazard lights aren't working.


There should also be another fuse panel on the interior located on the driver or passenger side foot panels or there about.

Sep 20, 2012 | 2002 GMC Safari

1 Answer

Hello . i bought a used 2001 saturn s series. everything was fine , the car doesnt nstart.the battery light is on the dash board p[lus "service engine soon and oil pressure light.i already changed...


First thing you need to inspect the battery.The battery warning light is coming,due to battery is low on charge or battery got weak.If the battery is low on charge then get it recharged.But if battery is very old,then get it replaced.The battery and turn signal problem are two different problems.
Turn signals not working are due to faulty hazard switch/Turn signal switch,or faulty flasher unit.But in some cases its due to faulty turn signal fuse located in the interior fuse panel.This possibilities needs to be checked.Keep updated for further help.Thanks.Helpmech.

Jan 05, 2012 | 2002 Saturn L-Series

1 Answer

I have a 1994 cutlass supreme and both the turn signals are flashing when they are engaged. We replaced the turn signal flasher underneath the dash, thinking that it might help and it did not. We also had...


Stop replacing things and turn off your hazard lights. If this doesn't fix you may have to replace your steering column turn signal switch. Youer hazard lights aren't working likely to a blown fuse.

Jun 16, 2011 | Oldsmobile Cutlass Supreme Cars & Trucks

1 Answer

I bought a 1995 truck and the brake lights aren't working I noticed ythat the hazzard light switch is busted up could that be the source of my problem


Check the fuses. And check for power at the taillights (These taillights have circuit boards on the back side that can go bad.) I don't think the hazard switch is it because the brakes would still work. Also check the brake pedal switch. There is a hazard flasher, does the hazards work?

Jun 06, 2011 | Chevrolet C1500 Cars & Trucks

1 Answer

My 1991 Honda Civic is not getting any power from the battery and we switched batteries and everything. When you turn the key it doesn't make any noise at all. The only thing that works right now is the...


Have you checked the fuse panel located under the hood? Hondas typically have several large amperage fuses in this fuse block that could cause the total power loss that you decribed. The hazard lights may be wired separately as a safety precaution (i.e.--not leaving you on the side of the road without hazard lights).

Feb 08, 2010 | 1991 Honda Civic

Not finding what you are looking for?
Cars & Trucks Logo

602 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8572 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...