Question about 1997 Subaru Legacy

1 Answer

Im having problems with my 97 legacy, i was told that my rear transmision mount may be broke,however i am also having problems with my speedometer not working and also my mileage gage is not working as well,im not sure how to go by diagonosing these problems can you assist me?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 200 Answers

It is possible that the vibration from a bad mount could cause the speedometer cable to come out or break causing this problem

Posted on Jul 07, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 92 GMC stepside and its lifted about 4.5 inches. I think its making my speedomiter be off. It says im going 50mph when i feel like im going 20mph. It also has a rebuilt motor and transmision....


If you have got taller tires on then what it came with from the factory it will definitly throw the speedometer off.You will need it to be recalibrated for a different speedometer gear put in the transmission.This will correct the odometer

May 04, 2011 | 1992 GMC Sierra

1 Answer

97 subaru legacy outback 2.5 vibration only at idle in gear


I would suspect a mount. Either motor or trans. Also check lateral mount on top of motor to firewall. Good luck and have a great day.

Feb 10, 2010 | 1997 Subaru Legacy

1 Answer

1995 Subaru Legacy. Speedometer stopped working


It's probably your speedo head, the gauge itself. I put several used ones in our car to no avail. When I finally went to the dealer they needed to know my cars serial numbers then sold me a gauge that matched my car. Sounds goofy but it worked! I didled with this problem for over a year on and off before that.

Nov 25, 2009 | 1995 Subaru Legacy

1 Answer

Transmision stays in 1st and speedometer doesnt work. Reverse is good. transmision problem and spedometer issues started at the same time today.


There is a speed sensor that has gone out on your car.This will need to be replaced to gain all gears in the transmission .It will be located in the transmission,mounted on the out side.You can change tis your self.

Oct 21, 2009 | 2000 Dodge Intrepid

2 Answers

Wheels making binding noises when turning


I have this same problem with my 1996 Subaru Legacy 2.2 Wagon. There is a Subaru Service Bulletin #16-62-97 dated 5/16/97 with a Subject entitled "Transfer Clutch Binding And/Or Bucking On Turns". There is also an important follow-up to it numbered 16-64-99 dated 09/15/99 entitled "Revised Transfer Clutch Assembly Replacement Procedures" that should also be used should you decide to go ahead with the transfer clutch replacement.

I just got these Service Bulletins from my mechanic who got them from a Subaru dealer.
The estimate was about $700-$1000 to fix. This is more than likely the cause of the binding problem on slow, sharp turns.

Dan Hunt
Danbury, CT

Aug 04, 2009 | 1996 Subaru Legacy

2 Answers

I have a problem with my subaru legacy bf it jerks


If it happens under load then it could be a coil pack . If not it may be a blocked fuel filter.

Jul 05, 2009 | 1999 Subaru Legacy

1 Answer

97 legacy gtb twinturbo. engine died within 1km dead!


Have you put the OBD scanner on it to find the problem. That would be a good place to start. the computer should have stored a code with the problem.

Jul 01, 2009 | 1997 Subaru Legacy

Not finding what you are looking for?
1997 Subaru Legacy Logo

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

76848 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Brandon Johnson
Brandon Johnson

Level 2 Expert

251 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...