Question about 1999 Subaru Forester

1 Answer

My car idles rough and a machine said the map sensor is running a little high.

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Subaru Master
  • 6,826 Answers

If the map sensor is running high, manifold absolute pressure, then I would try checking for a vacuum leak somewhere, or, change the map sensor and see what happens.

Also, check plugs and wires for age.

Posted on Jul 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I went to go get my car inspected and it wouldn't pass because of a code P0106. I want to explain how my car is acting when started especially when its cold out. The colder it is the worse it starts.


I'd be more inclined to the cold start side of things. Relay, cold start sensor. Water Temp sensor not activating the cold start setting.

The lights going dim could be something else completely

Feb 15, 2016 | Cars & Trucks

1 Answer

2005 Dodge Ram 1500 4.7 Engine. Starts fine, Idles fine, but when engine shifts into high gear and RPM lowers engine runs really rough under load


Have you checked for a broken valve spring. Repaired a dodge engine with the same running issue as you have described and it was a broken intake valve spring.

Feb 22, 2015 | 2005 Dodge Ram 1500

2 Answers

Why dose my truck turn off when I plug in my map Senior hose and when it unplug it idle high


That would mean its a bad map sensor ,when its unplugged it should throw a check engine which puts it in limp mode and ignores the sensor and then riches out the fuel mix to "protect"the motor which is why the rough idle.but is intended to get you home In a case where it goes bad ..new map will fix it up

Feb 17, 2015 | Cars & Trucks

1 Answer

96 eclipse non-turbo idles way too high, disconnect MAP sensor it goes down but then idles rough


Yes by disconneting the map sensor will drop idle and make run rough, the problem is the idle air control valve or a vacuum leak, try to clean the throtlebody with an old tooth brush and some throtlebody spray cleaner if that doesnt help then try having the iac valve checked the iac valve (Idle air control valve ) if with the engine running listen for a hissing noise that will be a vacuum leak, these are the most common reasons for higher than normal idle. hope this is helpful.

Dec 05, 2010 | 1996 Mitsubishi Eclipse

1 Answer

1991 302 runs like it is chocking out, I have changed the fuel filter, plugs wires rotor cap, and map censor, runs rough and worse when in gear, eating gas..help please? The truck is a 1991 f150 NITE 4x4


is it idling high and you put it i gear it runs rougher and smoke black check your coolant sensor also connection or sensor itself and fuel pressure if high check for return line blockage also vacuum leaks make sure you have the right vacuum going to your map sensor you need to check right vaccum at idle going to your map sensor/

Jan 19, 2010 | 1991 Ford F150

2 Answers

Wife's durango is idling rough and running rough


With both codes pointing at TP sensor, I'd certainly take the time to replace it, as well as make sure connections to it are clean, and good. Chances are, you won't be able to take part back anyway. As far as exhaust goes, if it's leaking in the right places in may cause improper readings at sensors downstream, but if not obvious leak, I wouldn't be concentrating in that area right now.

Nov 01, 2009 | 2004 Dodge Durango

1 Answer

1988 Ford Crown Vic Strange Idle


When you turn the key on does the check engine light come on? If not it may be burned out. It sounds like a MAP sensor or an O2 sensor is bad. I would suggest taking it to autozone as they do free diagnostic and seeing if a code comes up. If it is a sensor it should, if not it may be the idle sensor not reading right in the ECU. More than likely it is one of the sensors though.

Jun 23, 2009 | 1998 Ford Crown Victoria

2 Answers

Rough running and rough idle


here is a diagram of the map sensor #5.

2009-10-07_190044_3.gif

Nov 25, 2008 | 2000 Chevrolet Tahoe

Not finding what you are looking for?
1999 Subaru Forester Logo

Related Topics:

457 people viewed this question

Ask a Question

Usually answered in minutes!

Top Subaru Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you a Subaru Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...