Question about 2004 Mercury Grand Marquis

1 Answer

Ac fan stoped working all of sudden the other day I hav checked the fuses and the relays. and when I turn the fan on high I hear a click what do you think the problem is?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercury Master
  • 6,826 Answers

Look to see if the ac compressor is turning,look at the center of the pulley on the compressor,if it is turning,it could be a stopped up orifice tube,if it is not turning,check the freon,make sure you have not got a leak.

Posted on Jul 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

05 land rover freelander. When turn on ac, high speed fan will not turn.replace the engine coolant temperature sensor. I unplug the switch of the fan and jumped it to the battery high speed came on.


Check the fuses first, swap relays. If that doesn't work. Takes a scanner to see what is not working. If the PCM is getting the signal, then look to the wiring to the fuse panel, to the relays. Cold be the relay/fuse panel.

Sep 29, 2016 | Land Rover Cars & Trucks

1 Answer

2005 equinox ac fan only works at low speed. I just had it flushed and coolant added last year


There are two relays for the fans. One is a low speed relay and the other is a high speed relay. There are also fuses for the fans high speed and low. Take the cover off or the under hood fuse box and on the inside of the cover it will give a diagram of the fuses and relays. Try swapping the relays with something else and see if the fans go to high when you turn on the A/C as it always should. Sound like a bad High Speed Fan Relay to me but check it out.

Jul 21, 2011 | Chevrolet Equinox Cars & Trucks

1 Answer

Radiator fan not operating could be fuse don't know how to change 1994 lancer


Look in your manual for fuse diagram LOOK FOR A RELAY, put a "RF" on top of the "Radiator Fan relay and find another with same part number. in the fuse compartment. ie Air Cond. put an "A C" on that one, switch them out and get engine HOT to see if fan works, turn AC on too if it works the relays are both good. next things to check [a] "Temperature switch" on block, or [b] corroded wire terminal at firewall connections [c] the fan motor could be bad ...... that Radiator fan operate TWO ways. (1) a hot engine (2) turn the AC on high will also turn it on. Check this first before U get your hands greasy.

Mar 20, 2011 | Mitsubishi Lancer Cars & Trucks

1 Answer

Air conditioning works when car first starts up (Volvo s40) then stops cooling after a while (usually when I am stopped in traffic) -- then if I turn it off and back on after a few minutes it works again....


It sounds like your cooling fans are not working.Need to check the cooling fan fuses,and the cooling fan relays.There is also a high side switch mounted somewhere on the high side of the ac system that cuts the fans on,or kicks them up on high speed when the ac system gets to high on the high side of the system.This switch may also cut the compressor off.I would check the fuses and relays for these fans first,this is more likely the problem.Is the car running normal temperature? If not the fans may not be running at all.Have them checked.The fan or fans may be bad them selfs.If I can be any more help,let me know.>>roniecon@gmail.com

Aug 19, 2009 | 2005 Volvo S40

2 Answers

My car runs hot and leaks antifreeze


if it's coming from the radiator cap your car is overheating,two things could be wrong
#1 thermostat is stack and is not circulating or
#2 that your actuator switch is not engaging the
fan

May 29, 2009 | 2000 Chrysler LHS

1 Answer

1997 toyata tacoma AC suddenly stoped working


Not sure where the realy is, but there should be a 30 amp fuse in your fuse box. Did you check that?

May 25, 2009 | 1987 Toyota Supra

2 Answers

The heater quit working and the panel wont light up on a 1992 Chevrolet pickup


check the "blower motor fuse" "heater fuse" and ac fuse and relay. these will be located under the dash on the drivers side usually mounted near the foot rest next to the door AND under the hood along the fender on the passenger side.

Jan 08, 2009 | Chevrolet 1500 Cars & Trucks

1 Answer

1997 mercury marquis ac & blower


you could have. Take a look and find out. If the lid/cover of the fusebox does not name the fuses and relay's check owners manual, find the fuse(s) and/or relay and check it out.

Relay can be tested in a few ways,

first, easiest way get a buddy to go in the vehicle and switch your AC on and off, find the relay and get in real close and listen and feel for the relay clicking as he turns it on and off, if the relay is clicking it is most likely working fine.

if you are unsure on relay working you can try this method: theres usually 2 switches one is normally closed one normally open. Using a multimeter and the electrical diagram that should be on the side of the relay itself you should be able to figure out which switch is normally open and which is normally closed. Look carefully sometimes the writing, labels and numbers are hard to see.


Another possible cause is that your temp sensor failed so the computer thinks its -40 degrees and therefor won't run the fan. check the temperature sensor wiring, and the sensor itself after you look at fuses and relay operation.

Hope this helps :)

Sep 04, 2008 | 1999 Mercury Grand Marquis

Not finding what you are looking for?
2004 Mercury Grand Marquis Logo

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

fordexpert

Level 3 Expert

5467 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...