Question about 2003 Jeep Grand Cherokee

1 Answer

Loss of engine power after warm up. engine runs, sounds ok but has loss of power when accelerating.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 518 Answers

Fuel starviation,,check fuel filter,, fuel fump working okay, dirty fuel, =water/sediment from tank

Posted on Jul 05, 2010

Testimonial: "found out cat converter was plugged up. cut off clean out & weld back. plenty of power now!"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On a 92 Chevrolet s10 c/k 4.3litre TBI fuel injection pickup,,what can be causing loss of power wenpressing on gas? Otherwise,it run great.


Chevy S10 - GMC S15 and Sonoma Stalling/Dying Problems - Car ...

forums.edmunds.com > Chevrolet > Chevrolet S-10
Dec 15, 2007 - 30 posts - ‎22 authors please someone..i need help.i have 1992 gmc sonoma 4.3 6 cyl 2wd .... I have a 2001chevy s10 4.3 4wd auto, it runs good until it's warmed up, then once it's ... the gas pedal causes bouncing on the tachometer and loss of power. ... when driving at a steady speed if I try to accelerate the engine tries to die

Sep 24, 2015 | Chevrolet Cars & Trucks

2 Answers

1990 Buick Silouete loses power when accelerating, as engine warms it gets worse. Changed filter and had gas tank cleaned out recently did not solve the problem. It drives ok at normal speeds, it spudders...


You are a 1990 Oldsmobile sihouette with a 3.1 these vehicle are speed density in other word you are equipt with a MAP (manifold air pressure) when this sensor fails you loose the ability to accelerate or hesitate as you accelerate make sure the vacuum hose is connected to it and it is no leaking vacuum if the hose is okay and it is electrically connected correctly your fix is to replace the MAP sensor

Aug 05, 2011 | 1990 Oldsmobile Silhouette

1 Answer

Power (acceleration) loss at mid-high RPM only


Loss of acceleration, the backpressure noise and such are kinda tell tale signs of that converter having problems, feel the exhaust out of the tailpipe it will be warm normally have someone step on the gas and if its super hot it'd be a step in the right direction.

Jul 23, 2010 | 1991 Buick LeSabre

1 Answer

Hard Acceleration causes power loss. Vehicle


Download this link and find your Service manual for your vehicle. It will serve you well and to keep for future reference

http://ezinearticles.com/?Find-the-Free-Auto-Repair-Manual-You-Need-Online&id=92717

May 02, 2010 | 2005 Ford Crown Victoria

1 Answer

Loss of power on acceleration. engine bucking.


check transmission fluid.change fuel filter and air filter.try changing up on where you buy gas .because bad gas causes problems.

Jun 26, 2009 | 1999 Ford Taurus

1 Answer

Check engine light and power loss


Air flow meter sounds like your problem.

May 27, 2009 | 2001 Audi A4

2 Answers

Power Loss


hay I had the same issue it heated up quick and got too hot, the problem is that the thermostat can wear out and restrict the circulation of the coolant. an easy fix just get the bugger taken out no need to replace it and it will run just fine

May 11, 2009 | 1986 Honda Civic

2 Answers

2001 Hyundai XG-300 witn 86,000 miles. Bought used wholesale from a Honda dealer in Knoxville, Tn. summer of 2008. Engine was running with perfect idle & excellent acceleration, until you pushed the...


i have run into this before. the mass air flow sensor is contaminaited take it out clean it with parts cleaner on the element first if this doe not fix it replace it. thank you

Jan 25, 2009 | 2001 Hyundai XG300

Not finding what you are looking for?
2003 Jeep Grand Cherokee Logo

Related Topics:

331 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...