Question about 1997 Ford Expedition

1 Answer

1997 Ford Expidition - driving down the road about 55, when the engine lost power. It would only go about 35 and felt that it was being very restrictive with the power, felt like being held back. Also, the temp guage shot to overheating and the oil and temp lights came on. Radiator a little low, noithing new and oil ok. 142,000 miles. The engine had been on a while, saying it was running lean, but no concerns there. Also, had some problems with PVC valve vacuum leak, but that was fixed.Thanx.

Posted by on

  • Ned  White
    Ned White Jul 05, 2010

    It sounds like the alternator belt broke. The dash lit up, lost power, battery died. etc, etc. If not, the transmission went into limp mode, just enough power to get you home before destroying the tranny. And if that is not it, It could be a number of things, computer could have died, but I'll throw them out there for starters. Check it out. I'll leave this open for others to work on.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 541 Answers

Change air filter and see if the code comes back after resetting the computer. to reset, disconnect positive cable from battery for 5 minutes then reconnect or use the erase option on some OBDII code reader. if that fails to resolve the problem, test your sensors (tps, maf, mcs, map... etc.) and replace the ones that don't pass

Posted on Jul 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 Chevrolet Colorado transmission problem


sounds like the torque converter has failed

Nov 02, 2016 | 2005 Chevrolet Colorado

1 Answer

Why won't my 1997 ford expidition Start it's turning over but won't start my fuze is blown on the interior fuze box it's the last row over to the right and the 9th one down


CAN YOU REPLACE THE FUSE? AND START AGAIN. IF NOT TAKE OUT ONE SPARK-PLUG LAY ON THE ENGINE BLLOCK STILL CONNECT TO ITS WIRE; ACTIVATE THE STARTER WHILE CHECKING FOR SPARKS ON THE PLUG. nO SPARK, NO POWER.

Jun 19, 2015 | 1997 Ford Expedition

1 Answer

Dropped power smoke from motor and tail pipe wont start


if i was hazarding a guess ........i would say
HEAD

Mar 29, 2014 | Ford Escort Cars & Trucks

1 Answer

I have a 1997 pontiac bonneville and on long trips the engine seems to miss and the rpm guage stutters. I hope im explaining this right.


Have your closest AutoZone perform a free diagnostic scan because this sounds like a defective mass air flow sensor. If it quits for good, the vehicle will either not start or only run for four to five minutes and leave you stranded.

May 08, 2012 | 1997 Pontiac Bonneville

1 Answer

How do i do the drive cycle on a 1997 nissan pathfinder


The following drive cycle can be used as a guide to assist with re-setting monitors when a vehicle specific drive cycle cannot be located. This OBDII drive cycle begins with a cold start (coolant temperature below 122 degrees F and the coolant and air temperature sensors within 11 degrees of one another). This condition can be achieved by allowing the vehicle to "sit" overnight, and then by beginning the drive cycle the next day. Most drive cycles will be difficult to follow exactly under normal driving conditions, so the driver should exercise caution, road safety, and courtesy to others.
  1. . Start the engine. Idle the engine in drive for two and a half minutes with the A/C and rear defroster on.
  2. Turn the A/C and rear defrost off, and accelerate to 55 mph at half throttle.
  3. Hold at a steady speed of 55 mph for three minutes.
  4. Decelerate (coast down) to 20 mph without braking or depressing the clutch.
  5. Accelerate back to 55 to 60 mph at ¾ throttle.
  6. Hold at a steady speed of 55 to 60 mph for five minutes.
  7. Decelerate (coast down) to a stop without braking.

Sep 17, 2010 | 1997 Nissan Pathfinder

1 Answer

I was driving down the road and all of the sudden it lost power. I pushed the gas and nothing. I pulled to the side of the road and it died. When I try to restart it, it cranks but doesn't turn over. I...


Ignition Control Module is bad. When the dielectric grease used to mount them gets hard,they overheat and cause you to shut down. Really easy to install(about 10 mins.). I had this happen on two Fords. If you let the engine sit and cool down,they will fire up and run till that part gets hot,then itll die on ya. Auto zone sells this part for around 35 bucks.

Apr 30, 2010 | 2002 Ford Mustang

1 Answer

I have a 1997 ford expedition and today when i started it I had oil pressure then I drove down the road and lost all pressure and engine started to tick, I turned the engine off and then back on and The...


Sounds like the oil pump is going out. I would not drive it until you find out for sure. The ticking is oil not reaching the valves and rockers.

Jan 04, 2010 | 1998 Ford Expedition

1 Answer

My dodge runs strange if im i drive less then 35 40.then today the car shut off while drivin down the road i put it in neuatral to restart it??


I WOULD CHECK FUEL PRESSURE.IT SHOULD BE 55 PSI FOR THE 3.3 ENGINE.48 PSI FOR THE 3.5 ENGINE.THIS TEST YOU HAVE TO DISCONNECT VACUUM HOSE FROM FUEL PRESSURE REGULATOR.IF FUEL PRESSURE IS LOW.REPLACE FUEL FILTER.IF STILL LOW REPLACE FUEL PUMP.

Aug 25, 2009 | 1997 Dodge Intrepid

1 Answer

1997 Monte Carlo when driving 55-60 motor drops down to 34-40mph


A RESTRICTED FUEL FILTER WILL PROHIBIT PROPER FUEL DELIVERY....CHECK THE FUEL FILTER OR POSSIBLE A WEAK FUEL PUMP...THE ENGINE MAY BE STARVING FOR FUEL AT HIGHER FUEL DEMANDS

Jan 13, 2009 | 1997 Chevrolet Monte Carlo

Not finding what you are looking for?
1997 Ford Expedition Logo

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5522 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...