Question about Cars & Trucks

1 Answer

Had my pickup in to the dealership last week after driving it for two weeks and of course nothing wrong during that time. They did replace the mass airflow sensor since the computer showed the code for that. They also flushed the injectors as well but wanted to replace one so had appt. For this morning for that. Meanwhile Saturday morning go to leave home and same issue again depress the accelerator and it will go but only about 20 mph. Pull over to the side of the road and my husband and mechanic friend are with me and mechanic says to shut it off and reset the computer. Okay let it sit for a minute restart and same thing rev up the engine and white smoke is pouring out the exhaust which I think indicates an injector problem which is already scheduled to be fixed. It took 5 minutes of sitting there periodically revving up the engine and the white smoke smelled like fuel if that makes sense. After it "blew all the white smoke out" it ran awesome and I pulled my trailer with it yesterday and it pulled

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 541 Answers

Check throttle position sensor

Posted on Jul 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck won't start


If by your description I'm assuming you say "NO START" you mean it cranks but don't start..? Depending on the YR, make & model Poss. defective module? or switch itself, pickup (if app) Wrong plugs, mass air flow sensor (if app) Any C/E LTS? Scan PCM , also ck coolant system readings & ck emissions when running., crank & cam sensors are popular for that problem along with the module and pickup coil too. It's Long list but I would start with a scan of the PCM & check those crank & cam sensors 1st. Good Luck

Nov 26, 2015 | Cars & Trucks

1 Answer

Ck engine light on again..


Have your dealer look up this service bulletin.
NUMBER: 18-037-11
GROUP: Vehicle Performance
DATE: August 02, 2011
It states your PCM needs reprogrammed with the error code you are receiving P06DE. Was a pretty common problem back then.

Mar 24, 2015 | 2011 Dodge Avenger Heat

1 Answer

Why should my 2.7tdi terrano get through 4 glow plugs in one week?


Yeah, I agree that the relay is probably working...but my thought is that the only way you can burn out 4 glow plugs in a week is if the signal going to the relay is screwed up, and the glow plugs are on until they burn out... Did you have a battery problem during that week? Need to recharge or replace it? That could be a clue.... Or if you went on long journeys during that time where the alternator managed to compensate for the drain.....

Feb 17, 2015 | 2005 Nissan Terrano 2.7

1 Answer

I'm still having problems with my heater not blowing in my 2000 Saturn LW2 (L300). I've taken it to an elecrical specialist 4 times now and they can't seem to find what's wrong. The blower motor resistor...


Did you try to change the blower motor if you havent done that i would do that but according to me its sounds like a blower motor blow out good luck

Jan 04, 2011 | 2000 Saturn LW

1 Answer

2003 mazda mpv stalls several times while driving, all dash lights come on, need to coast to a stop, problem occurred once a week for three weeks and then happened three times within a mile, re-started...


i would ask the mechanic to check the ignition switch for pitting ....i had this problem with my honda accord for a long time until i finally just switched it for the second time and sanded it down to the point that it would touch but not keep contact to make the pitting .... hope this helped

Oct 29, 2009 | 1990 Mazda MPV

1 Answer

I have a 1995 maxima with hickup or hesitation


Try replacing spark plug wires. Probably one grounding out sometimes.

May 26, 2009 | 1995 Nissan Maxima

1 Answer

1999 Pontiac Grand Prix intermittent problem runs rough


i have had two of these problems both on grand prix's , both turned out to be a mass air flow meter. but nethier set a code for the sensor.

Mar 29, 2009 | 1999 Pontiac Grand Prix

1 Answer

All Accessories will quit working while driving 2002 Chevy Z71


Hello;
It sounds as if the main power lead could be loose powering the dash. There are several main power blocks, make sure your connections are clean and tight. I have seen the circuit board for the dash fail but not often. Hope this helps.
Thanks;
Rich
RPM Northwest

Jan 27, 2009 | 2002 Chevrolet Silverado

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

255 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...