Question about 1999 Mercedes-Benz C-Class

1 Answer

99 c180 will crank but not start. have replace ecu unit,replace crank and cam sensors, engine not getting any spark.

Posted by on

  • lisamarie_tu Jul 04, 2010

    already replaced coil pack,any other ideas please.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mercedes-Benz Master
  • 6,826 Answers

Try changing the coil or coil pack if so equipped.

Posted on Jul 04, 2010

  • Duane Wong
    Duane Wong Jul 04, 2010

    Try having the vehicle diagnosed by an auto electric shop that can trace wiring problems between the sensors and the ecu and the coil.



    Putting parts on can be more expensive than the labor at an auto electric shop in your area that can pinpoint the problem more accurately.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Nissan x trail.. Engine wont fire up or runs.. Scan tools had no fault code , try removed the connector of cam sensors and try to start the engine fault code appear on cam sensors fault or no communication...


Sounds like similar problem I had with a 2004 Altima 2.5. Crank but no start. Ended up being a timing chain stretched out and tensioner pinching chain against case not allowing variable timing to work and throwing off cam and crank sensor signals.

Mar 22, 2015 | Nissan XTrail Cars & Trucks

1 Answer

Why does my 1993 geo prizm have no spark or fuel?


old cars.... (old OBD1 , i know well)

skipping the 60k mile tuneup is 99% here. nobody tunes old cars they drive them to death. (stats facts)

there can not be fuel, if no spark, the ECU does detect no spark (most times) and then cuts fuel (to you dont crash and burn as seen on TV)

that is a fact.

so its just spark. and this engine unstated Toyota engine.

has EFI

and as such, the ECU, (EFI brain) makes spark.



the ECU listens to the crank (CKP) and CAM (cmp) sensors

and then fires the IGNITIOR (coil driver)

the ECU will puke DTC errors if CMP or CMP fails.

we see that cranking with the the Diagnostic TE1 jumper in place

the ECU can report dead spark to with its own DTC error codes.



here is my list for old funky engines.

1: compressing at 150PSI + , no ? its 80 the cam belt slipped or is snapped, if snapped the distributor rotor stalls

2: spark good times 4?

4: ok compression at spec, and spark good 4by4.

5: test fuel work ? now? runs for 3sec?

yes, runs and stalls, that is called fuel loss.

no, it must be flooding did you do the spark tip checks for flooding



see this link then go to toyota nation and learn the TE1 jumper

method of testing.

put in a 10cent jumper wire, and crank for 5 seconds , release

key, see flash codes ,bingo ? this works on all OBD1 cars made.



link

http://www.fixkick.com/PRIZM.html



go to toyota nation.

Jul 01, 2014 | 1993 Geo Prizm

1 Answer

Autoshutdown keeps turning on


which engine???????????????????????????
ASD is tricky on jeeps.
The Auto shutdown,relay.
what is it , how does it works is covered in the fsm. read it.
http://www.jeep4x4center.com/knowledge-base/index.htm?utm_source=cj#service
The ECU runs this RELAY, and if the ECU sees a gross error
it shuts this down, and the schematic there is clear as to what.
both spark and fueling.
here is what can drop it out.
1: crank sensor.
2: cam sensors or TDC ,etc.
3: sees spark dead or weak.
4: Immobilizer active. (failed)

as the book says , make sure spark is good for the 2 seconds cranking. (not after the 2seconds)
the ECU is programmed like this.
user cranks.
ECU creates spark,, using the crank/cam sensors at the time base
for 2 seconds
if the spark read back fails or the 2 sensors fail, the ecu shuts DOWN.
this is for fire prevention.
most other cars just cut the injectors, but not jeep
the drop the MAIN ASD relay.

using the check engine light flash codes, you can see which of the
3 failed, cranking for 5 second and releasing the key on all cars.
1996 and newer a scan tool is use to same effects.

now the 64,000 dollar qustion,
see page 8w-30-4
why does the ASD KILL THE IGNITION coil. easy.
1: it only guess it 2 seconds to make spark
2: if it cant,. it then drops the relay. killing fuel too.
3: this prevents the the crash and burn you see on TV.

so its 2 second permissive system. (or 3?) i forget exact seconds, its in then book and is short.
many dont know this. but is a fact.


now the flash codes.
crank for 5 seconds while in flash code mode
see emmisions page for how.

flash code 11 drops the ASD ! (cam or crank sensor dead)
code 54 cam signal dead?
code 43, spark bad.

Mar 02, 2014 | 1993 Jeep Grand Cherokee

2 Answers

1990 nisan n13 motor 1.6, has no spark to coil i drove car to train station, when i got back the car would not start, replaced coil, distributor, ecu box, all fuesible links, plugs & plug leads, fuel...


Your car has both a crank and cam position sensor. First start with your crankshaft position sensor. It is located by the harmonic balancer on the front of the motor.

Nov 28, 2013 | 1990 Nissan Pulsar

1 Answer

I have a 99 nissan pathfinder that won't start, it has spark and fuel. I even sprayed starting fluid and still won't start, replaced the distributor, same problem. does the crank sensor has to do...


well it takes four things for an engine to start,air, fuel ,ignition and proper timing of ignition and valvetrain . if you have spark then i presume the cams are turning , fuel injection is control by the ecm based on crank and cam inputs ( if applicable been awhile since seen a 99 nissan )
if you have spark then can assume the ecm is getting a crank sensor pulse , that leaves valve timing . any codes? check light on ?
did it die suddenly or just not start one day ? i would be app to check timing belt first make sure its lined up correctly . even if fuel injs were inop it should still start on staring fluid indicating a fuel problem, i would do a compression check also if the belt jumped it may have bent some valves if its interference engine but i dont remember, and make sure its getting air through the air intake

Apr 09, 2011 | 1999 Nissan Pathfinder

2 Answers

Swapped a 1999 420A engine into a 1995 eclipse (also a 420A) and we have no spark. We started by checking the cam sensor and it is working properly it is upside down from the 95 but the ASD relay is...


first the cam sensor shouldn't be upside down from the 95. they both should be with the plug facing down. they 95 CAS has a different plug than the 99 CAS.
the 95 has round pins and the 99 has flat pins.

95-96
9f942a5.jpg
--------------------
97-99
ad9a342.jpg
-----------------------------
also the 95-96 relays are opposite the 97-99

95-96
db7e0e0.jpg
------------------------
97-99
c98327d.jpg
---------------------
besides that it could be the ecu. i also have heard of the locating pin on the intake cam shearing off, allowing the gear to turn with the timing belt without the actual camshaft spinning.

Sep 27, 2010 | 1996 Mitsubishi Eclipse

1 Answer

Car wont start


being 94' im sure it has high miles, cam and crank sensor common to fail over time do to wear and heat exposure. check the basic, make sure you getting fuel and sparks. fuel pump only work as long the engine is turning over due to the crank sensor sense the flywheel turning. crank sensor may be faulty. no sparks, check coil make sure is good and putting out 12v, auto zone can test it for free. good coil, than check cam sensor, cam sensor senses the cam turning and tell the ecu to tell the coil to disperse the sparks to the plugs. cam and crank sensors, there no way of testing it but replacing the unit unless you have the special equipment to test it; both is fairly cheap to replace, check ebay.

Oct 24, 2009 | 1994 Mazda MX-6

1 Answer

'99 Saturn SC1 with intermittant check engine light P0341


a p0341 code mean cam reference performance, really it means you have a secondary ignition problem,,,,like a bad ignition module
a bad crank sensor
a high resistance spark plugs,do not use bosch platinum plugs in these cars
high resistance spark plug wires,,,i work at the dealer and the first thing we do is replace the spark plugs and wires if that dont work we replace the crank sensor,if thatdont work we reaplce the ignition mondule,and by then your fixed and you started with the cheapest items first,,,i would try plugs and wires and a crank sensor,,,,wires $50 plugs $14 crank sensor $37

Oct 23, 2009 | 1993 Saturn SC1

Not finding what you are looking for?
1999 Mercedes-Benz C-Class Logo

Related Topics:

181 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

74945 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...