Question about 1993 Chevrolet S-10 Blazer

1 Answer

I have a 1993 s10 blazer and it will run ok at idle but when i touch the gas it dies and wont start for a long time when i crank it over i can smell gas like it is flooding i am thinking it might be my fuel regulator might be stuck

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 541 Answers

Tps throttle position sensor to test first

Posted on Jul 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 GMC Sierra 1500 4.3L V6 will turn over but won't crank


could be faulty egr valve, faulty idle speed control, faulty engine coolant temperature sensor.stuck open pvc valve, i would have vechicle code scan first before buying new parts.meant to tell GMC SIERRA -C1500 AND C2500 CAN BE A 4.3 ENGINE OR A 5.0 5.7 6.2 AND 6.5 DIESEL ENGINE.

Feb 12, 2012 | Cars & Trucks

1 Answer

99' S10 4.3L starts a bit hard. Idles ok in P,R,N, but in D it has zero power and sputters and dies. Sometimes has a hard time running in P, but if left idleing for 5 min. it settles down and idles...


okay well here a few things u should sound to me like your timing is off those motors had a crank shaft sensor in the timing chain cover and cam shaft under the cap did u replace those ??? if u did check the rotor plate because those can turn to had to replace mine whole distributor because it was f up and yup u can find those at the auto parts mine was 107.00 out the door

Jun 20, 2011 | 1999 Chevrolet Blazer

3 Answers

Got a 92 s10 blazer 4.3L vin w. Cant seem to find a diagnostic machine that can read a vehicle this old. It has always had a slight miss and recently developed a problem with dieing while in drive at an...


this old its so simple .it has a ignition module and a crank sensor ,with a distributor so it can only be a crank sensor or the ignition module causing problems ,what about a cracked distributor cap ,dodgy rotor arm of the carbon brush in the cap??Thank your stars you dont repair europeon cars ,read a OBDII hahah i stand more chance of going to the moon

Aug 04, 2010 | 1992 Chevrolet S-10 Blazer

1 Answer

My 1989 s10 blazer wont idle


Check for plugged ctalitic converter

Jul 23, 2010 | 1989 Chevrolet S-10 Blazer

2 Answers

1993 s10 4.3 starts fine, while idling it dies. sometimes i have a hard time restarting. the blazer died a couple of times while driving.fuel pump is good, tuned up, remanuf. injectors 1 yr ago,engine lite...


only half way there if you have a tbi check the crank sensor/ cam sensor that is the first line of business on that truck if the crankshaft sensor fails the truck stops dead when you wait a few minutes the sensor re energizes and the truck will work again for a bit antiknock can cause similer problems but not while the truck is running

Feb 24, 2010 | 1993 Chevrolet S-10 Blazer

1 Answer

93 s10 blazer wont start until after about 20 minute trying


does it make any difference if the engine is cold or warm ? if when its warm and it starts ok your spider part is not working properly or not plugged in right check it again .. check it by using starting fluid if it starts ok its the spider part bad .. did you replace it with new ? holler if you need more Jerry

May 12, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

Fuel delivery s10 blazer


Did you change the fuel filter?

Mar 25, 2009 | 2000 Chevrolet Blazer

2 Answers

1993 5.7 l , TBI, Blazer, no start


check fuel pump for faulty ground.i had same problem and thats what it was,ground was loose,it was some times go and some times stall then quit till i had it towed and new ground put properly on

Mar 02, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

1989 s10 blazer will not idle


check timing with timing light , sounds like its out of time , and make sure that the timing marks are not off by one tooth

Dec 03, 2008 | 1991 Chevrolet S-10 Blazer

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

224 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...