Question about 2007 Fiat 124

1 Answer

Have a 94 Punto 55s. Starts and runs well but occasionally doesn't accelerate properly as if it is running out of fuel despite having half a tank. Could it be a problem with injectors, pump? Or gunk in the system. Was thinking of using redseal when I nx fill up to see if it makes any difference

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 45 Answers

I hear never heard of redseal. I do know that Sea Foam at Wal-Mart is the best fuel additive for cleaning out injectors. It is under 10 dollars.

Posted on Jul 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine cut out


Sounds like you may have fuel filter problem. you may want to check the pump and filters located in or near the fuel tank.
Go directly to the source ( Fuel Tank, Pump, Filters, Fuel Pressure Regulator and Injectors )
You may have water or grit in the fuel
Hope this helps

Mar 22, 2014 | GMC Sonoma Cars & Trucks

1 Answer

1989 ford f-250 dual tank problems


sounds like a problem with the switching valve under the truck, not the one on the dash, the first i would check that all hose clamps are tight

Jan 18, 2013 | 1989 Ford F 250

1 Answer

My fiat punto loses power when driving uphill


I have a 98 punto sporting nd today it started running like it was misfiring but wen i accelerate slow its fine but wen u accelerate as normal it spits and splutters :'( any suggestions??i have change fuel filter nd injectors ????

Sep 22, 2012 | 2005 Fiat Punto 1.2

1 Answer

After my 94 plymouth voyager 3.0L gets to runnig temp it misfires and stalls once in gear.It runs fine when its cold. I did a tune-up and still have the same problem


Have fuel pressure checked when it starts to misfire/stall and driving down the road at normal speeds.
Not unusual for fuel pump to run at proper pressure when cool, but lose pressure when warmed up. If it's only running bad when off accelerator and stopping or turning and runs down the highway good, remove and clean AIS/IAC motor. ( idle speed motor ) Once cleaned, if it runs better for a while then starts to act up again, replace it.

Jul 16, 2011 | Plymouth Voyager Cars & Trucks

1 Answer

The car just started to run rough and will not accelerate properly, some low level backfire, when I turn off the ignition and restart the car run somewhat smooth and when I accelerate it boggs down, etc....


Change the fuel filter, and put a can of Seafoam (from the parts store) into the gas tank, and fill up on top of it with high octane fuel. That should fix the issue.

Nov 08, 2009 | 2003 Saab 9-3

1 Answer

The engine runs fine until it get to half a tank of gas.


I wonder if it could be that the tank's not getting vented properly... have you tried just taking the gas cap off and replacing it, without adding fuel? is there a suction sound when you take the cap off?

Aug 15, 2009 | 2001 Dodge Durango

2 Answers

Everytime I run my car low on fuel then add more,whether I fill it up or not,it starts missing and the 'service engine soon' light comes. WE thought it was something to do with the firing system at first...


You've got water in your tank. There are fuel additives that remove water from the gas tank that work very well. As you run the tank low, all the water and other "junk" that collect on the bottom of the tank are now being injected into your fuel line, causing erratic idling and occasional misfires.

May 07, 2009 | 1996 Pontiac Firebird

1 Answer

Engine stops running after replacing the fuel sending unit.


do you have the seal for the tank properly installed kinks or collapsed fuel lines and properly tightened? did you bang or drop fuel pump?good places to start!

Jan 07, 2009 | 1998 Isuzu Rodeo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fiat Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

yadayada
yadayada

Level 3 Expert

76051 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Fiat Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...