Question about 1995 Buick Regal

Open Question

1995 buick regal intermittent starting problems. Changed plug, wires has good spark. Had coils checked. When it starts it runs great. Shut it off and sometimes will not start. Turns over fine, fires once then dies. IF the crank sensor is bad would it be intermittent? HELP

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: My 1995 buick riviera won't start. no spark fire

corrosion under the coil pack between the computer plates
Heres a video:http://www.youtube.com/watch?v=t_79_btzOF8

Posted on Jul 13, 2009

  • 67 Answers

SOURCE: 94 buick regal grand sport

Possibly timing.

Posted on Aug 27, 2008

StormStrikes
  • 104 Answers

SOURCE: how to replace a crank sensor on a 93 buick regal 3.8L engine

Im assuming this is the Series I 3800? If so, if you can email me I can send you some directions on the process. Its for a Series II 3800 but it should be similar. If you cant email me, post up and I'll see what I can do.

Posted on Dec 30, 2008

mcgyver468
  • 710 Answers

SOURCE: 98 dode ram wont crank no spark

May have no spark due to a bad crank sensor, which is responsible for spark when it gets a pulse through the cars' computer.

Posted on Apr 24, 2009

  • 218 Answers

SOURCE: 1995 JEEP GRAND CHEROKEE RAN AND DIED WILL NOT START

IS IT THE 4.0L?IF SO U MAY HAVE A BAD CRANKSHAFT POSITION SENSOR.

Posted on Apr 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

95 Buick Regal will not crank when engine warm wait 20 or so minutes and it will crank what causes this issue.?


Define crank ? Does the engine spin when you turn the key to the start position ? This is referred to as engine cranks . now yours won't start an run ! This is a cranks no start condition ! When it won't start an run check for spark at a coil , your vehicle has three if a V-6 . Pull both plug wires off same coil an crank engine , is there spark ? Yes - No . No spark , ignition module could be bad , crankshaft position sensor , Your best bet would be to take your vehicle to a qualified repair shop .

Sep 26, 2016 | 1995 Buick Regal

1 Answer

1992 Buick regal running with miss


I would do a compression test to see if all cylinders are good, and no internal mechanical damage has occurred.
If compression is good, check for possible intake manifold leak that especially affects the right bank- the bank with 1, 3, and 5 cylinders.
No way I can think of that spark would be different on the right bank, so it could be wrong air/fuel mixture for that side, or possible loss of compression that is causing the misfires.

Jun 08, 2017 | Cars & Trucks

1 Answer

Only starts half the time


If it cranks and you got fuel pump and filter changed, then have a look at the ignition components also, like spark plugs, coils, spark plug wires. also make sure the wiring for the fuel pump is not loose or anything. Hope it helps and let me know if you need more advice. Please don't forget to rate the answer it helps with my rating, thanks!

Apr 21, 2010 | 1995 Buick Regal

1 Answer

1999buick regal ls


The right turn signal will only work if its hit manually instead of just being turned on once. I have checked the fuses and changed the bulbs, all are good. I even cleaned the connection to the light but have had no luck getting it to flash intermittently once I have turnedd the signal on.

Oct 08, 2008 | 1999 Buick Regal

1 Answer

Car has hesitation at around 45 mph


Hi there,

You problem is most likely a bad spark plug wire or spark plug. I would start with the wires and then chenge the plugs. Most likely you have a wire shorting out under load.

I had the same problem on my 1999 century and it was cured after replacing the wires. My 1998 Regal GS was running rough and after I replaced the wires it runs great!

Good luck!

Jul 27, 2008 | 1999 Buick Regal

2 Answers

1995 buick regal custom missing


you might have bad plug wires replace wires and saprk plugs

Jun 09, 2008 | 1995 Buick Regal

Not finding what you are looking for?
1995 Buick Regal Logo

Related Topics:

186 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...