Question about 2001 Ford Expedition

1 Answer

My 2004 expedition is running hot......losing water but cannot find where the water is going.....help

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 218 Answers

Check the oil and the tranny fluid, and make shure u don't have white smoke coming from the ehaust

Posted on Jun 06, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2004 vw passat.. I have water coming from somewhere under my hood. I can drive about 20 after filling it up with water, before the Stop check coolant light comes on.. Its not running hot, but it...


It sounds like you have a leak. Go to any garage and ask them to put a pressure testor on top of your radiator cap. This will show were your leak is if any.

Sep 25, 2012 | Cars & Trucks

1 Answer

No heat from the heater of a 2004 Kia Sorento EX


check your heater controls , there may be a cable lose or broken, or a vacume hose lose or broken,i don't know if that car has a heat control valve,but if it does you might check that as well.
hope this helps!

Oct 25, 2011 | 2004 Kia Sorento

1 Answer

Lose reverse when after it runs a while


The radiator might not be cooling the transmission enough,fan clutch,or radiator might need to be replaced,also,have a filter and fluid change on the transmission .If this was helpful,please rate thank you.

Jul 05, 2010 | 1997 Ford Expedition

1 Answer

What makes a 2004 dodge neon run hot


Numerous things make a car run hot. Water Pump, overflow cap, belt not tight to turn water pump enough to keep it cool, radiator has a small hole or needs to be flushed to clean. Are you losing coolant? If so can you see what area it may be coming from? It more less something that has to be narrowed down without seeing it in person.

Jul 03, 2010 | 2004 Dodge Neon

1 Answer

Correct installation of thermostat for 2004 dodge 1500, 4.7 engine, runs abnormally hot, just a tad over middle temperature range, after being run top hose very hot to touch, bottom hose cool, thanks in...


you know when its wrong the guage goes to the top,then drops.the temp guage is notoriously wrong on most cars,so if your not losing power,water,leave it.(the top hose is hot,about boiling point,the botom should be just warm)thats what the radiator does......

Jun 17, 2010 | 2004 Dodge Ram 1500

1 Answer

Spec's on coolant capacity for 1998 FORD EXPEDITION


I drained my system out and ran a water nozzle into the coolant jug. this will help get any slime/grime out. They make a coolant cleaner you can use. I rushed plain water through until it came out white. But while I did this i had my engine running to circulate the water at a hot temp to loosen up other grime. leave hose in for 5 min while water is pushed through. go cut car off and let it drain for 2-3 minutes. plug your drain hole and put in Antifreeze not the 50/50. Pour in the whold bottle and rest with water. 1 gallon of antifreeze and fill with water.

Jan 23, 2010 | 1998 Ford Expedition

2 Answers

Overheating


It's going to run hot, especially in hot weather but one big thing is what kind of coolant you are using. If it's dex-cool ( chevy and gm brand ) get it out of there and put some pre-mixed good coolant / water mix and it will help a whole lot. Just had the same problem with my 02' blazer. If the water pump and thermostat have been changed you should not be having a problem.

Aug 06, 2009 | 2004 Dodge Ram 1500

Not finding what you are looking for?
2001 Ford Expedition Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...