Question about 1996 Isuzu Hombre

2 Answers

Engine temp guage shows cold

I have a 96 Hombre. The engine temp guage shows cold. What do I need to fix it? I was told it was an easy fix, but I was not told the paart I would need.

Posted by on

  • A Miller Jun 05, 2010

    depends ... can you find the temp sensor ... can you test the temp sensor to determine if that is the part ... can you remove it if necessary and install a replacement ... you follow the wire to the gage? can you test the gage. easy is in the eye of the beholder ...

×

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 115 Answers

Let the truck run for about 15 minutes. If the engine temperature does not come up turn the heater on and check to see if the air coming out is hot or cool. If it is hot the engine's thermostat is operating fine and most likely the problem is with the temperature sending unit for the gauge. If the air is cool the thermostat is stuck open. Try replacing the thermostat if the air is cool.

Posted on Jun 05, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Isuzu Master
  • 14,036 Answers

TEMPERATURE SENDING UNIT.

Posted on Jun 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Temp.guage on instrament panel is erradic


Could be the temp sensor or the gauge on the dash is faulty.
Does the gauge go to cold if you disconnect the sensor ?

Jan 22, 2014 | Cars & Trucks

2 Answers

Ford Fiesta Problem


You most likely have a defective engine temperatur3e control thermostat.

Nov 21, 2013 | Ford Fiesta Cars & Trucks

1 Answer

2000 GMC Savanna, oil pressure guage drops to


You need to pull the pressure sensor and install a manual test gage, (borrow from Autozone or other chain part store) that is the only way to verify the engine is not loosing oil pressure.

Oct 30, 2017 | 2000 GMC Savana

1 Answer

Starting Problem, engine runs cold acording to guage


c lean your TPS and your MAF sensors and check air filter

Apr 23, 2012 | 1996 GMC Jimmy

1 Answer

2006 impala. indicator light says "engine hot, A/C off". but temp guage is showing it is cold


cold or normal temp? Check coolant level. if the level is low, the temp sensor cant read correctly

Nov 30, 2010 | Chevrolet Impala Cars & Trucks

1 Answer

96 mustang v6 temperature guage reads around the "m" letter on guage, and even at "a" letter on the "normal" area of guage readout....seems like it's running a bit hot, but i'm not a ford expert. I got...


some of the factory gauges aren't very accurate if the fluid level is good and you get good heat inside I wouldn't worry about it, but I would keep an eye on it to make sure it doesn't over heat. If your still worried I would go to an auto parts store and pick up a temp. gauge there perty easy to install

Oct 15, 2009 | 1998 Ford Mustang

2 Answers

Engine Guage is showing Hot.


replace the temp sending unit on the engine first

Mar 11, 2009 | 2001 Pontiac Aztek

1 Answer

Temp guage dont read


U are talking about two different sending units, one is the Engine Coolant Temp sensor, the other is the temp guage sender, sounds like you have a bad thermostat, if the engine doesn't reach the proper operating temp it will set a code for the engine coolant temp sensor, and the guage will not move or move very little, replace your thermostat and both problems will go away.

Mar 02, 2009 | 1996 Pontiac Grand Am

2 Answers

Cold heater


Thermostat is faulty. Change it to fix your problem.

Jan 21, 2009 | 1993 Subaru Legacy

1 Answer

Temp guage goes to max (right) when engine is cold.


change the themostat when you remove the old themostat you should see it stuck in the open postion . before i install the new one i fill the the block with coolant install the new stat run the mtr and heater core until hot iwould also replace the cap

Jan 01, 2009 | 2001 Dodge Ram 1500 Truck 2WD

Not finding what you are looking for?
1996 Isuzu Hombre Logo

Related Topics:

247 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

77514 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14398 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...