Question about 2000 Chrysler 300M

2 Answers

I have a 2001 Chrysler 300m. It ovrheated pushing water out resevoir so I put new thermastat in and did't fix the problem. I now have water pump out but it seems to be ok and no evidence of the belt rubbing on the pulley like the bearing seizes under higher temps. There was no noise from engine either and no antifreeze smell from the exhaust or water in oil but water is going somewhere because after letting cool down the resevoir is empty.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You really should have your water pump replaced i had the same thing happen to me and i had to replace it. do not drive it long with out the water pump trust me.

Posted on Feb 09, 2012

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 218 Answers

Check and make shure the fan is cuming on when it should, the coolant could simply be evaperating from the engin getting to hot

Posted on Jun 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

No heat after water pump replaced 2001 300m 3.5l


Did you change the thermostat? It could be stuck in the open positon, or in backwards, or missing all together. I would like for you to check your heater hoses where they connect to the engine, as this is a very good place for corrosion to build up, restricting coolent flow to your heater core. If this don't fix your heat, I would like to know the reason you changed the water pump. Was it overheating? Did you have heat before you changed the water pump?

Dec 08, 2013 | 2001 Chrysler 300M

1 Answer

How do i reset the security system on my 1999 chrysler 300 m


sound like run battery down your water pump on the 300M driven by the timing chain.could have disturb timing.

Apr 06, 2013 | Chrysler Cars & Trucks

1 Answer

300M 3.5 V6 2001 CHRYSLER JUMPED TIMING BELT OR BROKE CAR JUST QUIT AT STOP LIGHT


This engine is what is known as an interference engine, so if the timing belt lets go like this you most likely have bent engine valves and or piston crown damage. The best advice i can give is have a new belt, water pump and automatic tensioner pulley installed and see if it starts, you may get lucky, my wife did when hers let go a year before I meant er. You can purchase a timing belt "kit" with all the parts here is the part number and price.
ACDELCO Part # TCKWP295 TIMING BLET KIT- INCLUDES WATER PUMP
BELT KIT,TMG INTERFERENCE ENGINE APPLICATION PRICE $184.00 USD Source for parts price and number www.rockauto.com

Jul 12, 2012 | 2001 Chrysler 300M

1 Answer

Because if you put the thermostat at 300m water does not circulate when the thermostat is new


So you changed the thermostat?
Water will not circulate while engine is cold. As it reaches normal temp it should open and circulate. If it is overheating when warmed up, and still not circulating, then either the thrmostat is bad or wrong type, or it was installed wrong and somthing is blocking it.
One other thing possible is the water pump is broken, but usually when pump is broke, it leaks, from the back of the pump.
You could check the belt is correctly driving the water pump.

Apr 10, 2011 | 1999 Chrysler 300M

1 Answer

2001 300m wont start changed fuel pump turns over but will not start any ideas


is there a spark at the leads? check leads, coil, crank or cam position sensors, e.c.m in that order. if there is a spark and the new pump's fitted correctly, check for fuel blockages along fuel line, if injectors are opening,air flow sensor.
or alternatively have a reliable technician put it on a diagnising machine. i'm sure you'll agree that it would save alot of time and effort

Jul 08, 2010 | 2001 Chrysler 300M

Not finding what you are looking for?
2000 Chrysler 300M Logo

275 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8575 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...