Question about 1992 Nissan NX

1 Answer

The car starts but runs rough like its not running on all the cylinders changed the plugs and wires doing the same thing

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 973 Answers

Did you check or change the ignition coil or coils? You could have dirty fuel injector or injectors. Change the fuel filter and try putting some STP Super Concentrated Fuel Injector Cleaner in your fuel tank and see what happens.

Posted on Jun 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car starts hard then idles roughly for 2-3min then stalls and dies


It sounds like some thing you have done if the fault started after the tune , did you check the gap on the new plugs, check the firing order as it may be messed up . 4 cylinder 1342 6 cylinder 153624 in direction of rotation.

Dec 03, 2015 | 1996 Nissan Altima

3 Answers

Why would engine run rough after tunr up?


Are plug wires connected in the right firing order to the plugs? Also are the spark plugs gap correct? Was vehicle running rough before tune up or only after?

Jul 05, 2014 | 1998 Ford Escort

2 Answers

97 Ford Explorer running rough code p0353


The code P0353 is for cylinder #3. (3rd one back from the front of the engine) on the passenger side. Follow this plug wire to the correct coil pack.

Mar 04, 2013 | Ford Cars & Trucks

1 Answer

Can a bad intake gasket cause my car not to run or run rough


Yes. If it is leaking, the engine is not getting enough air intake. It's the same as disconnecting the PCV valve.

Apr 29, 2012 | 1996 Oldsmobile Cutlass Ciera

1 Answer

I have a 2002mercury sable, idles rough but runs good when acceleration. I changed fuel filter,plugs, plug wires, coil, still idles rough.Autozone had three codes, P0316, P1151, P1131. What should I do...


P0316 crankshaft position sensor, camshaft position sensor, or a wiring issue. Since this code indicates a start up misfire, pay attention to items which may expand or contract when cold (if the code sets when the engine is cold), or hot (if the code sets on a hot restart).

If you have other misfire codes that pertain to individual cylinders, you should attend to them first P1151 has a huge list of things that it can be, But included in that list is the camshaft position sensor , po1131 is the same thing, all building up to your car is running lean , so I'd do the sensor (cam) and check timing,,

Jul 17, 2011 | Mercury Sable Cars & Trucks

2 Answers

Tuned up car changed 02 sensor full tank of fuel still running rough


Oxygen sensor only report the condition of the engine the rough running condition can range from a worn sparkplug wires to worn sparkplugs to valve problems to injector problems. with the cadillac deville a tune up should be the first attempt to smooth the rough idle with the inspection of the cap and rotor cap and rotor do have a tendancy to arc internally and create misfire so does sparkplug wire that can leak spark voltage to ground and create misfire. the spark plug wire especially if they are brittle and hard can create issues

Apr 23, 2011 | 1990 Cadillac Deville

1 Answer

Car was running a little sluggish, changed plugs and car ran great for 45 minutes then started running rough. checked ignition module, coil packs. all ok. replaced wires, ran better then started running...


Make sure the HT leads are secure. They might be popping off, causing it to not fire on one cylinder. I always change the plugs and leads at the same time to keep them the same age. HT leads break down rapidly and need regular replacement.

Jun 23, 2010 | 1990 Oldsmobile Cutlass Ciera

3 Answers

I followed the firing order installing a dist cap on a 91 camaro and still running rough What do I look for now


check plugs -plug gap-vacuum leak-fuel mix-fuel pressure-timing-pcv valve-egr valve-air filter-oil sludge build up-problem in heads[valves adjustment-burnt-weak springs if only changed wires do a complete tune-up and do a compression check

Mar 14, 2010 | 1991 Chevrolet Camaro

Not finding what you are looking for?
1992 Nissan NX Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...