Question about 2001 Land Rover Discovery Series II

1 Answer

Landrover 2001 cuts out after 5 to 10 minutes (no spark,no fault lights/warning signals)After 30+ minutes car starts runs perfect for 5 to 10 and cuts out.Help needed, thanks

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 30 Answers

I just ran into a 2002 Discovery doing the same thing. What ended up being the fix was a cam sensor and crank sensor. That is about all I can say without more information. Hope this helps and best of luck.

Posted on Jun 16, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I am driving a 1997 Toyota Prado 3.4 L petrol Automatic. Engine cuts out.


Hi
im assuming there are no lights on the dash.
If you remove both battery terminal wire and touch them together (Wires only)
that will reset any fault stored and reset the computer.
hopefully that will correct the fault.
Thanks

Apr 25, 2017 | Toyota Cars & Trucks

1 Answer

Hyundai motor problem warning motor light


run fault codes to check for failed sensor.

Nov 30, 2013 | Cars & Trucks

1 Answer

I have a 2002 landrover freelander. About every two months it will not start. It is not the battery as it turns over very strong. Let it sit for about 30 minutes and it will start. It is not flooded...


the next time this happens have a spare spark plug remove a plug wire and install a plug on the wire and ground it to the engine and have some 1 crank the engine over and see if you have spark if you dont have spark then you know it's electical if you do have spark then you know it's fuel. let me know how it turns out

Jan 02, 2012 | 2002 Land Rover Freelander

3 Answers

Just bought a 2008 porsche cayenne. After a week the car struggles to start. The lights come on in vehicle but it just slugs for about 4-5 seconds and does not start. Then I wait 30 seconds to a minute...


You may have purchased a car that was having problems before you purchased it. I do hope you didn't get scammed. I would take it to your trusted mechanic. This job is too big to tackle.

Apr 17, 2011 | 2008 Porsche Cayenne

1 Answer

Hi . i have a 2001 VW golf 1.4 16 valve AXP engine code . the problem is the car will start and run for about 30 minutes or so and then for no apparrent reason just cut out . EPC warning light comes on ....


change the pedal sensors if fitted ,not sure it has them though i cannot remember everything ,nothing in my alldata book about a fault with this particular model .but this is a common sort of problem with vehicles with pedal sensors

Oct 21, 2010 | 2001 Volkswagen Golf

1 Answer

Hill Decent Controll Warning light comes on


throttle switch on gas pedel not closing , check cable free play adjustment at throttle side.

May 12, 2009 | Land Rover Freelander Cars & Trucks

1 Answer

2001 Buick Regal cuts off while driving at times also won't start


The ignition switch on that model is rated @ 50amps. When I was driving my 2001 Regal LS (at 120,000 miles) and used the turn signal, the engine would die, when I switched the turn signal off, the engine ran. So I replaced the ignition switch, and all is well.

merkfritz@yahoo.com

Mar 24, 2009 | 2001 Buick Regal

1 Answer

Mazda etude 160ie a/c cuts out after approx 45 min driving.


Could be an electrical part that only fails after getting really hot. Coils and ignition modules are known for this. Unfortunately, these parts cannot be tested for this heat-soak type problems, other than to see if spark quality at the plugs has degraded when failing. One other thought. A bad gas cap which is not allowing air to flow in as gas is used can cause this and that is a cheap part to replace just for grins.

Jan 10, 2009 | 2003 Mazda MPV

Not finding what you are looking for?
2001 Land Rover Discovery Series II Logo

Related Topics:

472 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76682 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...