Question about 1997 GMC Jimmy

1 Answer

Taking longer 2 start...has 2 turn over longer b4 engine starts. Runs great once it starts.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 218 Answers

Check the air cleaner and fuel filter's first then the cap rotor plug's and wire's

Posted on Jun 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 Mazda Miata runs perfect in everyway except that it just started blowing white/grey smoke from tailpipe, only happens when it is first started and cold engine


could be 2 reasons.
1. start of a head gasket leak to the combustion chamber. Will become more white and for longer period as it gets worse.
2. oil rings are worn and starting to pass oil to combustion chamber. They seal up once engine is worn.

Mar 11, 2014 | 1989 Toyota Corolla 2 Door

1 Answer

Hard to start after car has started once


Hi,I know it costs but if you can afford it have a diagnostics done on engine,if not,when car woms up when you start again try taking the plug off the maff sensor as this could also be problem if it starts ok its proberly the maff sensor,ether way sensers are not cheep,best of luck

Nov 30, 2013 | 1997 Mercedes-Benz Mercedes Benz S Class...

2 Answers

1994 LaSabre...Stalls out


Sounds like a classic crankshaft position sensor problem to me.

Apr 27, 2012 | 1994 Buick LeSabre

1 Answer

Turns over and over can hear fuel pump come on will start with starting fluid and runs great but when shut off for a little while wont start again only with starting fluid


If the starting fluid works then you have a fuel pump or a fuel pump relay issue. The fuel pump relay allows the pump to come on for about 2 secs and prime the fuel system. Once the engine starts then the power to the fuel pump runs through the oil pressure circuit.
If the car starts on starting fluid and then continues to run... I would lean toward a fuel pump relay issue. Hope this helps, Good Luck!

Aug 18, 2011 | 1996 Chevrolet Tahoe

2 Answers

Hard starting when cold ( engine cranks normally )


see if your engine has a ECT sensor (temp sensor that delivers information to your ECM) they are installed on the intake side of the cylinder head, it usually has 2 cables, have it checked replace if necesary

Nov 19, 2009 | 1991 Jeep Wrangler

1 Answer

Rough idle, cruise control also stopped working


Sounds like you could have gotten some water in your fuel tank from that fill up. Go to a autoparts store and get a product to put in the tank that takes care of water in fuel. Use it when you fill the tank up a few times after and hopefully it goes away. Whenever you can't sustain power in the engine or it runs rough then your cruise control will constantly be shut off because the engine doesn't have the power to keep the speed up and should go away once your engine is running clean again.

Good Luck

Oct 09, 2009 | 2004 Chevrolet TrailBlazer

1 Answer

Have 94 toyota corona 1800 auto that has just started taking longer 2 change n2 top gear when first started.ok once warmed up.270000 kms so not worth spending much on it.is there a quick fix?


on some toyotas they lock out hi gear until the engine temp reaches a preset value ... thats to prevent lugging down a cold engine .. there is sometimes a light on the dash that indicates low engine temp .. when it goes out then the high gear is enabled ... if yours is now taking longer than normal then you might have a bad thermostat (causing engine to take longer to warm up) .. of course at 270,000 miles you might be pressing your luck if thats the original transmission .. those cars seem to last forever (almost) ..

Sep 28, 2009 | 1993 Toyota Camry V6

1 Answer

Engine dies


I had the same problem with my 94 chevy 6.5 diesel,and spent alot of money trying things that people told me to try.I wound up taking it to the dealer and they told me it was the injection pump.They put one in it and that fixed it.It has run great for over a year and a half.This set me back about $4000.00!

May 29, 2008 | 1993 Chevrolet C/K 3500

Not finding what you are looking for?
1997 GMC Jimmy Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...