Question about Mercedes-Benz ML320

1 Answer

Have a 98 ml320 starts and only runs for 2-3 seconds then dies will start back up and do the same thing been sitting for a couple of months

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mercedes-Benz Master
  • 1,619 Answers

Crank pposition sensor, known issue. Also there was a recall that your motor may fall under using incorrect oil.

Posted on Aug 15, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Will start but wont stay running


No the missing O2 sensors would not keep it from running. The missing exhaust pipes might not help matters. No exhaust system would cause a lack of back pressure.
I would want to know what base fuel pressure is with a gauge before and after cranking. Your thought about bad gas is legit, today's gasoline is only good for about 2 or 3 months before it starts gelling up.
Did you replace the inline filter the last time you put the new pump in ? And are you sure the pump is getting power after the key is released?

Feb 23, 2014 | Ford Windstar Cars & Trucks

1 Answer

98 Suburban will not start


Check for spark when it won't start. If no spark, it's an ignition problem-suspect the crank position sensor. The computer won't cause spark from the coils if the crank sensor gets hot and fails.

Nov 23, 2013 | 1998 Chevrolet Suburban

1 Answer

My 1999 chevy silverado starts and dies within two seconds. has anyone had this experience before and how did you fix it?


does it have a b2960 security code set, i bet it does, it probably has a security problem and is going into fuel shut off, try replacing the ignition switch harness, this is 98% of the time the problem

Jan 15, 2013 | 1999 Chevrolet Silverado 1500

1 Answer

I have a 1998 cavalier. It has been sitting for a couple of months and not drove much. I have recently tryed to start it and i'm having trouble. it will start then imedetly dies then it just crank


Probably the best thing you can try is to replace the fuel filter and do a fuel sample at the same time. Use a glass jar to capture a little fuel and let it sit for a day to see if it separates. Put a lid on the jar to prevent evaporation.

Depending on your results, you can determine if the fuel is the problem.

Apr 16, 2012 | 1998 Chevrolet Cavalier

1 Answer

98 chevy k1500 will fire then die right away will not stay running


That is usually the fuel pump in the tank you to check the fuel pump pressure in all conditions as these are sensitiveJohnny

Mar 16, 2012 | 1998 Chevrolet K1500

2 Answers

05 Nissan Pathfinder - Dies when driving. I pull


seems like your mass air flow meter is on its way out i had similar issue with my 98 pathfinder it did not throw a code until it finally went.

Jan 20, 2010 | 2005 Nissan Pathfinder

1 Answer

2001 Xterra - Replaced fuel pump twice and is still not running.


I am no expert, but I just had a similar problem. The car would shake and buck when accelerating. It finally just died and would not start. After sitting for some time, the car would start and run a while, then do the same thing. I thought fuel pump. The dealer diagnosed distributor. After replacing, the car is running perfect. Something to think about. Good luck.

Mar 13, 2009 | 2001 Nissan Xterra

2 Answers

Car won't run after rain or after it sits for a couple days


you need a tune up new plugs wires and cap an rotor

Nov 07, 2008 | 1990 Geo Prizm

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

404 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76682 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...