Question about 1999 Chevrolet Blazer

1 Answer

No ck eng lite but when warm long crank time things ive done tps/fi service tb service and coolant temp sensor 99 blazer 4.3

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 88 Answers

Check ignition coils

Posted on Jun 01, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 96 eclipse 420a. Ive replaced tps, coil pack, crank pos sensor, and relay, new plugs and wires, cleaned map and IAC. Car starts right up drivers good. Then after driving 20 mins car looses po


if your fuel pump is not bad ck the pressure , not sure of it but around 50 lbs I thing , ck the intake sometime the 4 bolts get loose and this will let to much air in and will not run right ,

Oct 21, 2014 | Cars & Trucks

1 Answer

Alero Problems car starts, but dies at running temp. then after 20 mins. it will restart, until running temp again, then dies. have changed, cam, crank, & map sensors, also ign. model, & pass lock assy....


Seems to me that I've run across this problem 3 or 4 times over the years on different cars. Problem usually comes down to either fuel system, electrical system (including sensors), or the coolant system (including sensors). I ran into this most recently on an '89 Escort. Wound up replacing fuel pump relay, ignition relay, TPS sensor, ignition module, coolant temp switch, coolant pump (and timing belt while I was in there). Fixed a couple of engine grounds and a couple of misc things. Point is that there is probably more than one item at fault.

Oct 11, 2013 | Cars & Trucks

2 Answers

98 blazer 4.3 engine won't start code p0336, already replaced crank sensor


which crank sensor do you replaced ? the P0336 means P0336 Crankshaft Position Sensor A Circuit Range/Performance.

________________
autel maxidas 708

Feb 25, 2013 | 1998 Chevrolet Blazer

1 Answer

2001 chevy cavalier burns too much gas


I would first see if you have a service eng lite, If not then I would check air filter and replace if can't see through it looking at a light. next I would change the coolant sensor, this regulates fuel to eng according to temp of engine, also if you haven't changed your thermostat, would be a good idea cause the cars have to run a certain temp for computer to work right. all else fails your Catiylic converter could be plugged ! just some things to check in the order of easiest first. good luck !

Aug 23, 2012 | Chevrolet Cavalier Cars & Trucks

1 Answer

My blazer runs good until gets hot and starts sputtering and backfireing


I have read that if the TPS is bad and you unplug it and the vehicle runs better then it could be the TPS.( throttle position sensor ). could also be low fuel pressure. also check or replace coolant tempurature sensor. if the coolant sensor sends wrong info to pcm when hot ,then it will throw the timing and etc. off. that could be why it backfires when warmed up. make sure fuel filter is ok!! have a good day !!

Mar 27, 2011 | 1995 Chevrolet Blazer

2 Answers

When going to accellerate my 99 silverabo seems to bog out ( hesitate) before any acceleration happens. i dont want to spend a milion dollars on it but i do love my chevy please help me......


first have fuel pressure test done.if no ck engine lite on ck fuel filter then have it scanned for fuel trim values. this will tell if mass air flow could be contaminated. several possabilities 02 sensor lazy,coolant temp, but anyone who can do drivability at your local should find that easy.

Jan 29, 2011 | 1999 Chevrolet Silverado 1500

1 Answer

2004 Chevy Trailblazer engine stalls after coolant temp senor R&R


clean your throttle body....same thing happened to me and my truck runs great now.

Mar 19, 2009 | 2004 Chevrolet TrailBlazer

Not finding what you are looking for?
1999 Chevrolet Blazer Logo

Related Topics:

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...