Question about 1999 Ford Expedition

1 Answer

1999 expedition motor runs smooth but it makes a clicking noise that don't go away. Brought it home from 30 miles away and it runs good buy makes a noise that seems to come from the front of the engine, more precisely from under the valve cover towards the back. It never overheated during the trip.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 80 Answers

If it has a 5.4 liter engine the ticking noise is normal. Sounds like its coming from the passenger side wheel well?

Posted on Jun 01, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Why does my 1999 Ford Expedition eating starters after replacing valve cover, removed cruise control box but it is back exactly the same?


Its your starter shims. Put shims in , what is happening is your starter gear is remaining engaged even after it starts thus it tears up the starter and the gear. It may take 2-3 shims. When you replaced your first starter did it have shims? I am willing to bet it did. Give it a try and i bet this fixes your problem. Good luck

Apr 12, 2015 | 1999 Ford Expedition

1 Answer

Knocking noise upper passenger side 99 expedition


have you changed the oil since it was rebuilt?? 2 quarts low is a lot. not suprising you may have a bad lifter

May 08, 2017 | 1999 Ford Expedition

2 Answers

I am considering buying a used 2000 VW new beetle (88k miles, $3200). The seller says that the head gasket has just been replaced, and that the mechanic said the engine will make the knocking/clunking...


All nonsense in my book

Buy a vehicle not over 3 or 4 years old
& never over 30,000 miles & try to pay cash
& forget the collision insurance

That is the correct way to do it

Of coarse i have been at this 47 years
& can do my own repairs & money isn't
an issue

Jun 26, 2011 | 2000 Volkswagen Beetle

1 Answer

1999 4Runner - Engine clicks on occasion


I would say that the engine is showing signs of wear in the valve area, but I wouldn't worry about it unless oil consumption is beyond 1 quart per 1000 mi., or the gas mileage of the engine is getting low.

I have a 1999 Ford Expedition that clicks right after it starts up, but it always goes away after it's warmed up to operating temperature.

I don't worry about it since it seems to run smoothly and gets decent gas mileage for its size.

Good luck on this.

Jan 19, 2011 | 1999 Toyota 4Runner

1 Answer

On my 1999 concorde LXi check engine light on


replace your belt and clean off your pulleys, your belt has gotten old and the rubber has started to come off on the pulleys, causing it to make the chirp and slip, your light came on because something was not getting full rotation because of the slip

Jun 19, 2010 | 1999 Chrysler Concorde

2 Answers

What weight of oil do i need to run in my 1999 k1500 chevy truck, it has 190,000 miles and I live in arkansas. I drive about 1500 miles a month.


SAE 5W-30 or 10W-30 will cover colder temps and most warmer temps. 10W-40 is a good choice in hot months - just make sure they are a high detergent ( most are nowadays)

Jan 11, 2010 | 1999 Chevrolet K1500

1 Answer

Not sure if it is the belt or the power steering pump. Making noise. Sprayed WD40 on it when it was running and it goes away for abour 30 seconds.


You probably need a new belt, don't buy a cheap belt. I have used cheap before and had noise right away. Ask for a Gates belt. When you sprayed the wd40 it lubed the old belt temporarily so the noise went away. Better to replace all or them at the same time. I am pretty sure the nissan has 2-3 belts.

Aug 17, 2009 | Hyundai Motor 2004 Sonata

4 Answers

Lifter noise


This is a very common issue with General Motors. I have never bothered to try and fix it because it is not causing any harm. It is because General Motors still uses a push rod motor and the cold oil causes it to knock a little until the oil gets warmed up.

Jul 24, 2008 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
1999 Ford Expedition Logo

327 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...