Question about 2005 Chevrolet TrailBlazer

1 Answer

What would make my 2005 trailblazer not want to accelerate on turns and hesitate going forward?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 14,036 Answers

COULD BE STOPPED UP FUEL FILTER OR DIRTY FUEL INJECTORS.AND FAULTY TPS SENSOR.

Posted on May 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2005 chev trailblazer is stuck in 4 wd so how can I get it back to 2 wheel?


park it...put it back into 2wd...slowly drive forward about 20 feet...it should reset back into 2wd...let me know if it doesnt please and we can go to the next step. Good luck

Feb 24, 2015 | 2005 Chevrolet TrailBlazer LS

1 Answer

When I accelerate my 2002 trailblazer it kinda stalls then kicks in later is it the throttle body or a sensor or?


Do you have the check engine light on at any time? If so, you need to get the codes scanned and make note of what the codes are.
It's possible the accelerator pedal sensor has a dead spot in it, causing the hesitation. It probably would be a good idea to have the throttle body cleaned (front side and back side).

Aug 20, 2011 | 2002 Chevrolet TrailBlazer

1 Answer

05 TrailBlazer 57,000 miles 4.2 6 cyl, bad vibration at cold startup, in idle and in drive, in reverse, smooth. Summer mornings just very slight. I live in central GA. My brother also has a TrailBlazer ...


WHEN YOU SAY THAT IT GOES AWAY IF YOU PUT IT IN REVERSE THE THERE HAS TO BE A MOUNT OR SOMETHING HITTING ON THE LEFT SIDE PUT IT ON A LIFT AND TAKE A BIG BAR AND MOVE THE MOTOR UP ON THE LEFT SIDE AND SEE IF THAT CHANGES THE FEEL CLEAN OUT THE THROTTLE PLATES AND SEE IF THAT TAKES CARE OF THE HESITATION

Oct 21, 2010 | 2005 Chevrolet TrailBlazer

1 Answer

Vehicle hesitates when during acceleration runs 2005 lincon ls


Got a Check Light on dash?
Got any stored codes?

Most likely you have a COP Ignition Coil going bad.
Have the TPS Sensor checked also. I would prefer a scope trace, to a voltage reading

You can expect at least one part failure a year on the LS I have a 2004.

Got codes--give them to me,I'll help you out.

Apr 16, 2010 | 2005 Lincoln LS

1 Answer

2005 Chev Trailblazer. Stabilitrac, check engine


need to get codes to repair, have seen alot of these vehicles go thru the throttle position sensor which is the complete throttle pedal assembly

Feb 07, 2010 | 2005 Chevrolet Trailblazer Ext

2 Answers

How to reset oil light after oil change on 2005 trailblazer


  1. Turn the key to the "ON" position
  2. Press the accelerator all the way to the floor 3 times within 5 seconds
  3. You should see the oil light flash, once it stops flashing, turn the key off
  4. Wait 10 seconds before starting the vehicle, the oil light should now be reset
  5. If this doesn't reset the light, repeat steps 1-4 paying careful attention to pressing accelerator all the way to the floor 3 times within 5 seconds
Best of luck.
Greg

Aug 10, 2009 | 2005 Chevrolet TrailBlazer

2 Answers

2004 nissan armada low idle then won't start


I had the smae problem with mine last week, it turned out to be the IPDM Independent power distribution moduel, looks like a big fuse box. I would take it to a side mechanic and have them fix it instead of going to the dealer it took like 45 mins to take the old one out and put the new one in. If you go to the dealer they are sure to charge something crazy. Hope that works for you.

Feb 21, 2009 | 2005 Nissan Armada

1 Answer

Power Steering Issues


Check Power-steering Fluid level and make sure that fluid is good first. If Fluid is good and when you accelerate the vehicle its fine then, you need a POWER STEERING PUMP. Good Luck and thanks for using FIX YA

Jan 12, 2009 | 2005 Chevrolet Trailblazer Ext

Not finding what you are looking for?
2005 Chevrolet TrailBlazer Logo

Related Topics:

158 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...