Question about Chevrolet C1500

1 Answer

When under load the engine misfires. Just replaced the spider injectors, plugs, wires, cap/rotor. No engine light and no codes. Runs much better but still misses under load. (going up a hill or passing on the expressway). Any help would be much appreciated!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 972 Answers

Check fuel pressure if its low then it will cause a miss under load

Posted on May 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have several codes in my 99 Chevy S-10, po171, po174, po303, p1509. could there bo a common problem/


They are related mostly. All have to do with air intake. 170 codes are both sides running lean, to much air. 303 is a #3 misfire, could be a vacuum leak around the plenum. you replaced the spider. Could be the injector not seated right(smell for gas in the oil/dipstick), also could be a bad wire or spark plug. 1509 is an electrical problem with the idle air control motor. Check the plug for corrosion. Also wires usually break a round the plug. This also could be the problems with too much air.

Nov 08, 2014 | Cars & Trucks

2 Answers

Why the loss of power and po300 code?


HARD TO SAY WITH OUT BEING THERE BUT THIS MIGHT HELP .
Crankshaft sensor Was the trouble with my 99 Chevy truck after replacing many components like coil cap rotor wires and so on .
http://www.obd-codes.com/p0102 Code P0300 Causes and Fixes Code p0300 is a code that is generated when your engine has a misfire that is not related to only one cylinder. Sometimes this code will be set in addition to other codes such as p0301 which means that there is a misfire on cylinder 1 (cylinder 1 is the number one cylinder when looking at the firing order. It is generally the forward most cylinder on the engine.). If these engine codes are present as well the you should diagnose those first as they are probably causing code p0300.
This code will set your check engine light and needs to be fixed as soon as possible. If it is not then you will probably need to replace your catalytic converter as well as the problem that is causing your misfire.
There are many causes for this obd code. Since it is a "random misfire" or "multiple misfire" this means that the misfire is on different cylinders and not just one all the time.
Common Causes
  • Low Fuel Pressure
  • Vacuum Leak
  • EGR system malfunction
  • Internal Engine Problems (such as low compression)
Less Common Causes
  • Faulty Coil
  • Faulty Spark Plugs and/or Wires
  • Camshaft or Crankshaft sensors
  • Ignition module
  • Computer

Jun 12, 2014 | 1998 Chevrolet Tahoe

2 Answers

I have a 1996 GMC Jimmy that was iddling very rough and code said cylinder 2 misfire check engine light was on solid. Replaced all plugs, wires, cap and fuel filter 1st of March 2013. It ran better for a...


Lets start at the beginning. Did anyone check fuel pressure before and after replacing the pump ?
Has anyone checked the fuel pressure regulator and the injector spider ? The 4.3w engine uses a spider with one injector that supplies all 6 cylinders. And it runs at 65psi or more.

Aug 05, 2013 | 1996 GMC Jimmy

1 Answer

Check engine light flashing misfire on # 7 cyl


wat was the compression? if good try doing a leak down test on that cylinder n compare to other cylinders.

Jan 04, 2013 | 1997 GMC Yukon

1 Answer

Van running like its missing


the problem is not in the plugs , wires , cap , rotor but in dirty injectors or injector controls and wires
use a quality injector cleaner for a few tanks of fuel
ECM controlled cars do not a tune up as the computer does that 60 times a minute so all you need to do is to run the fault codes and fix the faulty sensors
fault codes are being recorded all the time and only the serious engine or transmission faults put the engine light on

Jun 21, 2017 | Cars & Trucks

1 Answer

Knock sensor


is the code coming up as P0300 to 312? if so it is a misfire check plugs and wires. cap and rotor. then injectors with a noid light.

Aug 05, 2012 | 1992 Toyota Camry V6

2 Answers

I have a 2000 gmc jimmy with a service engine soon light. i received the code p0302 misfire detected cylinder 2.I replaced spark plugs and distributor cap and rotor. but still on. any other suggestion?


Well, Spark Plugs wear over time,seldom fail to fire
A worn or dirty rotor and cap will still fire, also

You never throw new wires at it,I don't,mine last 18 years,
on all vehicles

You need some OBD2 knowledge,start studying

The PO302,last # is the cylinder
Number 2 is misfiring

If you got individual coils, go there
If you got an ignition module, for all the cyl,go there
If you got plug wires,there is an extremely odd chance, one burned out inside ,on #2
& you did say your have a dist cap.

So you do have a cylinder monitor,that detected it
That may be the crank sensor,another possible

Need to know the system and how to test it.

You need to give veh specifics ,not just a year

Dec 01, 2010 | 2000 GMC Jimmy

2 Answers

HI I have a 99 Jimmy with 4.3 engine. I have bad missing in the engine, I have replaced all wires, plugs, cap and rotor. I have replaced the EGR valve, I have replaced the fuel pump and now the injector...


Please help us. I have the same problem with my 99 Jimmy. I was driving on the highway going 70 and then it started missing. Changed all the plugs, wires, rotor and cap but to no avail. HeLP! please email me if you have a solution to this problem. (apollo.morelos@hotmail.com) thanks a bunch.

Oct 29, 2010 | 1999 GMC Jimmy

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

436 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...