Question about 1989 Chevrolet C/K 2500

1 Answer

Running rough I have a chevrolet pick up 1989 year 5.7L engine,its running rough replace all spark plug,spark wire,distributor cap and rotor,check all compression is 150psi,we replace inlet manifold gasket and check for vaccum leak but still the same

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,309 Answers

You have done your home work, go to the egr system, and fuel pressure,

Posted on May 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Engine running rough why?


did you replace the plugs leads one at a time
and not mix up the firing order

is this plug lead layout the same as your engine ?


if the car was running rough before

could be fuel related
or a burnt valve = uneven cylinder compression



index-hpsofzl4yoq5ipvgh24ehjib-2-2.png

Apr 29, 2017 | Cars & Trucks

1 Answer

1990 K1500 running rough. Replaced plugs, wires, sensors. It runs rough with a load on it. Any suggestions?


Check distributor cap and rotor for carbon tracking(cracked cap). Perform compression test.If more than 10% difference between cylinders perform leakage test to find compression leak.

Dec 28, 2010 | 1990 Chevrolet K1500

1 Answer

Got a chevrolet pick up 1989 year 5.7L engine,it


CHECK THE CARB OR TDI MOUNTING BOLTS FOR TIGHTNESS OR CARB OR TBI GASKET LEAKING.COMPRESSION ACCEPTABLE YOU STILL HAVE INTAKE MANIFOLD LEAK. STOP UP FUEL FILTER.WEAK IGNITION COIL.WORN CAMSHAFT.

May 29, 2010 | 1989 Chevrolet C/K 2500

1 Answer

Engine run rough and miss 3 cylinder


maybe a bad plug switch plugs from 3 to to 2 see does it affect 2

Mar 23, 2010 | 1989 Chevrolet S-10 Blazer

1 Answer

Running rough, spark plugs, distributor cap, rotor


First thing you need to know is which cylinders are missing. Then, don't forget there is an engine beneath the electronics. Do a quick test with a vacuum gauge and do a compression test. Check the distributor shaft for side play. If everything checks out good, then do electronic component testing. have a code check run (many parts stores do this free) and get a chiltons or haynes manual and follow test procedures in there.
I refrain from giving repair suggestions with problems like yours because people keep changing instead of testing parts. When I work on my vehicles or other peoples cars, I do testing to avoid buying expensive parts that most times won't correct the problem. At this point the most I'd suggest is to clean the mass air flow sensor wires with a Q-tip and carb cleaner...that often helps and is free. If you run into a problem with whatever you find, ask and I'll try to help.
good luck

Oct 05, 2009 | 1996 Chevrolet Suburban

2 Answers

1989 Full Size Ford Bronco 302 won't start


pull number one spark plug and put your pinky in the hole, rotate the engine with the starter solenoid and when u feel pressure at max u are near or at number one cylinder top dead center, bring the timing mark to 10 deg BTDC and then pull distributor and point the rotor to number one plug wire terminal.

Apr 27, 2009 | 1989 Ford Bronco

1 Answer

95 GMC Jimmy 4.3l W vin rough idle


My problem was solved when I repaired my 4 wd activation dash switch. The switch was contacting on 2WD & 4HI at the same time. The front differential activation is vacuum activated possibly creating a tug of war that didn't actually engage it but drained off vacuum from the engine? A theory at best but stumbbled across it because I knew the switch wasn't working properly I repaired it and low and behold rough idle disappeared and all is good for 3 weeks running.

Nov 17, 2008 | 1995 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

74896 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7688 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...