Question about Chevrolet C1500

1 Answer

I took my 1993 chevy truck to a mechanic to change the head seals and i got it back with over heating problems and after a couple days it started eith high iddle i changed the radiator thermostat clutch fan temperature switch map sensor trottle position sensor and still no luck some body have any idea what can i do next

Posted by on

  • josevcorona2 May 29, 2010

    i already change the water pupm and still no, luck?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 117 Answers

Head seals?? Do you mean head gasket? So it overheats & high idles? It almost sounds like the wrong head gasket was used (its possible) also, if the vehicle overheats, have you looked at the water pump? I would worry about the overheating more than the high idle.

Posted on May 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Starting Problem hyundai 2007 model


Check the coolant again. It could be over heating. Caused by a bad head gasket again. Did your mechanic have the head milled flat when he replaced the gaskets?

May 25, 2015 | 2007 Hyundai Veracruz SE

1 Answer

At first my 1997 Oldsmobile Cutlass Supreme (only has 59,000 miles) after driving for a while the temperature gauge would start to rise when idling but when I started driving the temperature would go back...


This sounds more like the thermostat is not opening as it should, instead of an ECM problem.

With the indications you state - goes down when heater activated - goes down when moving, that is what I would have checked first, not the cooling fan!

Jun 01, 2011 | 1993 Oldsmobile Cutlass Supreme

2 Answers

My truck has a hard time starting when its the first time of the day and it backfires and blows white smoke during this process but after running the RPMs up for a while it finally smooths out and runs...


My 94 chevy with a 5.7 seems to foul a couple of spark plugs at the back of the engine on the drivers side quite quickly. My uncle who is a mechanic said he has seen same problem many times on that engine.
I sugest you pull your plugs and clean or replace if necessarry.
The first time I changed the plugs on the truck to fix a rough idle , I started at the back of the passenger side and worked my way around.
Of course , the last 2 that I got to were the problem...... Heartless uncle just laughed.
Also , white smoke just at start up could indicate worn valve stem seals.

Feb 28, 2010 | 1993 GMC Sierra

1 Answer

Crank but no start


Check all vacuum lines to the parts that were removed

Jan 01, 2010 | 1993 Chevrolet S-10 Blazer

1 Answer

95 gmc siera runs great then dies every couple days


check to see if there is white color in the oil it might be water getting into ur oil if thats the case it might be head gasket leak ..the car will over heat the computer will shut the engine down,,good luck ,,Joe

Aug 29, 2009 | 1993 GMC Sierra K1500

2 Answers

My 1993 jaguar is alway over heating .what do i do?


Nothing, you must fit a working fan, wether new or secondhand.

May 06, 2009 | 1993 Jaguar XJ6

1 Answer

Oily spark plugs


check the knock and o2 sensors

Apr 13, 2009 | 1993 Chevrolet Suburban

2 Answers

Transmission problems.....


I own a 2005 Chevy impala too I took it back were I got it from and they check it out you transmisson fluid might have thined out take and have it check asap!!!!! I'am not a mac. but I am sure thats not good they took it stright to the rack and changed it and flushed it out you might have got some bad transmisson fluid. Thats what they told me do that see how that works for you.

good luck

Oct 17, 2008 | 2005 Chevrolet Impala

2 Answers

Problem with engine


did you have the head gasket replaced or the intake gasket replaced. it's important that i know exactly what they did to your engine. i will be able to pin point the exact problem

Aug 31, 2008 | 1998 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...