Question about Oldsmobile Alero

1 Answer

I have a 99 oldsmobile alero that the coolant fan wont come on. I have switched relays around from fan 1, and fan 2, and have switched the fan mode relay. Im still having the same trouble. do you think it could be the coolant temp sensor, or something else ? I have also checked all fuses.

Posted by on

  • kerrybrentdu May 28, 2010

    i have a 99 oldsmobile alero, and the fans wont come on at all. I switched the relays around, and checked all fuses, and dont find a problem. I wired the fans direct to check the fans, and they are good. do you think it could be the temp. sensor, or something else ?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,608 Answers

Make yourself 2 jumper wires and remove the connector from the cooling fan.Put one wire to battery positive and one to negative.You can use a fuse on the positive wire so if you touch metal it will blow the fuse and not melt the wire or short out some thing else.Make sure you hook up the positive to the positive for the cooling fan.If the fan is good it should run.If it does not then replace the fan motor.If it does then it could be the coolant temp sensor.Let me know what you come up with or if you need more help.Good luck.

Posted on Aug 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Radiator fans randomly shut off


  • Relays carry high-amperage current controlled by a low-current switch
  • When a faulty relay is not replaced, the circuit will either be non-functional or remain engaged. here's your relay you need.
http://www.autozone.com/cooling-heating-and-climate-control/relay-radiator-cooling-fan-motor/duralast-relay-radiator-cooling-fan-motor/oldsmobile/alero/1999/4-cylinders-t-2-4l-sfi-dohc/221833_0_0

Aug 16, 2015 | 1999 Oldsmobile Alero

1 Answer

My 99 Honda Accords keeps overheating on and off when my car is on park or at a long stop. What can be the problem?


FIRST OF ALL I WOULD REPLACE THERMOSTAT AND RADIATOR PRESSURE CAP THEN CHECK SEE IF COOLING FAN RUNNING.WHILE CAR OVERHEATING. IF NOT CHECK COOLING FAN FUSE AND RELAY.IF ALL IS GOOD THE ENGINE COOLANT TEMPERATURE SENSOR COULD BE FAULTY.HOT WIRE SEE COOLANT FAN WORKS IF NOT, COOLING FAN MOTOR BAD NEED REPLACING.IF COOLING FAN MOTOR WORKING PROBLEM COULD BE IN FAN MOTOR WIRING OR PCM FAILED.

Sep 20, 2011 | 1999 Oldsmobile Alero

2 Answers

I have a 1999 Alero 3.4 V6 the cooling fans won't run. I checked the fans they both work if I unplug the harness for the temp sensor,the relays and fuses are fine,I replaced the coolant temp sensor and...


CHECK MODE RELAY IF BOTH RELAYS GOOD YOU CAN CHECK RELAY BY REMOVING IT FROM FUSE BOX HOOK RELAY TERMINAL 85 TO BATTERY POSITIVE AND GROUND TERMINAL 86 IF CLICKS RELAY GOOD. IF RELAY GETTING POWER GOOD AND THE 30 AMP COOLING FAN FUSE OKAY.EITHER THERE IS A SHORT IN COOLING FAN WIRING OR THE PCM HAS FAILED.THE PCM HAS LOST OR COMMAND RUN CIRCUIT IN PCM SHORTED OUT DUE TO PCM FAILURE.LET DEALERSHIP OR GARAGE USE DIAGNOSTIC EQUIPMENT TO ACTIVATE THE PCM SEE IF IT HAS FAILED.DONT SPEND MONEY ON NEW PCM COULD BE SHORT IN THE WIRING CIRCUIT

Sep 06, 2011 | 1999 Oldsmobile Alero

1 Answer

My radiator fans 2001 olds alero do not come on. i have change relays and new coolant sensor. are there 2 sensors


Check radiator fan relay first by changing with another with same part number in the fuse panel.If its good check for 12 volts at the fan switch coming in and going back out.If their is going back out replace fan switch.

Jul 13, 2011 | 2001 Oldsmobile Alero

1 Answer

Why my oldsmobile alero 1999 wont keep water in


CHECK FOR COOLANT LEAKS AROUND THE RADIATOR LOOK DOWN BETWEEN COOLING FANS AND RADIATOR SIDES FOR SIGNS OF ANTIFREEZE.CHECK ALL RADIATORS HOSES AND HEATER HOSES.IF ALL LOOK GOOD CHECK ENGINE OIL FOR COOLANT LEAKS.IF OIL LOOKS LIKE MILK SHAKE COOLANT LEAKING IN CRANK CASE.YOU HAVE A HEAD GASKET LEAK.YOU NEED TO CHANGE OIL + FILTER. GET THE HEAD GASKET FIX.BECAUSE LEAK IN THE CRANK CASE WILL LOCK UP THE ENGINE.IF CRANK CASE OIL LOOKS OKAY.YOU DONT HAVE THE COOLANT CORRECT MIXTURE.YOU SHOULD HAVE 50/50 ANTIFREEZE AND WATER.

Apr 23, 2011 | 1999 Oldsmobile Alero

1 Answer

My Alero heats up when I stop at a traffic light. Everything checks out ok. No leaks, new temp sensor, etc. Any ideas?


CHECK COOLING FAN SEE IF ITS RUNNING.IT NOT CHECK COOLANT FAN FUSE AND RELAY.IF ALL IS GOOD HOTWIRE COOLANT FAN SEE IF IT RUNS.IF NO REPLACE FAN.IF YES CHECK FAN WIRING AND CODE SCAN VECHICLE FOR PCM FAULT CODE.

Feb 26, 2011 | 1999 Oldsmobile Alero

1 Answer

How do i know my ETS is on on my 99 olds alero


IF YOU TALKING ABOUT ENGINE TEMPERATURE SENSOR.MOST OF TIME WHEN IT GOES BAD.YOUR ENGINE WILL OVER HEAT.COOLANT FAN WONT TURN ON.I SEEN A BAD COOLANT TEMPERATURE SENSOR CAUSE ENGINE STAY IN OPEN LOOP.CAUSE POOR ENGINE PERFORMANCE.FUEL CONSUMPTION.

Sep 22, 2010 | 1999 Oldsmobile Alero

2 Answers

1999 Alero: where is the a/c control tempature :problem is wh...


WELL TURN ON AC MAX COLD HIGH TO SEE IF COOLANT FANS TURN ON.IF NOT YOUR REFRIGERANT SO LOW THAT THE AC REFRIGERANT PRESSURE SENSOR WONT CLOSE CIRCUIT TO TURN ON COOLING FANS.MEANING YOU NEED HAVE AC CHECKED AND CHARGED.ALSO CHECK COMPRESSOR FOR POWER IF NOT YOU HAVE BLOWED FUSE OR BAD RELAY.IF FUSE AND RELAY GOOD YOUR AC COMPRESSOR CLUTCH COIL OPEN OR THE AC CONTROL SWITCH IS BAD.IF COMPRESSOR IS RUNNING WHEN YOU TURN ON AC YOUR AIR TEMPERATURE ACTUATOR NOT WORKING.

May 17, 2010 | 1999 Oldsmobile Alero

1 Answer

Radiator cooling fan


check coolant first .if all good .hot wire the fan make sure the electric fan motor is operating.if runs when hot wire.replace the relay and coolant temperature sensor.if fan dont run.when hot wire.replace the fan motor.

May 30, 2009 | 1999 Oldsmobile Alero

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7768 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...