Question about 2001 Ford Escort ZX2

1 Answer

Is the speedometer hooked into transmission somehow, had transmission kit put into transmission-all of a sudden speedometer not working

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,317 Answers

There is a speed sensor mounted on the transmission. Here is picture of it. It may be bad, or didn't get plugged back in.


is the speedometer hooked into transmission - 60bb22a.jpg

Posted on May 27, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i connect a wrangler speedometer to a turbo 350 transmission


Your factory tach won't be accurate because a 350 is an 8 cylinder engine. I put a 350 into a Vega, and my speedo was slightly off because of the differences between the ratios as well. I recommend looking for an aftermarket adapter, or a kit if you can't get the cable to connect into the tranny.

May 06, 2014 | 1990 Jeep Wrangler

1 Answer

My speedometer is not working. we already try to replace a new sensor and panel gauge but still is not working. Electerical was also checked and there were instances my speedometer works but suddenly it...


if speedometer and odometer are not working, chances are that the speed sensor is bad and stopped working. find vehicle speed sensor on transmission, the connection may be corroded or the sensor itself is bad. good-day !!

Jul 07, 2011 | 2000 Honda Civic

3 Answers

Nissan Maxima speedometer reads 20 mph but actual speed is 40-50 mph, is my transmission going bad?


NO, IT'S NOT THE TRANSMISSION! SOUNDS LIKE A SPEEDOMETER PROBLEM! THAT WOULD BE ONE OF THREE THINGS! EITHER THE SPEEDOMETER, THE CABLE, OR THE SPEED SENSOR! THE SPEED SENSOR WILL USUALLY GIVE YOU A P0500 CODE ON AN OBD-II CODE READER! THE SPEED SENSOR IS ELECTRONIC SPEED CONTROL LOCATED ON THE TRANSMISSION! SOME HAVE A SPEEDOMETER CABLE HOOKED TO THEM, AND SOME JUST HAVE A 2 WIRE PLUG THAT HOOKS TO IT!

Mar 04, 2011 | 2000 Nissan Maxima

1 Answer

Transmission for my 94 Corolla DX 1.8 liter, wont shift regularly. It will on occasion & sometimes I have to raise the RPM'S quite high let it return to idle speed 2 or 3 times in succession & all...


transmission problem...have it checked out first..tell them to put it on a diagnositc machine...speedometer fails to work??..you might need to replace the speed sensor..

Oct 23, 2010 | 1994 Toyota Corolla

1 Answer

Speedometer is erratic


It sounds like the core of your speedometer cable is rubbing the outer housing. The speedometer cable runs from the inst panel, thru the firewall, and onto the side of the transmission that faces the driver. This is not a hard job to do, but, when replacing the cable, take care to not break the ears off of the part that hooks on to the back of the speedometer.

Sep 15, 2009 | 1988 Toyota Corolla 4 Door

1 Answer

Speedometer/odometer not working 2000 kia sportage


Your Vehicle velocity sensor has gone bad or the wire harness has gone bad. Check the wire harness first and if that is good, then replace the sensor. You can find the sensor on the transmission out put shaft on the drivers side. Good luck and keep me posted, be glad to help.

Jun 29, 2009 | 2000 Kia Sportage

1 Answer

Speedometer


Like with many newer cars, there is a speed sensor and wire for the speedometer, not a cable. I would say based on the information provided that when they replaced the transmission everything was not hooked back up properly. For intermitent electrical problems like your guage cluster/speedometer sometimes going blank, a short or bad connection is almost a certainty. Which could explain the overheating as well, the fan is electric and may not be working all the time. To switch the transmission, they probably lowered the engine and transmission out of it, put the engine on the new transmission and then reinstalled the assembly. In the process they may have missed some wire hook ups, or pinched a set of wires in the loom. There are a lot of wires running through the engie compartment and it can be easy to overlook or miss things.

Jan 13, 2009 | 1998 Dodge Neon

Not finding what you are looking for?
2001 Ford Escort ZX2 Logo

Related Topics:

265 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...