Question about Chevrolet S 10

1 Answer

Was getting fire and fuel but not it is not doing nothing? we have checked everything. i have replace the the cam sensor.and it still will not start. can u help it is still back fireing.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 661 Answers

If it is backfiring then it would like to run but cannot for some reason.
Does it throw a code?
What about the crank position sensor? That is the main sensor for timing issues.
If you have all the ignition stuff correct there is still one horrible possibility. While remote and rare it may be that the timing for the valves is off. Do a compression check to verify that.

Knowing the history of this problem would be very helpful as I don't even know what year or engine.

Posted on May 16, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Buick Lesabre hard start


Try depressing the gas pedal once before cranking. If it fires right up then replace the fuel filter. If not then you may need to replace the cam sensor.

Feb 20, 2013 | 2000 Buick LeSabre

1 Answer

2005 Nissan Altima Cranking but not firing


see if you have 5 volts at cranshaft sensor

May 22, 2012 | 2005 Nissan Altima

2 Answers

1997 dodge ram won't start. My fuel pump does not run and coil won't spark. Iv'e checked fuses and relays and they look fine. Could a bad fuel pump cause the asd to kill power to the coil?


First check any ignition/fuel related fuses. Check to make sure you have 12 volts coming into the pump and coil. If nothing to the fuel pump replace the fuel pump relay - if you do have power to the fuel pump then replace the pump. If nothing is coming to the coil it is either an ignition relay or a wiring issue. If you have 12 volts to the coil but no spark then replace the coil.
Also the fuel pump/relay would not kill the coil.

Jan 21, 2010 | 1997 Dodge Ram 1500 Club Cab

1 Answer

1993 wrangler starting problems


You have to find out if it has fuel and spark . One or the other is missing at the demise of the engine.

May 07, 2009 | 1993 Jeep Wrangler

2 Answers

92 camry v4 wont start


fuel and spark are great but are you getting air? sounds to me if u did a head job possible that cam sensor could be the issue or possible mass air as well i would check those compnents but also check basic starting compnents as well plugs wires ignition start batter connectors and air

Feb 10, 2009 | 1992 Toyota Camry V6

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...