Question about 2002 Mercedes-Benz C-Class

1 Answer

C320 THE ODOMETER GOES FROM 50 TO ZERO AND STARTS TO GO BACK AND FORTH THEN JUST DROPS TO ZERO. FIRST I CHANGED THE HUBS AND STABIZER BAR THIS CAUSED THE ABS AND BAS AND ESP LIGHT TO START FLASHING . I THEN CHANGED THE SPEED SENSOR. THIS DID NOT WORK .

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,489 Answers

If the unit is bouncing quite eratically, this is an indication of a gear/motor issue in the speedometer itself. There are places that repair these but are few and far between. Check out Silverstar Porsche/Mercedes auto recycling in CA. Great service and resonable on prices and will ship. Replace the speedometer.

Posted on May 16, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1991 honda accord lx and one day while driving my RPM gauge started to move back and forth rapidly, it dropped down to zero and my car shut off. i changed the fuel filter and my car was driving...


a dirty or faulty MAF sensor can cause proplems like this. try cleaning it with CRC MAF cleaner you can get it at just about any autoparts store. the MAF is located on the air intake disconnect the electrical connection and remove the sensor be careful not to damage the fragile filaments inside. there is no need to wipe it just spray it clean and let air dry be sure to spray all parts plug, filaments everything

Apr 16, 2011 | 1991 Honda Accord

1 Answer

Oil pressure drops to zero when engine starts then goes to 60,while driving after warm,pressure drops down 4.3 V6 vortec engine


The 4.3 engine should have 20 to 30 psi at idle cold and around 50 to 60 psi running down the road. Has this engine had regular oil changes? If not the problem could be sludge build up. The oil pressure sending unit could be the problem. If in question about the sending unit install a mechanical gauge and watch the pressure.

Jan 02, 2011 | 1999 GMC Jimmy

3 Answers

2005 lexu 330, turn off maintenance light


1. With your car OFF, place your key in the ignition and turn to "On". Do not start the car.
2. Find the odometer button and press until it reads the total odometer setting, (not the Trip A or Trip B setting).
3. Turn the key to OFF.
4. Place your finger back on the odometer button, press and hold. At the same time, turn the key back to "On".
5. Hold the odometer button in until the MAINT REQD light goes out...should take about 8-10 seconds.

page 77 of the 2004 Lexus rx330 handbook...
(you will find the answer you are looking for in resetting your maintenance light.)
with the odometer reading visible, (not trip A or trip B..) turn off engine.

While keeping Odo/trip button depressed, turn ignition back on (not starting the engine) You will see dashes (instead of numbers) on your odometer disappearing one at a time. it will be replaced by 0's (zeros).. Release the Odo/trip button and your original mileage will come up....
And your done..... until the next oil change.

Thank you for using fixya and good luck

Oct 10, 2010 | 2005 Lexus ES330

1 Answer

Tach. drop's to zero while driving 70 ?


I have had the almost same problem twice. A 'thump', like the engine missed a fire and tach drops. Seems OK after restart. Electrical? Timing chain slip?
Has 135,000 mile. Any clues?

May 15, 2010 | 1997 Buick Park Avenue

1 Answer

Toyota Avalon 2001 error code 1155


The cooling temperture send unit is send out of range data to the computer (ECU).

The corrective is to buy a coolant sending unit and replace it.

The unit is withing 6 inches from the thermostat housing.


Since your car is a 2002 and probably has around 80,000 miles on the odometer so it's a good time to all of the following on the same time.


temp. sending unit / clean the contacts

drop bottom coolant has and flush radaiator

change 195 F thermostat and gasket + seal with black RTV.

Fill 50/50 mix coolant. /// if you live in aub-zero temp area then read the chart on the bottle for the recommended mix


Please rate my answer if it's helpful to you.



Cheers,

MUSTGO

Dec 12, 2009 | 2002 Toyota Avalon

1 Answer

Dash lights go on and off, odometer needle drops to zero, races back up, rpm needle drops and races back up as does the gas gage needle. car does not lose power. dash light module???


its a loose connection, i've dealt with it in my truck for years, you can remove the entire dash to check all connections and change lights but its a HUGE job., if you can live with it, otherwise take it to a pro to have it done.

Nov 06, 2009 | 2003 Saturn VUE

Not finding what you are looking for?
2002 Mercedes-Benz C-Class Logo

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...