Question about 2003 Kia Sorento

1 Answer

Hard starting and if eventually starts has poor acceleration

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,489 Answers

Likely failing fuel pump and plugged filter. The system should be tested for proper pressure. On these models, the filter is on the pump inside the tank. This can be accessed by removing the rear seat and you will see an access cover. One more check you can do, next time you start it, let it run for about 15 minutes and look underneath at the exhaust near the engine. If anything is glowing red, this would be your catalytic converter. This would indicate a plugged cat and needs to be replaced. Let me know what you see.

Posted on May 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

89 ford probe hesitates when leaving a red light, then runs fine otherwise, fuel filter?


Engine Runs Rough, Stalls, Hesitates on Acceleration, Hard ...

repairpal.com > Problems > Ford > Probe
Ford Probe Engine Runs Rough, Stalls, Hesitates on Acceleration, Hard Starting, Poor Performance. This is a verified problem based on 9 reports. Learn more ...

Starting Problems - 1997 Ford Probe - RepairPal

repairpal.com > Questions > Ford > Probe > 1997 Ford Probe
Dec 5, 2010 - Starting Problems on 1997 Ford Probe ... If the engine runs rough,stalls, hesitates on acceleration, is hard to start, or has generally poor ...

A new misfire/hesitation on accel. Problem.. - ProbeTalk.com Forums

forums.probetalk.com > Tech Section > 2nd Gen (93-97) V6 2.5L

Feb 05, 2016 | Ford Cars & Trucks

1 Answer

What are the symptoms of a bad fuel filter?


poor fuel delivery, chugging, poor acceleration, stalling, hard starting are just some of the symptoms.

May 24, 2015 | 1997 Toyota Tercel

1 Answer

Bomba de gasolina


Poor acceleration and eventually a no start condition. Your type of car has a problem with a plastic fuel line on top of the gas tank. The fuel line develops a crack and leaks gas. Do you smell gasoline after you park the car. If you smell gas, it is also a safety issue of fire. There is no safety recall yet.

Mar 26, 2014 | 2007 Pontiac G6 GT Convertible

1 Answer

Toyota troubleshooting


Broken rings caused by excessive power maybe. Do a compression check, that will tell you.

Aug 06, 2017 | Cars & Trucks

1 Answer

Hard to start sometimes


You don't say what the year make and model is.
I am going to assume it is fuel injected, so the problem could be a faulty fuel pump or check valve in the pump.
The fuel line should have some pressure before you crank the engine. If the line has low or zero pressure, it takes a long time to pump it back up enough to start the engine.

Dec 20, 2012 | Cars & Trucks

1 Answer

Will start and run only if you hold down the accelerator. as soon as you let off of it it will die


Hello,
It sounds like you may have a faulty MAF, ( mass air flow sensor ).
The ECM, ( electronic control module ), should set the fuel/air mix ratio at 1 part fuel to 14.7 parts air. A faulty MAF can prevent the computer from determining the proper fuel/air mix ratio, and that can lead to bad idle, poor acceleration, fake stalling and stalling. Eventually it can prevent the engine from starting.

I hope this helps you.
Thanks for using Fixya!
Donnie

Feb 18, 2011 | 2001 Nissan Maxima

1 Answer

I have a 97 grand am gt with 3.1 idles fine but normal acceleration and cruise is nearly impossible. Bogs down at all speeds. Hard acceleration is fine goes good.


I had the same problem with my 89 grand am it was caused by a faulty crank position sensor. Initially it would cut out when accelerating and eventually wouldn't start at all, replaced the sensor runs great again.

Aug 22, 2010 | 1997 Pontiac Grand Am

1 Answer

My clutch in my 1998 kia sephia is going out it has a bad smell to it and doesnt like going fast. what is going on


Clutches work on the same principle as your brakes. As they spin with high friction, they heat up. If they heat up too much, they start to smell.

Every time you depress the clutch pedal, you are allowing the clutch to spin and create heat. If you pop the clutch or drive in a stop and go environment and accelerate very hard off the line, you will generate a lot of heat in the clutch. Also, if you were hauling heavy loads or towing a trailer, you can create a lot of stress on the clutch which will cause it to heat up.

I don't know you or your driving style, so it is hard to pinpoint the cause of the smell. It sounds like the clutch is worn to the point where it is starting to slip. There is no solution to make it stop slipping except to replace the clutch. You can nurse the car along for a while, but eventually you will have to replace the clutch. Try to avoid hard acceleration and stop and go driving as much as you can. Also, make sure there is a little bit of play in the clutch pedal at the top of its stroke. There is an adjustment on the actuator rod so that the clutch can be fully engaged. If there is no play in the pedal, that could mean that the clutch is partially engaged. There would not be enough friction on the clutch to turn the transmission input shaft. This, in turn, would cause slip and heat and eventually smell and poor acceleration.

I hope this helps. It may not be the answer you wanted to hear. If you have further questions, let me know.

Feb 18, 2010 | 1998 Kia Sephia

3 Answers

Accelerator sticks at start off - not cable problem - it was replaced and problem still exists. you have to push against the peddle quite hard to get going. Also revs when you stop at traffic-lights or...


The high-idle sensor often malfunctions on those cars. I would check that. If you have a carbureted model, then you have a vacuum actuated sensor on the firewall that sends a vacuum signal to the dashpot on the carburetor that raises the idle speed.

Sep 07, 2009 | 1993 Ford Festiva

Not finding what you are looking for?
2003 Kia Sorento Logo

259 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...