Question about 2006 Nissan Pathfinder

2 Answers

My gas hand dosent work and now my engine is racing but im only going 30 mph someone said that its the sensers on the 91 pathfinder thats makin the problems and the emmissions light comes on some tmes

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 370 Answers

It you engine is racing at 30 mph your trani is not shifting right...
the fuel gage hand id the resister on the fuel pump itself gone bad...
the emisions light you will have to have it plugged in and get the code for me to further assist you...

Posted on May 12, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Nissan Master
  • 77,169 Answers

U have a defective transmission u have a sipping condition, this is no sensor problem., the gas gauge is a separate problem and is caused by a defective sending unit in the gas tank

Posted on May 12, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an 84 mazda rx7 and all it does is crank over but it doesnt start


The engine is most likely flooded. I worked at a mazda dealer a long time ago and the best way to fix it is to remove all 4 plugs and wind it over Not touching the throttle at all.Take an oil squirt can filled with engine oil and put a couple squirts in one spark plug hole of the leading and one plug hole of the trailing.Again turn the engine over about 10 seconds without the plugs in. Wait 20 mins and reinstall the plugs (all 4) then try starting as you would normally. IF this dosent work,,get ur buddy to hook a ROPE to the front of it and tow it.Once you reach about 30 mph with the transmittion in 4th gear let the clutch out (with the ignition switch on so lights r on on the dash) . Let ur buddy tow it a bit like that without touching the gas at all and it should start.IF it dosent,,keep on towing but play with the throttle and it will soon start to run on its own.These engines are the worst thing I ever seen to get going after their flooded.Thats if that really is the problem.Not too much goes wrong with them so Im betting this will work.

Jan 07, 2013 | 1984 Mazda RX-7

1 Answer

Grinding noise over 30 mph


you would have to find out where the speedomator wire/cable
connects
heres some idea

there is a gear at the end of a speedomator cable

try this 1st hit me back if this dosent work

Nov 01, 2012 | Mazda MX-5 Miata Cars & Trucks

1 Answer

Have a slight miss intermidetliy


sir please go to a near by work shop

Mar 05, 2010 | 1992 Honda Accord

1 Answer

91 integra ls with stage 3 clutch slip


Transmission should still be under warranty! Check on it. Throw out bearing might be the problem

Dec 24, 2009 | 1991 Acura Integra Hatchback

1 Answer

Changed o2 senser the rpms are running high. dosent feel like trans. it changing gears, can go 40mph but runs at 5rpms


Look for a vacuum leak around the engine. you can do this with a propane torch, NO FLAME, just the gas will change the way the engine runs when you get near the leak.

Aug 04, 2009 | 1992 Subaru Legacy

2 Answers

1984 CHEVROLET SCOTTDALE 10 PICKUP AUTOMATIC


SOUNDS LIKE A TRANSMISSION VACUM MODULATOR,THET ARE CHEAP,MAKE SURE VACUM LINE DOESN'T HAVE ANY HOLES OR DRYROTTED AND YOU HAVE VACUM

May 19, 2009 | 1984 Chevrolet K1500

1 Answer

Engine races hot or cold


It sounds very much like the idle air valve is faulty as I have just had same sort of problem I fitted a new idle air valve and it has cured mine. Unfortunately these idle air valves are not cheap. They are about £70 from ford but you can get them on ebay for about £30 from partsdome

Apr 13, 2009 | 2000 Ford Focus

1 Answer

When traveling between 35-55 mph. my pathfinder jerks and stalls a little bit. Doesn't seem serious, just anoying. Then just yesterday it wouldn't respond to pressing the gas pedal. It started out very...


You got a problem a sense on the accerlator .Or on the air intake senser.If it's not that I would put gas cleaner in the tank.That would be the cheaps thing to try. Buy your gas at walmart and in the insle that has the tech gas cleaner and buy it there ,it will install it has you pump.

Mar 21, 2009 | 1999 Nissan Pathfinder

2 Answers

Sluggish on the acceleration


I have had same problem I took off the gas cap and then put it back on and it seemed to fix the problem.

Jul 23, 2008 | 2003 Nissan Pathfinder

Not finding what you are looking for?
2006 Nissan Pathfinder Logo

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...