Question about 1996 Buick Century

2 Answers

When you run it half hour it start to buck when step on gas , it

Posted by on

  • saundersecke May 11, 2010

    Well its at the shop now , they call this am said the same thing as you it could be a couple of things , they said plugs and points , control module or coil , they said they would start first by changing plugs then see if that fixed the problem . i love how these garage want to put all these parts on my car an give me a big garage bill !

  • saundersecke May 11, 2010

    well the shop said they put plugs on it and ran it an still did it and now they put coil on said drive it a few day to see if it does it anymore then let them know crazyyyyyyyyy ????

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Buick Master
  • 5,763 Answers

Many thing could cause this, il give you a few things that are common, the maf sensor or a control module or coil pack and last the fuel pump may loose preasure when hot, the first thing i would check is to make sure your converter in the exhaust system is not plugged, this is a big problem and the most common that i see,you start to loose power after running a while so make sure the exhaust is not red hot at or before the cat,hope this helps,

Posted on May 11, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My 96 buick Cenury did the same thing and turned out to be bad coil.

Posted on Jun 08, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car "bucking"


Are you pulling a trailer or have a heavy load - you should not drive in overdrive in those conditions. You will eventually ruin your transmission.

May 19, 2013 | 1994 Oldsmobile Cutlass Supreme

1 Answer

2001 montero wont start


sounds like possibly the timing belt has slipped or broken...or possibly a bad and plugged up catalytic convertor

Dec 03, 2012 | 2001 Mitsubishi Montero

1 Answer

1997 chevy pick up, 4.3 Ltr. Bucks HARD when driving. Was told it needs Higher octane gas, didn't work. Acts like it's got hickups! Any help ?


Check your plug wires, and possibly distributor cap and rotor-If you look at the wires closely you may see a date stamped on them i.e. '98' which certainly would deserve being retired. Your symptoms are classic secondary ignition (wires and cap) and for less than $100 and a half hour to one hour's work will have it running like new again.

Dec 28, 2010 | 1997 Chevrolet K1500

1 Answer

2.2 96 Sunfire will fail to start or if starts will miss.


From the way it sounds you have a fuel pump going out.The fuel pump on your vehicle is located in the gas tank .the gas tank has to be removed from the vehicle to replace the pump.

Mar 09, 2009 | 1995 Pontiac Sunfire

3 Answers

Engine shut down after 15miles then won't start for half hour


just went thru the same think wit a s 430 it was the crank position sensor . 60 bucks at auto zone and it took me 5min. 2 install if u need help feel free to call me 918 808 9706 chris

Feb 20, 2009 | 2000 Mercedes-Benz S-Class

1 Answer

151 4 cyl , runs for 20 min perfect then starts bucking and seems like its starving for fuel and wants to stall. let it sit for half hour and its fine, starts right up. i suspect carb. malfunction have...


Could be carb but you should also look and make sure the fuel supply line is not running near the exhaust manifold or anywhere it could experience high temps as it may be boiling the gas in the line and could be "vapor locking" the fuel line. After it cools, the vapor dissipates and the unit has plenty of liquid gas then. Also check the manual fuel pump if it has one and make sure it is not faulting. The diaphragm could be getting weak and the engine heat could be causing it ti get soft and lose it's ability to draw fuel. Good Luck!

Jul 15, 2008 | Jeep CJ5 Cars & Trucks

1 Answer

93 dodge intrepid 6cyl 3.3


Your fuel level sending unit is not working properly. The fuel pump and sending unit is one thing in the tank. It isn't too bad of a job to replace, it takes about 2 hours. Buy a manual for you car and it'll have step by step instructions on how to do it.

Jun 10, 2008 | 1993 Dodge Intrepid

Not finding what you are looking for?
1996 Buick Century Logo

Related Topics:

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...