Question about 2004 Kia Optima

1 Answer

Changed my spark plugs yester day think i spaced thm wrong car ns

Car was running great but now putts and does not wanna pick up speed

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kia Master
  • 14,036 Answers

EITHER SPARK PLUG GAP INCORRECT GAP IT SHOULD BE 0.028 - 0.032 OR USING WRONG TYPE SPARK PLUGS.YOU HAVE TO USE WHAT THE FACTORY CALL FOR.

Posted on May 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 92 f150 starts missing and losing power when ambient temperature reaches 85 degrees.Can a weak fuel pump cause this, truck runs great on cool days and at night


Check the fuel pressure when it's messing up ! Also check for strong spark ,pull a plug wire off a spark plug an hold to ground ! Ignition problem maybe - ignition module ? A weak fuel pump would be weak hot or cold ! Now electronics are a different story ! I have had ford pick-ups from the age run great cold but when they got hot quit working altogether ,then when they cold down , they started right up again ! The important thing is to test not guess , be sure what's wrong before you replace parts ! There is a good video on you tube from scanner Danner on a ford pick up you should check out ! Good luck ,hope this helps !

Aug 15, 2015 | Cars & Trucks

2 Answers

Not starting. Getting fuel/spark, and compression is good in all cylinders.


I don't think there is any sensor, you might need to check all the plug wires one of the wires might have come loose if they all are good then check to make sure that your getting fuel to the motor even if your fuel pump is working you might have a blockage in the fuel line, double check the timing to make sure that its right because if its off just a hair it will cause the car not to start. once you have done that if it still wont start hit me up and we will go from there ill check to see what else we should do to get your car up and going!!!!!

Nov 16, 2014 | 1990 Geo Storm

3 Answers

My 2000 dodge intrepid will not pick up speed n when it does its very slow. You have to floor the gas pedal to 3 RPM to pick up speed but the car just jolts and goes. We changed the O2 sensor, throttle...


check your ht leads ,coil packs are all functional .then check your spark plugs are not fowled.if this is not the cause it will be your egr valve is not opening correctly.buy a diagnostic scan tool of ebay for around $40 it will pay for its self with time . Great piece of kit you can carry in your dash,,,

Oct 23, 2014 | 2000 Dodge Intrepid

1 Answer

Wont pick up speed shuts off


You might need new spark plugs and wires due to misfire. It is probably a problem with your alternator. Could be something wrong with your catalytic converter.

Mar 14, 2013 | 1991 Eagle Talon

1 Answer

Changed spark plugs now runs rough and has thick white exhaust


Changing the plugs probably had nothing to do with it.
White smoke is usually a sign the engine is burning coolant or trans fluid. You might want to check those fluid levels.
If the coolant is low, you may have a leaking head gasket or intake gasket.

Dec 24, 2012 | 1997 GMC Jimmy

2 Answers

I went through water and stalled engine and have got new speark plugs, wires for them, new distributator cap and rotor. their is no water in oil or in the air intake. what could be probablem. it happened...


you may need to change your fuel filter sounds like you have water in the line. you can put some gas treatment or octane booster in the tank. but make sure that the new wires are in the right sequence for the firing order.

Jan 28, 2010 | 1995 Jeep Wrangler

1 Answer

2000 passat v6; check engine light+spuddering when accelerating


good chance with that problem you were close most likely a misfire will cause that. it would be either your spark plugs or coil pack. also make sure your vacuum lines are good and air filter is good. also bad gas can cause that problem. the worst outcome would be your throttle body going out on you.

Oct 17, 2009 | 1999 Volkswagen Passat

1 Answer

Takes a long time to start,when started it putts.


distributer cap and button are weak it sounds like
put the screw driver in the spark plug boot. close to a ground
make sure its not aluminum.
turn the engine over when its somewhat dark
look for the intensity of the spark.
if the sparks bright then its strong IE if the sparks not strong means its the coil that needs to be replaced.or the wires
More then likely its the cap button or plug wires..
if there is any cracks in the wires they will leak power out.. making it use more gas to make it run.

May 29, 2009 | 1995 Buick LeSabre

Not finding what you are looking for?
2004 Kia Optima Logo

143 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...