Question about 1990 Chevrolet Camaro

1 Answer

MY 1990 5.7 CAMARO RUNS FINE COLD,AS SOON AS IT WARMS UP IT RUNS ROUGH AND STALLS.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 31 Answers

Head gasket?

Posted on May 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1990 1500 runs good when cold but when it warms up rough idle then stalls


Remove the EGR you have carbon,that is keeping the pintle open,if there is no carbon and the pintle is open replace it.

Mar 10, 2012 | 1990 Chevrolet K1500

1 Answer

1990 camaro rs starts after a few tries, runs rough and stalls


I had same problem it was the magnets on the the top of the distributor.

Sep 11, 2011 | 1990 Chevrolet Camaro

2 Answers

Car runs fine when cold, when warm it stalls


My first guess is a vacuum leak or maybe a defective IAC. Tests need to be run to narrow the search down.

Apr 17, 2010 | 1990 Chevrolet Lumina

1 Answer

Cold starts ok warms up shakes and stalls


check engine coolant temperature when it gets warmer, or at operating temperature, and verify that the temperature gauge is showing warmed up to operating temperature. If the coolant temperature sensor tells the computer the engine is cold it will over fuel and miss and the engine will die. When cooled down it will run fine until it warms up. Also could be coil if it starts missing after warmed up.

Aug 18, 2009 | 1990 Ford Bronco II

1 Answer

Loses power and stalls when warmed up


check the fuel pressure,replace the fuel pump-its in the tank

Jun 01, 2009 | 1990 Ford Taurus

1 Answer

Truck runs rough


Sounds like one of your chambers isn't firing. Run your car for a few minutes, shut it off then pull your plugs one at a time and see if one of them is wet. Might just need a new plug.

Nov 28, 2008 | 1990 Ford F150

1 Answer

Stalls when engne warms up


Your ECT (Engine Coolant Temp) sensor is bad. What's happening is at cold start it richens up the fuel mixture and as it warms up the ECM thinks it's still cold and essentially the "choke" is still on. Also check your coolant level. If you don't have enough coolant in you engine/radiator, the ECT doesn't know what to do so it thinks it's cold.

Jul 13, 2008 | 1990 Jeep Cherokee Limited

Not finding what you are looking for?
1990 Chevrolet Camaro Logo

Related Topics:

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...