Question about Chevrolet Silverado 1500

1 Answer

My 1989 chevy silverado will not start with the map sensor plugged in it will start with it unplugged but it will not take any gas it runs like the choke is on

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,489 Answers

Replace the MAP sensor. it is giving a false signal. Let me know what else you need.

Posted on May 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

99 Chevy Silverado 2500 was running fine last night..got gas last night but got it from the same gas station as always...thismorning idle was realy rough,shaking the whole truck...really struggling for...


Have you changed plugs and plug wires lately. Sounds like misfire, possible ! Should also check fuel pressure , plugged fuel filter or weak fuel pump ! Mass air flow sensor dirty, or map sensor .What engine do you have and does yours have How to replace the spider injector on Cheyv motor 4 3 or 5 7 liter

Jan 20, 2015 | 1999 Chevrolet Silverado 2500

1 Answer

1989 chevy surburban


i think map sensor is faulty

Jun 10, 2008 | 1989 Chevrolet Suburban

1 Answer

Bad map sensor?


Yes the map sensor could be faulty.
You should also get a check engine light when you unplug it.

Sep 14, 2012 | Cars & Trucks

1 Answer

1989 dodge ram charger not pump,not filter,not plugs,not wires not rotor or cap will not stay started


Manifold absolute pressure sensor, throttle position sensor, and engine coolant sensor. The MAP and TPS sensors can be unplugged (one at a time) See if this lets the engine run. If either do replace it. Mostly the MAP. The ECT doesn't usually kill the engine just makes it run really bad. To much gas. These also can be check with a hand held computer, More precise diagnostics, the numbers will tell you if they are bad or close to bad. If there are no readings then they are bad. I recommend that you put a computer on it. Because even when I unplug something and think it's bad, I use an ohm meter and check the numbers of the old part against the new part. they should be really close if the old part is good. And I will do this at the parts store, Because once you leave the store with an electrical part it is yours. I hate replacing parts that are not bad. If you know what I mean.

Feb 04, 2011 | 1989 Dodge Ramcharger

2 Answers

1989 Chevy Truck , Stock Radio , Whining noise thru the speakers seems to increase with enginge speed. Radio Grounded ? or ?


Sounds like you have a capacitor problem.It could be a number of issues , but i suggest you check the alternator one first.

If you unplug the power cable to the back of the alternator and the whining goes away then replace the capacitor(usually only one bolt/screw)and you should be OK.

If not I sometimes have dissconnected the + wire from the HT coil when the car is running and the same applies,and if this works replace the capacitor or fit one if there isn't.

If none of this helps fit one to the + wires of your radio.

Please leave fair comment if I have helped you.

Thank you

Sep 01, 2009 | 1989 Chevrolet C1500

1 Answer

2004 chevy 2500 hd 6.0 ltr gas engine 4x4


No and No...And it's the "MAS". "Unhooking" the MAS will place your ECM in the "limp back" mode...in other words it will run like ****.
Did you try the O2 sensors (3)? These are notorious for failing. Try a cheap fix...Buy a can of "SeaFoam" at Advance Auto Parts ($9) and add to your tank per instructions.
Good Luck

Jun 27, 2009 | 2004 Chevrolet Silverado 2500HD

4 Answers

My 1993 chevy 1500 Silverado truck suddenly quits


I put a new fuel pump, fuel filter, and a fuel pump relay and the fuel pump is still not coming on. I am not getting any fuel. Can you please tell me what it might be.

Mar 08, 2009 | 1993 Chevrolet C1500

2 Answers

2000 silverado 4.8 v8 runs bad when it is cold out side.


Try replacing the coolant temperature sensor for the injection system.

Jan 05, 2009 | 2000 Chevrolet Silverado

1 Answer

My 1989 silverado surges really bad in mornings when cold


HI, You need your coolant temperture to run 195 degrees, start by replacing thermostat with correct part and re-check..

Dec 01, 2008 | 1989 Chevrolet C1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...