Question about 2006 Nissan Xterra

1 Answer

SUV cranks fine I think I'm not getting fuel to the injectors. How do I check this?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,374 Answers

Use a stethoscope and place it on the injector and listen for it to click on spray and click off.
Any other testing is dangerous for a DIYer.
The only other test is to hook up a fuel pressure gauge on the schrater vale off the fuel rail and test for residual pressure and running pressure.
If you do this have extinguisher handy , wear eye protection and after testing wiper down fuel rail and any where else fuel spilled during removal of gauge.

Posted on May 10, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

90 7.3 ford diesil cranks but wont start start


check for air in the system . Bleed out at all bleed screws . crack the injector lines at the injectors and continue cranking until diesel drips from the nut. tighten and continue cranking. Check for fast crank speed and glo-plug operation

Jan 11, 2014 | Cars & Trucks

2 Answers

My truck sat up for probably 3 or 4 years cranked and run fine yesterday but today it wont crank at all any ideas?


If it won't crank over, it's not a fuel issue, but a starting circuit issue. The gas may be stale, but if tank was full all that time, I don't think that would be a problem.
Pull off the small wire on the starter solenoid, and see if it has power when key is held in crank position. If power there, the starter or solenoid or the battery connections from battery to starter need to be checked or tested. If no power to solenoid when key is in cranking position, the ignition switch may be bad or the neutral safety switch (or the clutch start switch if a manual) or the starter relay needs to be checked.
If you get it cranking, and still no start, look down the throttle body bore and watch your injector spray pattern while the engine is cranking-you should see a fine, cone spray pattern coming from the bottom of the injector. If it just drips and no cone pattern, or no gas coming out, injectors need cleaning (probably from stale gas). Good luck.

Oct 23, 2012 | Cars & Trucks

1 Answer

Truck will crank but not fire up. The problem started about two weeks ago. It would crank and crank but not turn over right away. Eventually it fired up after maybe 8-12 tries. Over the last several...


I think you may be on the right track with the fuel pump idea. Check your fuel pressure - it could be the pump or just the fiter screen in the tank. You don.t say what kind or year of truck you have - I am guessing the pump is in the tank. (Although you do mention a throttle body / fuel injector)

Dec 14, 2010 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

My car takes at least 3 cranks to start. I had it tuned up and had the fuel injectors tested. The fuel injectors were fine and the fuel pump pressure is fine.


3 times rings a bell,thinking cam sensor,so timing is wrong ,1out of 3 seems to be what they do.
Have to get it on a read out tho,(scanner) Your shop should have one

Nov 06, 2010 | 2000 Oldsmobile Intrigue

3 Answers

I have a 2000 chevy blazer vortec 4.3 thats has the "spider" fuel rail. i have presure all the way to the intake lines. i have spark but it will not start i changee the fuel pump a couple months a...


check the 2 wire molley plug going around the front of the intake down into the injector i have found many of those tend to overheat on the plug just cut it and splice the wires back togehter

Jan 17, 2010 | 2000 Chevrolet Blazer

1 Answer

Put new battery in car. Now it is hard to start. Replaced fuel filter no help. What could the problem be? Engine cranks ok. Seems like fuel not getting to engine. Seems to run fine after it is started....


fuel pump is in the tank but don't think that it is the problem if it runs fine after started. sounds like a cold start problem alot of these vehicle have what they call a cold start injector that supplies the initial fuel to get the car started and then the regular injectors do the rest have this checked and make sure it is working properly.

Aug 28, 2009 | 2002 Daewoo Nubira

1 Answer

1992 bronco crank no start


are the injectors delivering fuel? just because u have fuel press it doesn't mean the injectors are working, buy a tool called a "noid", about $5.00, it plugs into the injector connector and blinks when u crank the engine if the injectors are working, u do one at a time. if not check the wiring harness to the engine, very common to have problems there. I have been a Ford dealer tech for 20 years and my specility is this type of problem, i.e. no starts, the ECM/PCM is not a common failure.

Jun 16, 2009 | 1992 Ford Bronco

1 Answer

97 firebird formula hard to cold start


Check the cold start injector useing a digital multimeter with a bar graph. Unplug the injector wires and insert the probes into the wiring plug, crank the engine and the bar graph should pulse if it does remove the injector and with the wiring reconnected and the injector held over a suitable container crank the engine and observe the spray pattern. If insufficient replace injector. This should be a starting point at least

Jun 05, 2009 | 1997 Pontiac Firebird

1 Answer

1988 gmc k1500 wont start


hi, check the connections at the ecm,i think it's under pass front seat,i've had a couple of those years loose injector signal at ecm connector,if you have a test light you can unplug injectors and test across terminals ,it's a 12v signal at inj ,if lights flash on both while cranking try plugging in one at a time and see if either sprays, if one does and not the other, you would have a shorted injector

May 05, 2009 | 1989 GMC K1500

Not finding what you are looking for?
2006 Nissan Xterra Logo

Related Topics:

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...