Question about 2002 Mitsubishi Lancer

1 Answer

Not running smooth

Seems to be firing on three plugs only and not enough pick up in speed

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 40 Answers

Start the engine remove a plug wire if the engine start more problem that mean its ok
if not that mean wich one u remove its not working
do the same to all plugs and check

Posted on May 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2003 2 stroke evinrude 225 hp outboard will run at high speed about 5-7 min than starts shaking seems like not all cylinders are firing. if i shut off the motor and restart it will run another 5 min.


check the plugs if they wet its getting too much oil in the mix. if dry and black plugs then it could be not enough oil or fuel in mix.

Jun 21, 2017 | Cars & Trucks

1 Answer

Number 2 cylinder misfire at idle. Runs smooth at 1000 rpms


Could be a loose connection at the plug or at the coils. Look at in the dark and see if you see any spark off.

Aug 27, 2017 | 2000 Chevrolet Blazer

1 Answer

Bogs down when shifts into 3rd gear and speed levels out


there are several possibilities. by bogging down do you mean the engine runs smooth but looses power? or does the engine/car start shaking and doesnt want to go any faster? if the engine runs smooth and doesnt seem to be shaking...can you hear a noise from the engine compartment? or a hi pressure noise from the rear of the vehicle - like a vacuum cleaner? if so then you probably have a plugged catalytic converter. if the engine seems to shake the van and looses power until you let up on the throttle slightly then you have a misfiring condition which can be caused by bad plug wires,plugs or a coil breaking down. as you shift up in gears the spark needed to each cylinder is increased and if you have bad plugs,wires or coil the spark wont get to the cylinder when it is needed. see if any of this sounds similar to your condition and request more info from me if ya like. good luck. carefull the converter can cause a fire if it gets too hot!

Dec 30, 2009 | 1993 Pontiac Trans Sport

1 Answer

When driving my 2003 VW Jetta 1.8L Turbo at


replace both and also check for a loose ecm ground

Sep 27, 2009 | 2003 Volkswagen Jetta TDI

1 Answer

Air fuel mixture control sensors


hav u had tuneup n chec fuel injec-thats basic--now u probly shud perform a code scan 1st just to confirm the 02s-ther both found at each muffler manifold-they look like spark plugs n may be difficult to remove

Sep 07, 2009 | Nissan Stanza Cars & Trucks

1 Answer

92' geo metro won't start after spark plug change out.


firing order is wrong, and rings are bad on the weak cylinder or a burnt valve

Mar 23, 2009 | 1992 Geo Metro

1 Answer

Check engine light comes on temporarily - engine chuggs at idle


Before changing you pcm try cleaning your egr valve. remove the valve and see if its stuck in the open position if so use a small pick to clean around the spring.

Mar 12, 2009 | 1999 Jeep Cherokee 4WD

2 Answers

I have a 2001 ford focus


near the fire wall in the back of the engine you have the throttle body where the air goes in the engine 3or 4 inch bellow that there a hose it goes in the air intake start the car you should ear a hissing sound in there the rubber pice that plug in the throttle body got a hole in it block it with our finger the car should run fine that part come with the hose that go in the front hope it help fixya our post thanks pierre

Jul 19, 2008 | 2001 Ford Focus

Not finding what you are looking for?
2002 Mitsubishi Lancer Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

78257 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8836 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...