Question about 2004 Dodge Ram 2500

1 Answer

When I push on the accellerator pedal there are times it doen't do anything no acceleration or anything. after a few pumps it seems to catch and go. Is there a fuel sensor that could be going bad or what. I have a 2004 2500 diesel with a cummings motor.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 196 Answers

The cable is bad replace it that will fix it

Posted on May 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 94 crown vic cuts out at 70mph it feels like it dies. If I play with the pedal and push in on it lightly it'll catch and accelerate and roll for a minute but cut out again


your fuel filter is the simplest answer
Fuel pump is not pumping at the right pressure is the second answer
Or your fuel rail presure releaf valve is going bad

Oct 23, 2015 | Cars & Trucks

1 Answer

My 88 bronco backfires on accelleration. mostly under hard accelleration. could this be a timing chain, or something alse


aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa Advance the timing and make sure the accelerator pump in the carby is working.

Aug 14, 2014 | 1988 Ford Bronco

2 Answers

After oil change on 2010 mercury mariner I hear a whistle when i accellerate


Did you remove any plastic/metal splash shields under there to get to the oil plug/filter?
Make sure you put those back in correctly as they could catch air and make noise if put in wrong.

Other than that, I can't think of anything oil change related that would cause a whisteling sound.

Mar 17, 2014 | 2010 Mercury Mariner

1 Answer

Fitted new mass air sensor engine now very slow to accelerate


LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | Cars & Trucks

1 Answer

Engine hesatates when accellerate


It can be fuel pressure issue or its the problem with accelerator pedal or its clogged filters causing there.
There are many other possibilities.I suggest you to go through the list of help links mentioned below,these will help you to confirm where the actual fault lies:-------
Jerks and Hesitates During Acceleration? http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html
-----------
Loss of acceleration? http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------
Headlights flickering and car hesitates to start? http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------
How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------
How exactly Vehicles Accelerator Pump Diaphragm Works? http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------
2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration? http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------
2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End? http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------
Wheel hop under hard acceleration? http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------
2009 Chevy impala accelerator pedal sensor? http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------
Nissan Pathfinder stalls and bucks on Acceleration? http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------
Acceleration lag problem? http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------
These details will help.
Thanks.



Nov 23, 2012 | Cars & Trucks

3 Answers

Astro HESITATES upon initial accellerating.


My 1996 Astro does the same thing... It has new fuel pump, fuel filter, plugs, wires, cap, rotor, maf sensor, ignition coil, alt., battery, cat converter, im stumped...

Jul 04, 2009 | 1989 Cadillac Sedan DeVille

1 Answer

The rps remains high after acceleration


accellerator or throttle sticking or air leak at throttle body gasket.

May 05, 2009 | 2000 Hyundai Elantra

1 Answer

1987 Toyota supra turbo


it can be the TPS, throttle position sensor,bad or loose intake hoses, bad airflow meter or unplugged, clogged fuel filter.

Aug 05, 2008 | 1987 Toyota Supra

Not finding what you are looking for?
Cars & Trucks Logo

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...