Question about 1985 Mercedes-Benz 190

2 Answers

1982 300TD Runs very good for about 10 minutes then starts to slow down as if I'm riding the brakes.I replaced my fuel filters and it is running cool.What could be the solution to this nightmare?

Posted by on

  • Archie Ferrarini
    Archie Ferrarini May 08, 2010

    The brake float pins?? Can you explain why I would even check them with the problem I stated????

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 196 Answers

Check the float pins on brake caliber

Posted on May 08, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Mercedes-Benz Master
  • 1,619 Answers

Fuel pump, or dying ignition parts, ie cap, rotor, plugs, wires and coil.

Posted on May 08, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RE LK 3504 (35 hp 4 wheel drive Tractor starts, runs 5=10 minutes under load, then slowly fades away running slower and slower until it stops. Restarts in 15 min, same result


Here is an idea.
It sort of sounds like there is a blockage after a while in the gas tank.
If there were sediment in the bottom of the gas tank, it would start and run fine sitting still.
However, when driving it, it would be a matter of a few minutes until the sloshing of the fuel would cause the sediment to mix in with the fuel, and clog the filter screen in the fuel tank.
When it stops, the sediment would settle back down, and in 15 - 20 minutes, it would be clear again.
God bless your efforts.

May 08, 2017 | Cars & Trucks

1 Answer

Runs fast for about 10 minutes


Check fuel filter and pump,check for good spark at the plug lead.

Oct 19, 2015 | 2001 Ford Focus

1 Answer

Cuts out when slowing down. Then starts right back up. Could this be fuel filter plugged?1999 vw passat


be checking emissions controls for vacuum leaks especially with the brakes..

Dec 23, 2013 | 1999 Volkswagen Passat

1 Answer

1992 toyota truck running rough


The reason for the problem can be faulty fuel injectors, clogged air filter, faulty ignition coil, and many more or none of these. These are just assumptions for the problem. The real problem may be something else, so I would suggest you to get your ride checked for the error code and then update your answer indicating error code.

Jul 08, 2013 | Cars & Trucks

2 Answers

1990 Buick Century 3.3 L V-6. Starts fine and runs good while i'm parked .


check the temp sensor. and id replace the one bad injector. these engines have problems with the coil pack. id change it with one at a scrap yard.

Mar 25, 2013 | 1990 Buick Century

4 Answers

2001 BMW 325i problem: Car runs very rough, but no warning lights


Sounds like a fuel problem , have you changed the fuel filter in a while ? could be the knock sensor or the knock sensor module needs to be replaced.

Jul 28, 2009 | 2001 BMW 325

1 Answer

'99 chevy Silverado Z71,5.3 engine.....will not rev when hot.....


try replacing your EGR Valve, or your Oxygen Sensor

Feb 10, 2009 | 2001 Chevrolet S-10

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75005 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...