Question about 1986 Nissan Pulsar

1 Answer

My car stalls while driving, but not while idling or revving in idle. Its an 86 PulsarNX. Soon as I hit the highway, it started to feel like it was gonna die, so I immediately pulled over, after a couple seconds, drove off just fine, then a minute later, same thing. Then as I was going up a steep hill, it died on me, so I backed up a bit, put it in park, started it up again, and drove it up the hill. Then just as I was about to pull into my house, it started to putt and feel like it was gonna die. Seemed like it started to die whenever I went past around 60 on the highway, maybe a gear problem with the tranny? While going up the hill, it died, but came back to life right away. Before all of this, I was driving it around town just fine for about 20 minutes with no problems whatsoever. Soon as I got home I checked the plugs, all fine, checked the air filter, it had some **** in it but I cleaned it out (some foil that may have peeled off a hose or something). I revved it in park for about 3-4 minutes, no problems. The battery is old, but has a full charge. Nothing but the stereo was running while driving. Recently changed the water pump, may have not set the belt back to the right tension. The car had been sitting for months when I got it off a friend, maybe it just needs to be run for awhile? Im not very auto-savvy so theres not a whole lot I can do. Anyways, any help on what the problem might be after reading these symptoms?

Posted by on

  • dudeitskevin May 08, 2010

    Me again:

    Also to add, the RPMs are at 6k while driving 50km/h

    Drove it again, no problems around town at all, only problem is soon as I touch the highway it start puttin, I guess it doesnt like to be consistantly drivin at 50-80km/h. Around town I'm frequently slowing down and stopping, and I almost made it up that hill again, twice, no problems.

    Also, before I insured the car, my brother wanted to see how it ran so he put some chainsaw gas in it, he said he had just put in a bit, could the remainder of this mixed gas be causing a problem here? Cause it seems that its running alot better after driving it around town for 30 minutes, highway still a problem tho.


  • dudeitskevin May 08, 2010

    Plugs and wires seem okay.
    oil is good fairly fresh.
    air filter seems alright, it was a little gunky on the outside, but I blew through it and seems okay, on ths inside its still white.
    Everything else, not sure yet, havent checked.

    I took it out for another drive today, it seems to start choking after about 5kms, whenever it started to choke i'd let off on the gas, after a few seconds it'd go again. Stalled going up a steep hill again, but like before came back to life instantly.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Nissan Master
  • 752 Answers

Even if it looks okay its not okay. do a tune up on plugs, wires, if needed oil change, air filter FUEL FILTER VERY ditributor rotor, cap. important

Posted on May 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does it feel as though it's going to die as I am at idle in park and/or while in gear sometimes?


    2002 4cyl stalls out after revving in park - Drive Accord Honda Forums

    www.driveaccord.net/.../68237-2002-4cyl-stalls-out-after-revving-park....
    Jan 25, 2012 - After driving around all day and what ever, I noticed the car idling funny, gave it ... It's almost as if it's not automatically giving it enough fuel after the RPMS ...Mine will do this if I accidentally hit the gas in park when I'm getting ... 03 EX V6 Accord -- Vibration at Idle?? Help.. - Drive Accord ...
    Apr 29, 2009
    88 Accord idle issues - Drive Accord Honda Forums ...
    Mar 17, 2009
    More results from www.driveaccord.net

Sep 29, 2015 | Honda Accord Cars & Trucks

1 Answer

When i am idling in drive the car starts to stutter and feels like it is going to stall. when driving everything seems ok just when it idles i feel it. any ideas on what this could be and if it's


Usually your pcm, (onboard computer) will pick up anything out of the ordinary and set a check engine light. this will point you in a direction if the code pertains to the idle issue. If no check engine light, then being a ford you may have carbon build up behind your throttlr body butterfly valve/flap. this will cause a rough idle, as well as issues with your egr valve and your idle air control valve. Its really kinda difficult to diagnose over the phone so to speak, especially if you are dealing with a problem that your pcm will not pick up.

Feb 21, 2012 | 2002 Ford Explorer

1 Answer

2002 Toyota Camry stalls out after i disconnected the battery. It idles rough, rpm's just keep decreasing until it stalls out.


Hello. Welcome to FixYa. Please allow me to assist you.

What you have is this: Disconnecting the battery caused your car's computer to lose its 'base idle' parameters. This info is kept in the computer, but, removing power to the computer allows the info to be erased, so to speak.

This is, unfortunatly, a normal condition, and, easily rectified.

What you need to do: Get in the car, start it up, and drive it; simulating stop/start city traffic, and then take it out on the highway, hit passing gear a few times, pull off, and let it idle 30 seconds and repeat highway speed, and passing gear a few more times, then simulate city traffic again. You might need to apply a slight bit of gas during the idle periods of the drive. If you do it right, you can reset the base idle parameter under10 minutes.

If you have any questions, please feel free to get back to me via reposting.

Thanks for choosing FixYa for assistance today.

Aug 02, 2011 | 2002 Toyota Camry

1 Answer

My '97 Kia Sephia has a stalling issue. It starts fine, and if I just let it sit and idle it has no problem, although it has started making a sort of ticking sound as it runs. As soon as I hit the gas,...


does it have a check engine light on? if so i would start with getting that code pulled most auto parts stores will do it for free. it could be any number of things that are going wrong with it.

vacuum leak, egr problems, faulty cps... ect

if you don't think it's safe to drive and you can't fix it on your own then i would suggest having it towed to a shop.

Jun 19, 2010 | 1997 Kia Sephia

1 Answer

Starts/stalls won't run until pedal tapped, 2 miles in town, 6 miles highway, then1000-1500 idle. shut down 9 hours, start/stall tap pedal runs return 6 mi. highway,2miles town same high idle. checked code...


Check your IAC motor (Idle Air Control) It could be sticking open.
Ps. Might be called Idle Speed Control motor it depends on the make and i forget what chevy calls theres.

Mar 11, 2010 | 2000 Chevrolet Malibu

1 Answer

Idle loops


the egr valve could be sticking causing this issue put a vacuum gauge on the egr valve to draw a vacuum then release it to see if it sticks

Feb 27, 2010 | 1994 Toyota Pickup

1 Answer

OVER REVVING RANDOMLY IN MITSI VIENTO OR GALANTE 1996


Check into the automatic idle system.It may just need a good cleaning.

Aug 28, 2017 | 1996 Mitsubishi Galant

1 Answer

2001 Alero revving too high


SOUND LIKE IDLE SPEED CONTROL IS FAULTY.

Sep 14, 2009 | 1999 Oldsmobile Alero

Not finding what you are looking for?
Cars & Trucks Logo

317 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...