Question about 1996 Mazda MX-5 Miata

1 Answer

Washed car...lift hood to wash leaves...car started, then sputtered and cut off. It looked like it was out of gas, so I put gas in it. Now it starts, but is skipping and sputtering and will not go...water in plugs maybe...thanks, Sally

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,033 Answers

Yeah, you sound like you have water down in the plug/wires. You will need to dry out the wires from the plugs to the coil pack. You can buy a solution spray to dry these out faster than air dry. But it will have to be dried before it runs good.

Posted on May 08, 2010

Testimonial: "Thank you so much! I REALLY appreciate it! Wow, what a great source!"

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Washed out performance Literally!


Did you get the alternator wet?
Have somebody measure the voltage in the alternator, just to get that out of the way.

May 14, 2017 | 1987 Chevrolet S-10 Pickup

1 Answer

I had a new alternator put on and ever since while i'm stopped & or parking my car is idlding and acts like its going to cut off. is that timing it didnt start till after put on alternator


Hi Cindy,need to check and see if the belt is turning tightly,they may have not done it,to check,open hood,start engine,leave in park,go to engine,find accelerator cable and rev up gas and see if belts are turning tightly,or have someone rev gas in car and someone watch.Also look around engine to see if they let something out of place,you never know these days,even at dealers.

Sep 25, 2013 | 1999 Nissan Altima

1 Answer

Why do i have to rev. my engine to start my kia rio everytime after i put gas in the car


I had the same problem with mine about two years ago. The problem drove me nuts for six months. The solution was replacing the purge valve on the intake of the engine. With the purge Valve hung open when refueling raw gas vaper is washed into the engine causing the engine to become flooded after fueling. Hope this helps and good luck.

Aug 13, 2012 | 2006 Kia Rio

1 Answer

My car doesnt start after i wet under the hood


Keep the hood up, maybe blow a fan on it. You probably wet the wrong thing or connection. Rule of thumb, keep engine running while spraying it, and take for a small highway drive afterward to dry it out.

Mar 07, 2012 | 2003 Kia Rio

1 Answer

I have a 93' LT 1. for the past couple of days ive had a serious problem with my car. it was working fine on sunday, i washed it up, i needed to get the dirt/gravel out of the wheel wells (the motor...


sounds like water in distrubutor cap - pull cap and check for moisture/carbon arcing (gray lines )- engine got hot- water evaporated of back of block- got into cap thru vents on bottom- no escape when cool- repeat

May 11, 2011 | 1993 Chevrolet Corvette

2 Answers

Well i have a 1983 chevy s10 2.8 and its been broke down for awhile i just put a full tank in before i was having this problem the thing is it started just fine from the gas station and it was fine for two...


sometimes if a fuel pressure regulator goes bad , you will be able to smell fuel fumes under hood. a leaking pressure regulator will cause---hard starting, poor fuel economy, stalling, check engine light, gas smell under hood. also check all fuel lines under hood.

Dec 20, 2010 | 1983 Chevrolet Chevy

1 Answer

My 98 Saab 900s started to sputter a few days ago. I put new spark plugs, dist. cap and rotor. The air intake is clear and the hose has no cracks. It still sputters in low rpm at idle and when driving it...


change your fuel filter and check the fuel pressure on the fuel pump you may have gotten some bad fuel try some STP gas treatment make sure you have a half tank of gas and add a little more go somewhere you can drive 55MPH give these websites a try www.alldatadiy.com and www.autozone.com wish you the best of luck Michigan Man.

Mar 02, 2010 | 1998 Saab 900

1 Answer

Starter kick back


If this is a gas engine, check the ignition coil or plug wires. A simple test...

Start the truck at night, then look under the hood while it's running. Don't use a flashlight or your headlights; it should be dark !

If you see sparks anywhere around the engine, you've found the problem. Now you can turn on a light to see where they're coming from - probably from a cracked ignition coil.

Good luck !

Marco

Feb 05, 2009 | 1999 GMC Yukon Denali

Not finding what you are looking for?
1996 Mazda MX-5 Miata Logo

Related Topics:

125 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7710 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...