Question about Toyota Land Cruiser

1 Answer

HINO NO4C MOTOR STALLING ,HAS NO DTC CODES ,ENGINE STARTS FOR ABOUT 10 SECONDS THEN SHUTS DOWN !Fuel filter replaced,found small amount of metalic in bottom of bowl!Air filter ok and no leaks,some times ok for a day then returns to stalling!

Posted by on

  • rshipcot Jul 18, 2010

    Problem has been solved

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 630 Answers

Sounds like a fuel tank inspection/flush or replacement is on the horizon.... sometimes dirty fuel has contaminated your tank or the tank itself is rusting from the inside out... either way it needs to be addressed... drain the tank analyse what gets drained for particles and water...send the tank to a radiator shop for a complete boil out/inspection....blow out the lines and replace the filter again along with the fuel bowl etc. after that all should be well?

Posted on May 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 jeep liberty 3.7L engine miss on 2 cylinders engine revs to 2800 rpm and shuts down comes back on at 2300 rpm and repeats.


stalls?
ok stalls are complex. there are over 50 causes.
no , im no listing them..sorry.
ill not tell you to read a book, but they do tell you how to diagnose all engines. made... no kidding.
so what is it.
so the CEL did not come on as the engine SHUTS DOWN.
then that means it never fully stalled. (a key fact)
but was the throttle dead, at the SHUT DOWN? key fact 2.
if the throttle is dead, at stall.
then that is the ASD relay cutting out.
if you had scanned it at the stall it be obvious with DTC's stating that fact. in fact 8 reason there are for that.
if not asd drop this try this.
1: lost spark, never tuned up in 10 years, so spark ends.
2: lost of fuel pressure.
there is my guess, 3 things. (i skipped bad engine, (loss of compression hot)

Got P03xx codes, DTC errors. that be top of list
here is the ASD list

http://www.fixkick.com/Jeeps/ASD.html

fixing stalls with no scan tool is like juggling blind.....
buy one or rent one.?

Aug 22, 2015 | Jeep Cars & Trucks

1 Answer

1992 isuzu pickup,2.6 engine , surges up and down after 10 minutes then shuts off


1992, PICKUP, in USA? what country , ? cars are not same all over earth. sorry.
engine surges, then stalls. correct.>?

nice testing , rare here, real nice !!!!
spark good as it stalls
so if engine is ok, compression, (seems cat is not melted with 20 " HG)
is flooding or starving for fuel,.
one or the other, you can find that out.
if spark timing was ok, then the belt did not slip. on cam)
leaving only fuel issues.
so DO the magic , WOT, cranking trick this trick (logic in ECU)
cuts the injectors dead, cranked, to unflood all engine with EFI.
do that?
check spark tips, for 3 to 4 hours dead.? be next
2.6L (is 4 cylinder.) is cam belt drive, i never fail to check it first
the fail, at 60k miles, all do. all rubber band engines do.,

if all this is ok, not flooding
one can start engine with test fuel, and even keep it running
even with (hint) fuel pump relay pulled.
if that works, the fueling is wrong.
injectors leaking,? ?
if only one spark tip is wet , soaking in fuel, Injector issues.

when it stalled pull all 4 plugs and look at the tips.
(if cam is timed right) be super super first thing, on this 4 banger.

Mar 08, 2017 | 1992 Isuzu Pickup

1 Answer

Hi. i have a 1986 mazda 626, with the 2.0 4 cyl engine. car sat for a year or two. i replaced the driver side c.v., and the clutch. after some tinkering i got the car to start. but, for some reason it...


If the cars stays running for this amount of time I would replace the fuel filter to start. If it continued after this , check the fuel pressure and replace the pump if necessary. The only other thing I would be concerned about is the security system. But these usually only let the car run for about 2 to 3 seconds before shut down.

Jul 29, 2011 | Mazda 626 Cars & Trucks

1 Answer

My car doesnt accelerate properly as it hits 20mph and holds back for 10 to 15 seconds cleaned sensors(idle,mass or maff sensor and sensors around) and changed wire set and spark plugs and fuel filter


run it without the air filter and see if it makes a difference. does it shake? missfire? any DTC's(diagnostic trouble codes), Check engine light on? Does it do the same thing when in park and pressing on the gas gently? Does it bog down? It can be as simple as the air filter. The other thing that comes to mind is the intake manifold gasket. Try spraying some starter fluid around the intake manifold(car on) and see if the car stalls or shakes.(do this step with engine started from cold for your safety)

Mar 09, 2010 | 2002 Chevrolet Malibu

1 Answer

Our 1999 Chevy Truck looses power after the engine warms up. We have changed the knock sensors, o2 sensors, catalitic converters, and the fuel pump relay? What are we missing?


Have you had the s10 scanned for the DTC codes. Auto Zone scan free of charge and this should help figure out why your loosing power when the engine warms up. You could have a faulty MAP sensor or a weak fuel pump, dirty fuel filter.

Not knowing what has been done, here is a few things you can do and check.

You may be weak on fuel pressure, even a couple of lbs low on fuel pressure can cause low performance.
Double check cold start cranking fuel pressure. If under 63-62 lbs you have problems. Run the full fuel pressure test and post back pressures.
Here is the guide lines on testing.
Check cold start fuel pressure.
Check engine running fuel pressure.
Check engine running on the road fuel pressure.
Then shut it off and watch for fast leak down.
Pinch off at rubber part or block off return line and check full pressure.
Later V6 and V8 gm engines should have 60-66 fuel pressure.
Cold start should be 64-65 lbs of pressure.
If you do not have full fuel pressure on a cold start the injectors will not squirt fuel.
Engine running should be 60-66 lbs pressure depending on engine load.
Full pressure with return pinched off should be 75-85 or more.
And if it has a fast leak down after shut off you have a leak.
Post back fuel pressure readings.

The 75-85 is only a check on the capable full pressure of fuel pump.
If you can not find the rubber return line check full pressure by plugging return line or just or the true full pressure can be taken direct at the end fuel filter.What are the pressure readings that you have done.
What are your cold start pressure readings?

You need 3 things.
Compression
Good hot blue spark to all plugs.
Good gasoline and proper fuel pressure. 63-64 lbs.
If you have all 3 then move on to injector pulse to all injectors.
I think each injector is on a separate driver on that one.
Check for pulse to all of them.

The next thing you can look at is the Cap and Rotor, inspect for any damages and corrosion which is common to accumulate in the distributor due the a clogged vent screen at the bottom of the distributor. That is where is ICM is located also and my be on it's way out and needs to be replace.

Best thing to do is check for any DTC codes at Auto Zone and that should help determine what is causing your loose or power. A bad fuel pump and dirty fuel filter will not trip any DTC codes.

Start with the simple and check all the fuses, the wire leads to the MAP sensor, it's located on the passenger side on the intake manifold by the throttle body. Check then check the distributor Cap and Rotor and replace, check the fuel pressure reading, and almost forgot to check the MAF sensor.

Try this in the mean time, turn you ignition to the run position "engine not running" and pull the fuse to your ECM for 1 min and place back in. Turn your ignition off for 5 sec and turn on again for 10 sec and then start the engine. It may stall out, let it. just start it again and let idle for 2 min and go for a test drive. This will reset your ECM to default and relearn all the sensors on the engine and transmission. Any DTC codes will have been erased and any DTC codes will be new to the issues your engine is having. Good luck and keep me posted, be glad to help you get your S10 running 100% again soon.

Jan 26, 2010 | 1999 Chevrolet S-10 Pickup

4 Answers

98 Saturn SL2 - Stalling issues


I had a problem with starts on my 98 sc2, did it twice only, but it would start up, shake a bit then shut down like it wasn't getting fuel, or a wrong mixture. Replaced the coolant temperature sensor and starts / idles like new now... goodluck

Jun 22, 2009 | 1998 Saturn SL

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

777 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8215 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...