Question about 2002 Chevrolet Blazer

1 Answer

Vortec 4wd 2dr auto trans stalls while drive

I have a 2002 blazer vortec 4wd 2dr auto trans i was at a stop, temp was at normal max, rpms were at normal, tack jumped up and down a couple times with no rpm increase it stalled, restarted fine, stalled again restarted fine again, drove the rest of the way home fine, this has happened a few times at a hard start gauges jump around in ignition on position while not running now driving at various speeds tach jumps around no rev of engine nothing has changedand stall, neutral starts fine... what the... could this be, cleaned mas air flow changed coolant temp sensor put different fuel and cleaner in

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 52 Answers

You might want to look at your O2 sensors, they can cause the motor to run lean or rich. also you might have an electrical issue that is tripping your ECM. your electronic control module might be faulty. best solution is to get a trouble code reader and find out what your on board computer has stored. from there you can repair and clear the codes.

Posted on May 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi my name is chris i have a 2001 chevy blazer 4x4 for so reason it keeps putting itself into 4x4 when i stop at a light or stop sign and won''t let me put it back into 2 wheel drive ?


There's been a lot of problems with the 4wd systems on the blazers of that vintage. The only sure way to track down the cause is to have the system scanned. Some of the most commom causes are: the switch in the dash, - the control module, - the transfer case . There are other issues if it has auto 4wd as the ABS system is tied into that system to activate it when the sensors sense wheel slippage. If your blazer has the auto 4wd funtion and has a ABS light on, it could be in the ABS system.
IF you could get it back into 2wd, you could pull the fuse to the 4wd to dis-able untill you have a chance to have it scanned.

Jun 24, 2011 | 2001 Chevrolet Blazer

1 Answer

Intermitent electrical problem - 4wd lights flash


have the sensors on the trans checked this is a common problem

Apr 19, 2010 | 2000 Chevrolet Blazer

1 Answer

2001 chevy blazer


Sounds Like you lost the front pump in the trans. Onley way to confirm is by checking chking the pressures at the trans. If you have the gauges you can probably do this yourself although a trans shop is recommended.

Jun 02, 2009 | 2001 Chevrolet Blazer

1 Answer

Stalls when placed in reverse


well you have convertor lock prob prob a sensor for trans let me know hey till fix ya bouy me ok

May 23, 2009 | 2005 Chevrolet Colorado

1 Answer

02 escape 4x4 3.0L TRANS OVERDRIVE


I would recommend taking it to another tranny shop. Because if the tach is higher than normal then more than likely its slipping. Eather way what ever it is. I wouldnt wait till the last min, because it could be just the tranny pump and if so then it can be saved before it wrecks havoc on the tranny.

Jan 27, 2009 | 2002 Ford Escape

1 Answer

Stalls at stop when at peak temp


My problem wasn't the O2 sensor. Finally threw a code...106 then 107 and 108...Map Sensor and circuit. Checked the wires and found no issue. Then tried to clean the nipple where the hose from the MAP sensor went into the exhaust below the throttle body and I couldn't get a pipe cleaner in there so I sprayed some wal-mart break cleaner in it and continued to attempt a breakthrough and sure enough it cleaned out and now no issue at all. Yay me!!!

Jan 06, 2009 | 1998 Chevrolet Cavalier

1 Answer

Gas pedal Problem


needs to have the throttle cable ether replace or greased with a frezze protection

Dec 20, 2008 | 2007 Ford Focus (3 Door) Hatchback

1 Answer

1999 Blazer 4wd - Trans jump's HARD to 2nd gear on takeoff


shifts off electric servo controlled by cars computer , see trans guy you can trust could need service ,oil and filter changed or part , like i said see one you can trust .

Jul 17, 2008 | 1999 Chevrolet Blazer

Not finding what you are looking for?
2002 Chevrolet Blazer Logo

218 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8201 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...