Question about 1993 Isuzu Spacecab

1 Answer

I have a 93 isuzu truck, the water will not circulate. Has new water pump on it. If I put water in the top hose and it comes out the bottom hose, put water in the bottom and it comes out the top. Different radiator and still the same. It has the 2.3 liter

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 957 Answers

You may have a defective thermostat. Also check all the radiator hoses. If one or more are pinched and/or collapsed internally that to could cause the circulation problem. The last option is to consider a blockage in the engine block or heads.

Posted on May 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What makes car run hot, and leaks water from top of motor around the belts.


you might want to have your water pump checked, and the soft hose replaced

Mar 11, 2015 | 1999 Isuzu Rodeo

2 Answers

Water not circulating radiator engine running hot


Hi ytabaja97,
Sounds like the thermostat on the hose that goes to the top of the motor is stuck closed, or does not open completely. Try replacing the thermostat. Make sure it is correct for your Jeep, and that the seals on the thermostat housing are replaced correctly.
Hope you have no more overheating problems.

Feb 10, 2014 | Jeep Liberty Cars & Trucks

1 Answer

93 Mercury 150 water will not circulate, just replaced water pump and still having problem


Check the hoses to be sure that they have not seperated internally

Nov 27, 2012 | Cars & Trucks

1 Answer

Heater only blows cold air. I have replaced the thermostate and blown clean the heater core. also replaced a control switch ($280). Sick of getting ripped off.


When the van is warmed completely check the top radiator hose by squeezing it together. If you can squeeze it without any resistance replace the radiator cap. The coolant is not circulating properly and can keep the heater from working. If you cannot squeeze the hose together than you may have a bad water pump. The water pump has fins inside of its' case. Those fins may be rusted completely off to where the water cannot circulate. You can check the circulation by feeling the top and bottom hose coming off of the water pump to the radiator. Both those hoses should be the same temp. If not I would consider changing the water pump.

Mar 11, 2011 | 1998 GMC Safari

1 Answer

I put on new water pump.Motor still gets red hot.could it be rad.


You need to make sure the coolant is circulating. Check to make sure the top and bottom hoses are hot and firm to the touch. If the bottom hose is not hot and firm the water isn't circulating which means the thermostat is stuck in the closed position. Also check to make sure the radiator isn't clogged or doesn't have to many crushed fins that prevents the air from properly cooling it.

Aug 24, 2010 | 2001 Pontiac Montana

2 Answers

2001 kia sportage is over heating but has no leaks. the radiator has been flushed but is very rusty inside. The water is rusty inside the radiator. We have checked the resevoir, it is fine. the water...


Rusty is from running a bad or no mix of coolant. (PH level is off) You may have a water pump that has corroded impellers, and can't move the coolant as well any more. I would start by making sure to flush the engine block again, and make sure you flush water through every possible hose, and where you can get at it.

Jun 14, 2010 | 2001 Kia Sportage

1 Answer

Heater hose routing


heat rises upwards so put the one from the pump to the bottom connection

Jun 12, 2010 | 1993 Dodge Dakota

2 Answers

1997 Saturn SL2 Coolant Leak


you would have a water pump problem at a guess, does the water come from under the front of the engine?if so that is what it will be

Aug 05, 2009 | 1993 Saturn SL2

Not finding what you are looking for?
1993 Isuzu Spacecab Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14380 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...