Question about 1995 Oldsmobile Ninety Eight Regency

1 Answer

The radiator fans aren't working on my 1995 oldsmobile, and it's running hot, is it fan motor or the heating sensor?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 14,036 Answers

FIRST SCAN CAR TO SEE IF COOLANT TEMPERATURE SENSOR IS WORKING SEE IF YOU GETTING ECTS CODES. IF NOT CHECK THE COOLING FAN FUSE AND RELAY.IF BOTH GOOD HOTWIRE THE COOLING FAN USING JUMPER WIRES TO CAR BATTERY.IF FAN DONT WORK REPLACE THE COOLING FAN MOTOR ITS FAULTY.

Posted on May 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 Buick Regal Running Hot


have a compression test done to check for head gasket/ cracked heads problem
have a flow test done to check pon radiator condition
was the coolant temp sensor replaced or was it the single gauge sender unit replaced

May 09, 2017 | 1996 Buick Regal Olympic Gold

1 Answer

I have a 1995 camry and the rad fans aren't working! any suggestion


Hi Jan, Open the bonnet (hood) and have a look for the fan fuses and fan relays. I believe either a fuse has blown, or a relay is not working. A simple way to test the circuit is to disconnect the electrical connection to the sensor at the bottom of the radiator. With the connector left unplugged, turn on the ignition and the fan should start immediately. If it does not, the problem is with the relay or the fuse. Regards John

May 10, 2012 | 1995 Toyota Camry

1 Answer

Engine runs hot after a few minutes of running the car


That is very vague. Have you checked the radiator, and when it is hot does the electric cooling fan come on? Try running the A/C and see if the cooling fan comes on. Does it run hot on the highway or just in city traffic? I need some more details to try and narrow it down. There are many things it could be. Low coolant, stuck thermostat, air in the cooling system, bad fan motor, fan motor relay (also known as fan switch), or temp sensor.

Jul 17, 2011 | 2000 Oldsmobile Intrigue

1 Answer

I have oldsmobile alero 1999, problem is that the engineer idles after running for an hour or when engine is getting hot


SOUND LIKE ENGINE COOLANT FANS NOT RUNNING.CHECK TO SEE IF COOLANT FANS RUNNING WHEN ENGINE START OVERHEATING.IF NO CHECK COOLANT FANS FUSE AND RELAYS.IF ALL IS GOOD.HOTWIRE COOLANT FANS TO MAKE SURE THEY ARE WORKING.IF NO REPLACE FAN MOTOR.IF FAN RUN WHEN YOU HOT WIRE IT.THE COOLANT TEMPERATURE SENSOR FAULTY ARE THE PCM FAULTY YOU CAN USE A SCANNER TO CHECK THEM FOR FAULT CODE.IF EVERYTHING GOOD SO FAR.REPLACE THERMOSTAT AND RADIATOR PRESSURE CAP FLUSH ENGINE BLOCK AND RADIATOR.CHECK RADIATOR AND CONDENSOR AIR CORES MAKE THEY NOT STOPPED UP WITH LEAVES AND OTHER DEBRIS THAT WILL BLOCK OFF AIR FLOW THROUGH THE FRONT GRILLE RADIATOR CORES.ALSO CHECK WATER PUMP WEEP HOLE IF ITS LEAKING WATER PUMP NEEDS REPLACING.

Nov 05, 2010 | 1999 Oldsmobile Alero

2 Answers

1995 Monte carlo both fans don't work and it runs hot help put new thermostat in and fan motor now what


Try unplugging the coolant temperature sensor and see if the fans come on.If they do then the coolant temp sensor needs to replaced. The sensor is located in the intake manifold by the upper radiator hose.Here is a link to provide a general location http://www.greatautohelp.com/sensor-location/3400.html

May 28, 2010 | 1995 Chevrolet Monte Carlo

2 Answers

I have a 95 chrysler new yorker the fans faulty.


try checking fan motor to see if is good take it of and use battery to make them work if that dont help motor is bad

Apr 08, 2010 | 1995 Chrysler New Yorker

2 Answers

Electrical fans wont kick on, car will run hot if they dont kick in..Tried changing fuses still wont come on..


The fans have a seperate temperature sensor either in the radiator or the block. Follow the fan wires to locate this sensor and unplug the sensor and with the key on touch the wires together. If the sending unit is bad the fans will come on. If the sending unit works the fan motor is bad.

Jan 19, 2010 | 1995 Chevrolet Impala

1 Answer

Radiator cooling fan


check coolant first .if all good .hot wire the fan make sure the electric fan motor is operating.if runs when hot wire.replace the relay and coolant temperature sensor.if fan dont run.when hot wire.replace the fan motor.

May 30, 2009 | 1999 Oldsmobile Alero

1 Answer

Radiator cooling fans don't turn, car heats up! Where is the switch that turns those fan on? Thanks/Bob


on most cars , there is a temp sensor screwed into the radiator. When the coolant reaches a certain temprature , the contact inside the sensor closes , and completes the circut for the fan relay.
It should have two wire terminals , pull the wires off , and jump the posts with a short piece of wire or metal. Fan should start . ( Keys must be in the run postition , or engine running when you do this. )

If the fan goes , that means the sensor is not working. If the fan does not go , than it's something else. Perhaps the relay , or the fan motor itself is no good.

If your car has A/C , the fans should turn on when the A/C is turned on.

If you start the engine cold , it should not overheat for quite a while.. If it overheats within 5 min of driving , than your thermostat is probly cooked.

Most cars cooling fans do not run most of the time , airflow through the rad while driving is enough.
The fans would only come on while siting still ( idleing ) for a while.

Good luck : let me know how it goes.

May 05, 2009 | 1995 Oldsmobile Ninety Eight

1 Answer

Runs hot replaced radiator fan motor and heat sensor, fan still won't run


I own a 1997 caravan and had the same problem, turns out there is a fan relay switch mounted on the inside of the drivers side frame rail under the battery tray.. cost me 80.00 hope this helps..

Apr 21, 2009 | 1992 Dodge Caravan

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

253 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...