Question about 2001 Mitsubishi Eclipse

2 Answers

Runs but wont move

Driving down the interstate and just quit accelerating, engine light came on and gas peddle did no good kept runnning, no smoke, restarted just couldnt get it to move,

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Sounds like your transmission shot.... I had my tranmission flused few months later all the light in my dash board came on...car lost power...I pull over to the side of the raod..the car started up fine and reved up fine...but the car would not move.

If you get your transmission fixed...you better get the transmission fuild from the dealership only. Advance Auto, O Relily fluids will not work.... I found out the hard way..

Posted on May 08, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 149 Answers

Your peddles r bad

Posted on May 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I was driving down the interstate at 80 in my 2002 Monte Carlo when the rpms drop and I lose acceleration. The gas pedal got really lose as well. It's not starting either.


Sounds like your throttle cable has came off or broken. Have someone sit in the drivers seat and press the accelerator repeatedly (with engine off) while you look in the engine compartment for movement. if nothing moves your cable is broken and you will need a new one. as for not starting, the cable could be binding the throttle body, but that's only if the engine cranks over. if the engine wont even turn over, you may have a bad alternator. Worst case scenario though is that you have broken your timing belt and basically scrapped the motor. I would highly recommend a tow to a mechanic. Hope this helps

Nov 11, 2015 | Cars & Trucks

1 Answer

Why are so many trouble diagnostic codes being thrown


sounds like you speed sensor and your throttle poistion sensor

Sep 02, 2014 | Cars & Trucks

1 Answer

2006 chrysler sebring/check engine light stays on car jerks while driving


Sounds like a basic miss or fuel problem.
Have you had the computer scanned for trouble codes ?

Apr 09, 2013 | 2000 Mitsubishi Galant

1 Answer

2007 ford fusion starts to bogg down around 40 mph with heavier acceleration. No issues from take off and rides smooth otherwise


If the check engine light is not on, it could be low fuel pressure and/or a dirty fuel filter.
On this model the fuel filter is in the gas tank.

Jan 14, 2013 | 2007 Ford Fusion I4 SEL Sedan

1 Answer

Cold outside, on interstate my Intrigue started acting sluggish. couldn't get to 70mph. was only going 50mph. Service engine soon light was flashing and kept flashing the whole rest of the drive even...


sounds like you have moisture in the gas tank. there's plenty on the market that will take moisture out of gas tanks. Home Depot, Menards, etc.

Kdog

Dec 29, 2010 | 2000 Oldsmobile Intrigue

2 Answers

Engine kept runnning car stopped moving


change your clush plate or gear if its in place

May 04, 2010 | 2001 Mitsubishi Eclipse

1 Answer

94 Lexus GS300 Amber Oil Light Went On and Off


this light indicate tha oil level is low in engine , make a service oil ,or check the level, this light have an sender in oil pan and could be dirty

Feb 23, 2009 | 1999 Lexus Gs 300

Not finding what you are looking for?
2001 Mitsubishi Eclipse Logo

241 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...