Question about 2002 Mercury Villager

2 Answers

2002 mecury villager stalls at low speeds or on acceleration from a stop. Replaced speed sensor and this was not the issue, but diagnostic code says that it still is. Must turn car off and start it again to fix issue and drive again. Please help! Confused.... Mechanic is baffled!

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Have mechanic check distributor if it has one-specifically the bearings. My 1999 Mercury has a distributor and was acting similar to yours. Would start every time no problem but then skip and stall especially if put into gear or was worse even in neutral if gas pedal pushed. Dealer clueless. I found bearings issue myself. Every time distributor shaft went out of balance is when skipping would start. New distributor and was purring like a kitten again.

Posted on Feb 21, 2012

First- Codes do not tell you what to fix. You already found that out.
Second-Logically,why would a speed sensor on a trans cause a stall. The speed sensors and there are several.produce outputs on shaft and drum speeds in the trans. Those signals are part of the PCM input strategy for shift points. At low speed,your not shifting,your stalling.
There is no such thing as baffled. Lacks your vehicles system knowledge, maybe!
Do you have a clean fuel filter?
Do you have fuel pressure during the stall?
Do you have fairly new spark plugs?
What does the data for the Throttle Position Sensor,Mass Air Flow Sensor,Egr Valve Etc look like before the stall.
Got vacuum leaks?

Now --you either need to leave the vehicle at a shop,until they repair it
-Find a good tech at another shop that knows your vehicle
Or get the manuals and start on a life long persuit of auto technolgy. I like the last one.

Posted on May 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why did my speedometer stop working and within minutes my 02 Cadillac Sts stalled and would barely accelerate?


The speedometer and odometer gets a signal from the speed sensor in the side of the transmission where the speedo cable once was.
The problem could be the speed sensor, or something in the wiring, or in the instrument cluster. Or it could be that the transmission is failing internally.

Feb 27, 2013 | 2002 Cadillac Sts

1 Answer

- stumbles when stopped and accelerating at low speeds


ENGINE HESITATES WHILE ACCELERATION
LOSS OF ACCELERATION

It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.
There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------
Jerks and Hesitates During Acceleration?
http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html
-----------
Loss of acceleration?
http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html
---------
Headlights flickering and car hesitates to start?
http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html
--------
How exactly the Vehicles Accelerator Cable works?
http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html
-------------
How exactly Vehicles Accelerator Pump Diaphragm Works?
http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html
--------
2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?
http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html
---------
2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?
http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html
---------
Wheel hop under hard acceleration?
http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html
--------
2009 Chevy impala accelerator pedal sensor?
http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html
---------
Nissan Pathfinder stalls and bucks on Acceleration?
http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html
--------
Acceleration lag problem?
http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html
-------------
These details will help.
Thanks.

Dec 07, 2012 | Cars & Trucks

1 Answer

Buick 2002 lesabre- stalls 1 or 2 a week and starts up.nothing shows in diagnostic code. stalls when slowed or stopped


Have you had it to a shop that has a professional type scan tool that can view engine sensor data parameters ? Do you know what those are ? Idle air control counts , mass air flow sensor data , MAP sensor , TPS - throttle position sensor , crankshaft position sensors , Cam sensors , engine coolant temp , intake air temp etc......

Apr 18, 2017 | 2002 Buick LeSabre

2 Answers

Please help, I have a 2006 nissan altima bought used 56000 miles. Been having stalling issues for a while now at low speeds, making slow turns or just coming to a stop. I have replaced the fusible link,...


sound like you have a distributor that is going bad , the carnk sensor is build into the distributor and sometimes when that gi bad it will cause the car to stall but will not set a code A couple of things here. First, the distributor is probably bad. Second, I would clean the throttle body and check the throttle position sensor. I think the idle air control valve is dirty along with the throttle body so I would clean them first and that should correct the idle thing. The distributor should correct the bucking problem. Now, make sure you have a fresh tuneup like plugs, wires, cap and fuel filter along with a new PCV.

Nov 05, 2011 | 2006 Nissan Altima

4 Answers

My 2002 Lincoln LS v6 Lost Engine Power,Traction Control Light was flashing & ABS light Came on! ANY IDEA?


Had the same problem with my 2002 Lincoln LS, it was a bad wheel speed sensor. The right front wheel bearing had some play in it, so I had the hub assembly replaced. The hub assembly comes with a new wheel speed sensor attached. After I replaced the hub assmbly with sensor, the ABS and Traction Control lights went off. No problem since!

Jun 13, 2011 | 2002 Lincoln LS

1 Answer

At low speed from deceleration or accelerating from a stop the car runs roughly and has stalled several times. 2002 3.8L 85 k miles auto trans. My code scanner shows no faults. No check engine light.


Sounds like a faulty cam sensor. ford is known for this to happen. This does not show up because it is a mechanically working peice. get it checked and replaced it necessary.

Jan 12, 2011 | 2002 Ford Mustang

1 Answer

Cam shaft pos sencer code. replaced both sencers. still same code. wiring & plugs look good. car wont idle & stalls


Now you know that codes ,do not tell you what is wrong and what to replace
Get a diagnostic chart for your vehicle,and troubleshoot the area with issues.
TPS Sensor,Throttle Speed Sensor Etc, whatever applies to your vehicle

Apr 29, 2010 | 2002 Honda CR-V

2 Answers

2002 miata ls driving @ 80 mph engine stalls dies let set for 10min restarts and runs fine gives obd2 code p0340 camshaft sensor


I have had the same problem on my 2000 Miata. Turned our it needed a new cam sensor. Had it replaced 9 months ago and now it has occurred again. They are replacing the cam sensor again.

Mar 18, 2009 | 2000 Mazda MX-5 Miata

3 Answers

Synchronization problem between accelerator and transmission at low/no speed


disconnect the egr valve and try it at low speed if you give some gas egr open to mush to mush air not enought gas create hesitation before changing the egr just disconnect it and try hope it FIXYA our problem thanks pierre

Jul 04, 2008 | 2002 Chevrolet Venture Passanger

4 Answers

Stalling


I have a 2000 Sonata V6 with the same issue (low speed intermittent stalling). Finally found a Hyundai dealer that knew about the issue and replaced the CRANK SENSOR. This has dramatically reduced the stalling but it still occurs very rarely. I think the engine idle speed of my car is abnormally low and this may be a secondary issue not completely related.

Jun 07, 2008 | 2000 Hyundai Sonata

Not finding what you are looking for?
2002 Mercury Villager Logo

286 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

fordexpert

Level 3 Expert

5495 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...