Question about 1999 Chrysler LHS

1 Answer

Temp goes to HOT, seems like it's over heating.

Temp guage goes to HOT, seems like it's over heating. Found green gu comin out of the coolant. Fan assembly ain't turning.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 196 Answers

Flush the radiatior and replace the fan sensor switch do not mix coolents use what the car calls for in owners manal mixing will gel and miss up your car coolent system

Posted on May 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Temp. guage indicates overheat 10 mins. from startup


Hi Reggie, I'm glad to help. TWO things I want you to check. ONE: You have changed out a lot of stuff, so you may have air trapped in the cooling system, you'll need to remove the radiator cap and let it run until your at operating temperture, while watching to make sure it doesn't overheat on your of-course. If after running the engine say 30 minutes and topping off the coolant if needed, it still runs hot. Move on to: TWO: If you have the electric fan, some do, some don't. If it is electric make sure the fan is coming on, if it doesn't come on then you have found your problem, replace the fan assembly. Hope this helps and have an awesome day Reggie!

Jan 09, 2014 | 1996 Jeep Grand Cherokee

2 Answers

No heat blowing from vents


1st check fuse to the heater
2nd check relay
3rd the filament wire of the heater

Dec 09, 2013 | Volkswagen Jetta Cars & Trucks

1 Answer

2000 acura tl coolant fan after fluid change


New thermostat, installed, saw, new coolant made a little mess filling reservoir, (normal) checked fan fuse for some reason, and condenser fan fuse (xxx ?:), and temp guage, is slightly lower on gauge (than normal?) (disconnected xxxx? quit? a bit? to get to thermosta?.t no dash warning lights have a feeling I popped a relay.

Answer:

ok, you did a coolant service with STAT,

and it failed.

tell us what works right and wrong, symptoms only.

over heating? parked, (fan never comes on)? as it hits 225F?

under heating? ( fan stuck on , up North can cause huge cold engine)

dash gauge stuck low. (thermostat wrong heat range 180f is best. see FSM for spec. on this temp. spec..

Dash guage varies.? oddly (air in system)?

Dash gauge too high.? (Stat put in upside-down or bleed hole (jiggle) not UP side. higher side of mount , trapping air.)

Does something wrong happen only driving?

leaks?

does cap on rad hold 12-14psi pressure, hot.?

if car has fan belts, are they tight? (for sure water pump does)

Nov 19, 2013 | 1994 Honda Civic

1 Answer

Location of engine coolant temp sensor on 1995 saturn sl


On my daughters sl2 it is on the driver side. A note though, there are 2. Crazy i know, one above the other. One goes to the guage and one to the computer. When my son had the car it would not stay running at idol, had to rev the engine to keep it going. The engine would shake hard too, what through me was the guage in the care read fine but once i found the sensors the one looked fine the other looked like it split in half. Hope that helps

Jul 06, 2012 | 1995 Saturn Sl

1 Answer

1988 BMW 318i temperature guage flickers between normal temp. through to max temp. Most of the time the guage is 3/4 to Hot. Main fan seems a little loose when hot - not tightening up. Coolant level OK no...


It could be the impellor wearing out on the water pump, though I have not heard of this issue in your make of car, I have seen it first hand in other makes. The thermostat may not be opening up all the way, flow restriction,. The coolant temperture sensor could be going out, and the gauge in the dash could be going out. You could have flow restrictions else where in the engine. Have you ever had the engine flushed? these are the things that I can think of that would make your engine run hotter than normal.

Nov 18, 2010 | 1997 BMW 318

2 Answers

Over heating on gauge, both fans on rad.


I would say check your coolant level, and change your thermostat. And see if it is high fans or low fans when they come on. There is a fan control relay down on the drivers side frame right under the air box that goes bad too if your fans arent working quite right to check if all else.

Jul 25, 2010 | 1999 Dodge Caravan

2 Answers

Car overheating


You have a bad radiator fan. Check to see that your fan comes on when temp goes past half way, about 3/4.

Aug 11, 2009 | 2001 Nissan Sentra

1 Answer

Temp Gauge Reads Hot all the time and i have heat


as soon as you turn it on after it has been shut off for how long? you could have a bad sensor. if you have a sohc (single overhead cam) engine you have a coolant temp sensor. if you have a dohc (double overhead cam) engine you have a cylinder head temp sensor. either way you will need to start with everything cooled off, drain the coolant, remove and replace the sensor. for the sohc engine you have to remove the ignition coil to get to the sensor, for the dohc you have to remove the alternator. in both engines you are supposed to torque the bolts that hold the sensor in place to 89 in-lbs, tight enough to not have a coolant leak at that point, and not so tight that you stretch the bolts or break them off in the block. if you still have a problem after you replace the sensor then you probably have a bad water pump. hope that helps.

May 26, 2009 | 2000 Ford Focus

1 Answer

GUAGE SHOWS HOT


is it ever low in coolant? i agree with emissionwiz sounds like your getting airpockets do you have heat when this starts?

Nov 09, 2008 | 2002 Chevrolet Avalanche

Not finding what you are looking for?
1999 Chrysler LHS Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8531 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...