Question about 1995 Ford Explorer

1 Answer

I started my explorer yesterday and noticed a sort of hissing sound. Obviously it is more noticable when I am sitting idle. It sounds as if it is comming from under the hood. I just had a new radiator put in a little over a week ago. But the sound does not seem to be comming from there.

Posted by on

Ad

1 Answer

Check for vacuum leaks. Follow all small hoses with engine running

Posted on May 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2006 H3 and I just noticed red fluid leaking from the front end yesterday but today there is no leak. I did hear a strange hissing or whistling like sound when I accelerated. Is this somethin


Most likely one of the transmission cooling lines which go from the transmission to the side of one or the radiator expansion tanks has rusted through. It is making that noise because you are driving it with no transmission fluid in it. If you continue to drive it you will break the trasmission.

Mar 18, 2014 | 2006 Hummer H3

1 Answer

Engine idles up about 1000rpms when warm sitting at idle whether in gear or not


it sounds like a vacume leak. pop the hood, start your vehicle and listen for a hissing sound.

Oct 29, 2013 | 2001 Toyota Tacoma

1 Answer

Hissing noise from under the hood- passenger side.


loose hose clamps hole in one of the vac lines it seems to only hiss when its under pressure

Jan 26, 2013 | 2004 Pontiac Grand Am

1 Answer

2001 sable..while idling i smelled rubber burning, then a loud hummm from the upper right hand side of the engine (as you sit behind the wheel) and then smoke only from that area..noticed some...


It sounds like you may have a problem belt or some kind of a problem with something turns on the belt Ican;t say for sure with seeing it but thats what i would look at first see if it looks melted or other wise distorted do this when engine is off

Nov 19, 2010 | 2001 Mercury Sable

1 Answer

I have a 2004 ford explorer 4x4, alternator/battery/?


voltage regulator in alt gone bad..will strain battery

Jun 08, 2010 | 1998 Ford Explorer

1 Answer

Check engine light and power loss


Air flow meter sounds like your problem.

May 27, 2009 | 2001 Audi A4

1 Answer

Bad sounds, bad smells from 94 ford explorer


Sounds like you may have a vacuum line off or ruptured going to the EGR valve. The burning smell is probably the catalytic converter. When the engine runs rich you will get a sulfur smell that smells sort of like rotten eggs.

Mar 15, 2009 | 1994 Ford Explorer Limited

1 Answer

Air around break petal


It sounds as though the diaphragm on your vacuum assist has ruptured. This will cause a hissing sound and less brake you may also notice a change in the engine idle speed or a rough idle until the hissing stops.

Feb 22, 2009 | 1992 Ford Explorer

Not finding what you are looking for?
1995 Ford Explorer Logo

Related Topics:

97 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...