Question about 1989 Chevrolet K1500

1 Answer

Speedometer not working all gauges work 700r4 trans ohms r good have ac voltage at cluster changed cluster when in air in od doing about 60mph speedo says 10mph

Posted by on

  • 1 more comment 
  • tcampbell198 May 03, 2010

    yes it is a transmission out of a 91 camaro the gear on the tailshaft is good replaced the speed sensor and gear still only goes up to 10 mph vhen in air at high speed replaced cluster but not sure good

  • tcampbell198 May 03, 2010

    the speed sensor is from the camaro it is gear driven the 1500 has magnetic style gears r good speed sensors read the same the cluster does the same with different sensors

  • Zaraki May 11, 2010

    If there is an electronic speed sensor, have you removed it from the extension housing on the transmission and checked the drive gear for damage?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 834 Answers

Is the speed sensor that you are using the original one, or is it from the Camaro, or is it new for an 89 K1500?

The worm gear inside of the transmission on the output shaft that drives the speed sensor gear is not damaged?

No matter what speed sensor is installed the speedometer still reads the same?

Posted on May 03, 2010

  • Zaraki May 03, 2010

    If the K1500 used a magnetic pick-up type sensor with a tone ring, and the speed sensor from the Camaro is gear driven, then the two different types of sensors might not generate the same signal pulse.



    The next thing to do would be to determine if the two sensors actually do generate the same signal pulse.



    If the two sensors do generate the same exact pulse then there is a problem with the speedometer.



    If the two sensors do not generate the same signal pulse, then either the speed sensor will have to be changed to match the speedometer, or the speedometer will have to be re-calibrated to match the speed sensor. I do know that OBD-II systems are very easy to re-calibrate because I have done so myself, but I am not sure how easy it is to re-calibrate your vehicle.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2013 ford ranger speedo cluster dead


Check for shorted wire for OD switch in steering column if you have OD, common issue

Apr 14, 2016 | Ford Cars & Trucks

1 Answer

Speedometer not working


The speedometer is electronic. There is no speedo cable. It could either be the speedometer sensor located in the transmission, or the instrument cluster. Is your speedometer a gauge, or an LED display? The gauge can be replaced, but the entire dash cluster will have to be checked if it is an LED display.

Jan 26, 2013 | 1992 Oldsmobile Toronado

1 Answer

Gas gauge ground problem or tank sensor, speedo won't work,electronic,


The common fault is that the fuel level sending unit is defective inside the gas tank.

Oct 26, 2012 | 1990 GMC Suburban

2 Answers

2003 VW jetta speedometer stopped working and the gas gauge started fluxuating as car turns etc. I replaced 2 speed sensors, one on top of trans with no pigtail just connector, Didnt solve problem. I...


The speed sensor that is under the trans. mount on the driver side sends the shift points to the computer telling it at what point to shift. The sensor that actually controls your speedometer is in the back near the firewall. It is tall and should have a silver heat shield over it. However, the problem that you have described sounds more like an electrical short or a wire grounding out somewhere. I would check for wires getting pinched under the steering column in the dash since things quit working when you are turning. Also check the wiring behind the instrument cluster. Elecrical problems can sometimes be complex and hard to find but with some due diligence they can be solved. Hope this helps.

Dec 21, 2011 | 2003 Volkswagen Jetta TDI

1 Answer

My speedometer wont move. its stuck 10mhp idk what to do? its a chevy 1500


the speedo cable is probably broken. pull the cable out of the trans and gauge cluster and use a drill to SLOWLY spin it. make sure the other end spins if it doesent replace the cable if it does make sure the spedo gear on the trans side is not chewed up. if that is good replace the speed cluster withe a new one or have it fixed at a shop.

Dec 23, 2010 | 1988 Chevrolet C1500

3 Answers

1997 Buick LeSabre speedometer, eratic operation reads faster than speed actually going, analog electronic unit. How do I repair and access it.


A reliable fix would be to send the cluster out for repair, if in fact the problem lies in the speedo head. There is a bulletin for this car that states that at 20mph the speedo can be + or - 4 mph inaccurate, and its normal operation.
I suggest first having the alternator tested. The VSS on this car produces an AC voltage signal. The alternator also produces AC voltage, which is converted to DC before it is output to the cars electrical system. If any AC voltage is leaking from the alternator, it can interfere with the VSS signal, and cause the speedo to read higher, or even show that the car is moving when sitting still.

Aug 13, 2010 | Buick LeSabre Cars & Trucks

1 Answer

1997 Jetta GLX speedometer and odometer


If your cluster gauges work ok but your speedo does not work once and awhile, its time to replace your cluster panel, this is a common problem in the MK3's I had to change mine twice in the MK3 vdubs I own. Its fairly easy to replace, I just picked up a used one at a scrap yard. The cluster panel is all once peace you can not swap out gauages, you can try but you will do more damage then its worth. Good luck

vdubs 4-ever

Jul 17, 2009 | 1997 Volkswagen Jetta

1 Answer

Gauges not working properly


Hello, Last year General Motors lost a lawsuit about the instrument panels in 2002 to 2005 trucks. The following website contains all the information about this lawsuit settlement.
http://www.speedometersettlement.com/
This impacts the entire gauge cluster in your vehicle.
I have the same year and model as yours and my speedo is never accurate and the tach always read 6000.
The issue is the metal bearings that the gauge meter movements use. The bearings are getting dry which impedes the meter movement.

Apr 01, 2009 | 2003 Chevrolet Suburban 1500

1 Answer

Instument Guages


well the issue is youe enitre gauge cluster i do understand that your speedometer is working but it is a cable speedometer not electronic like everything else in the gauge cluster so first i would recomend checking the voltage getting to your gauge cluster then just replace the guagecluster they are really cheap i a salvage and not hard to install at all but the cluster itself is not very comon to go out so make sure you check voltage to it first i wouldnt want you to go through buying and replaceing the cluster and that not fix it

Jan 20, 2009 | 1991 Mitsubishi Eclipse

1 Answer

Speedometer doesn't work in my 98 Mits Galant and only warm air.


Well the speedo problem could well be behind the actual speedo gauge. Theres a long square shapped plastic piece on the end of the cable the fits in to the back of the gauge, as it turns it makes the hand on the dial read the speed, In most cases the plastic bit breaks away from the cable which will make the speedo read zero.You will have to get another speedo cable and replace it the same route as your original one.You have to take off the dash surround to get the gauge cluster out for a start to see if its broken at that end.

Jan 20, 2009 | 1998 Mitsubishi Galant

Not finding what you are looking for?
Cars & Trucks Logo

1,127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...