Question about 1994 Chevrolet S-10

1 Answer

I have a 1994 chevy s-10 4x4 blazer with the 4L60E tranny. It shifts good at start up but when it gets warmed up it slips into neutral and I have evn had fluid blow out of the breather tube. Any solutions?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Chevrolet Master
  • 753 Answers

Transmission needs to come out and be overhauled.Clutch disc material worn off or a seal problem that when the fluid gets thinner once it is hot it blows by enough to disengage the clutch packs.

Posted on May 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 1999 Chevy Blazer shift really hard into second gear without the RPM's increasing like the tranny's slipping?


Shifting hard broken modulator valve on the trany itself normally there a vacuum line connected to it

Mar 13, 2015 | 1999 Chevrolet Blazer

1 Answer

I own a 1998 Chevy Blazer 4wd that is on its 3rd transmission and I'm having the same issue where when shifting from 2nd to 3rd gear it's slipping badly my rpm's rev up to 3500 and I have to take my foot...


this is a known issue with the gm 4L60E transmission. the valve body in transmission causes this. if it is wore, then less fluid is sent to shift selonoids. thus causing torque convertor not to lock up, and this causes slipping. if it slips 2 consecutive trips then the transmission detects this and should turn on check engine light. ( p1870 ). you can see if the tcc solinoid is bad. but if not its usually the valve body in tranny.

Dec 15, 2010 | 1998 Chevrolet Blazer

4 Answers

I have a 1994 S10 Blazer with 4.3 Vortec engine. My 4X4 is not working properly. It is sort of intermittently working. When I depress the 4X4 LO position on the switch, there is no indication of anything...


If I'm not mistaken, there should be a module or relay. Not for sure where it's at. Heard of these going out and not being able to switch into 4 wheel drive. I know on a 200'? Ford F-250 they have a motor on the side of the transfer case. That switches it into 4 wheel. Signal from 4x4 switch is sent to module then to the motor that engages the transfer case. Hope this makes sense. Hope this helps.

Feb 24, 2010 | 1994 Chevrolet S-10 Blazer

1 Answer

Tranny will not down shift


tranny shift cable thats hook up below the throttle cable on carb needs adjusted

Aug 16, 2009 | 1994 Chevrolet K1500

1 Answer

4L60E won't shift to 3rd on 1993 Chevy Blazer 1500


Sounds like you have a bad shift solenoid. Not sure if the Chevys are a solenoid pack, or seperate, but it will need to be replaced.

Jun 02, 2009 | 1993 Chevrolet K1500

1 Answer

4L60E won't shift to 3rd on 1993 Chevy Blazer


Hello;
It sounds as though your trans is going out. How is reverse? If reverse is real strong then you may just have a solenoid going out. Drop the pan and change the oil and filter if you are comfortable doing that. Inspect the pan for metal shavings and contaminents. Otherwise it would need to go to a shop for repair.
Thanks;
Rich
RPM Northwest

Jun 01, 2009 | 1993 Chevrolet S-10 Blazer

2 Answers

Chevy transmission hangs in 2nd,


It just holds 2nd forever. Is the 1-2 shift point high?

Mar 24, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

1994 K1500 CHEVEROLET BLAZER wont move in any gear


Hello;
Your trans is the 4L60E. A really good trans but they do go out. I would start by pulling the oil pan on the trans and seeing if anything is there. The obvious is a large debris field showing the trans is in need of a rebuild. Specialized tools are required for these units and not recommended for a novice. I would also look to see if the shift linkage has broke inside the case. Have someone step on the brake while you look under the trans and shift the gear shift through the entire range. I have seen the cables brake in the casing and have also seen the rooster come come loose, break, and disengage. hope this helps.
Thanks;
Rich
RPM Northwest

Mar 21, 2009 | 1994 Chevrolet K1500

1 Answer

1995 Chevy S10 Blazer


IT IS NOT GOING INTO NEUTRAL. IT HAS LOST THE DIRECT DRIVE CLUTCH PACK INTERNALLY. SOUNDS LIKE IT IS HIGH MILEAGE. IF SO AND YOU CHANGE THE FLUID IT CLEANS UP ALL THE VARNISH IN THE TRANNY AND THE END RESULT IS TRANNY MALFUNCTIONS DEPENDING ON WHAT KIND OF CARE IT HAS HAD IN THE PAST.

Jan 24, 2009 | 1994 Chevrolet S-10 Blazer

2 Answers

Replacing a 4L60E with a 700R4?


Not with good results, the 4L60E is run by your ecm, the 700R4 while looking close to the same does not relie on your ecm for commands,it relies on a cable to regulate your line pressure.

Jan 01, 2009 | 1994 Chevrolet K1500

Not finding what you are looking for?
1994 Chevrolet S-10 Logo

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...